]> git.pld-linux.org Git - packages/Glide_V3-DRI.git/blob - Glide_V3-DRI.spec
- buildrequires XFree86-devel
[packages/Glide_V3-DRI.git] / Glide_V3-DRI.spec
1 %define snapdate 20001102
2 Summary:        Glide runtime for 3Dfx Voodoo Banshee and Voodoo3 boards
3 Name:           Glide_V3-DRI
4 Version:        3.10
5 Release:        20001102.1
6 Group:          Libraries
7 Copyright:      3dfx Glide General Public License, 3Dfx Interactive Inc.
8 URL:            http://www.3dfx.com     
9 Source:         Glide3-CVS-%{snapdate}.tar.bz2
10 Vendor:         3dfx Interactive Inc.
11 Icon:           3dfx.gif
12 BuildRequires:  XFree86-devel
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description 
16 This library allows the user to use a 3dfx Interactive Voodoo Banshee
17 or Voodoo3 card under Linux with DRI support. The source support DRI
18 or non-DRI versions of Glide.
19
20 %package devel
21 Summary:        Development headers for Glide 3.x
22 Group:          Development/Libraries
23 Requires:       %{name} = %{version}
24
25 %description devel
26 This package includes the headers files, documentation, and test files
27 necessary for developing applications that use the 3Dfx Interactive
28 Voodoo Banshe or Voodoo3 cards.
29
30 %package static
31 Summary:        Static library Glide 3.x
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}
34
35 %description static
36 This package includes the static Glide3 library.
37
38 %prep
39 %setup -q -n Glide3
40
41 %build
42 mv chores.3dfx chores.3dfx.bak
43 echo "#!/bin/bash" > chores.3dfx
44 cat chores.3dfx.bak >> chores.3dfx
45 chmod 755 chores.3dfx
46
47 CFLAGS="$RPM_OPT_FLAGS"
48 CXXFLAGS="$RPM_OPT_FLAGS"
49 GLIDE_DEBUG_GCFLAGS="$RPM_OPT_FLAGS"
50 export CFLAGS CXXFLAGS GLIDE_DEBUG_GCFLAGS
51 mv -f swlibs/include/make/makefile.autoconf.bottom swlibs/include/make/makefile.autoconf.bottom.bak
52 sed "s,GLIDE_DEBUG_GCFLAGS = -O6 -m486,GLIDE_DEBUG_GCFLAGS = $RPM_OPT_FLAGS -I/usr/X11R6/include," swlibs/include/make/makefile.autoconf.bottom.bak > swlibs/include/make/makefile.autoconf.bottom
53 ./chores.3dfx \
54         --clean \
55         --generate \
56         --configure="--enable-fx-dri-build --enable-fx-glide-hw=h3" \
57         --build
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT%{_examplesdir}/glide3/tests
62
63 make -C build -f makefile.autoconf install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 ln -s libglide3.so.*.*.* $RPM_BUILD_ROOT%{_libdir}/libglide3x_V3.so
67 ln -s libglide3.so.*.*.* $RPM_BUILD_ROOT%{_libdir}/libglide3x.so
68
69 # Install the examples and their source, no binaries
70 install h3/glide3/tests/makefile.distrib $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/tests/makefile
71 install h3/glide3/tests/*.3df $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/tests
72 install h3/glide3/tests/test??.c $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/tests
73 install h3/glide3/tests/tldata.inc $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/tests
74 install h3/glide3/tests/tlib.[ch] $RPM_BUILD_ROOT%{_prefix}/src/examples/glide3/tests
75
76 gzip -9nf glide_license.txt
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc glide_license.txt.gz
87 %attr(755,root,root) %{_libdir}/libglide3.so.*.*.*
88 %attr(755,root,root) %{_libdir}/libglide3.so
89 %attr(755,root,root) %{_libdir}/libglide3x.so
90 %attr(755,root,root) %{_libdir}/libglide3x_V3.so
91
92 %files devel
93 %defattr(644,root,root,755)
94 #%doc docs/*.pdf
95 %{_prefix}/src/examples/glide3
96 %{_includedir}/glide3
97
98 %files static
99 %defattr(644,root,root,755)
100 %{_libdir}/lib*.a
This page took 0.073924 seconds and 3 git commands to generate.