]> git.pld-linux.org Git - packages/FusionSound.git/commitdiff
- added update patch to fix build with DirectFB 1.4.0
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 18 Nov 2010 18:40:42 +0000 (18:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- updated dirs for DirectFB 1.4.x

Changed files:
    FusionSound-update.patch -> 1.1
    FusionSound.spec -> 1.17

FusionSound-update.patch [new file with mode: 0644]
FusionSound.spec

diff --git a/FusionSound-update.patch b/FusionSound-update.patch
new file mode 100644 (file)
index 0000000..a379df8
--- /dev/null
@@ -0,0 +1,343 @@
+--- FusionSound-1.1.1/proxy/dispatcher/ifusionsound_dispatcher.c.orig  2010-11-18 08:56:24.443104966 +0100
++++ FusionSound-1.1.1/proxy/dispatcher/ifusionsound_dispatcher.c       2010-11-18 09:17:35.627103290 +0100
+@@ -207,7 +207,7 @@ Dispatch_GetDeviceDescription( IFusionSo
+      if (ret)
+           return ret;
+           
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     DR_OK, VOODOO_INSTANCE_NONE,
+                                     VMBT_DATA, sizeof(FSDeviceDescription), &desc,
+                                     VMBT_NONE );
+@@ -243,7 +243,7 @@ Dispatch_CreateBuffer( IFusionSound *thi
+           return ret;
+      }
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     DR_OK, instance,
+                                     VMBT_DATA, sizeof(FSBufferDescription), &dsc,
+                                     VMBT_NONE );
+@@ -279,7 +279,7 @@ Dispatch_CreateStream( IFusionSound *thi
+           return ret;
+      }
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     DR_OK, instance,
+                                     VMBT_DATA, sizeof(FSStreamDescription), &dsc,
+                                     VMBT_NONE );
+@@ -312,7 +312,7 @@ Dispatch_CreateMusicProvider( IFusionSou
+           return ret;
+      }
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     DR_OK, instance,
+                                     VMBT_NONE );
+ }
+@@ -328,7 +328,7 @@ Dispatch_GetMasterVolume( IFusionSound *
+      
+      ret = real->GetMasterVolume( real, &level );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_DATA, sizeof(float), &level, 
+                                     VMBT_NONE );
+@@ -350,7 +350,7 @@ Dispatch_SetMasterVolume( IFusionSound *
+      
+      ret = real->SetMasterVolume( real, level );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -366,7 +366,7 @@ Dispatch_GetLocalVolume( IFusionSound *t
+      
+      ret = real->GetLocalVolume( real, &level );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_DATA, sizeof(float), &level, 
+                                     VMBT_NONE );
+@@ -388,7 +388,7 @@ Dispatch_SetLocalVolume( IFusionSound *t
+      
+      ret = real->SetLocalVolume( real, level );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -403,7 +403,7 @@ Dispatch_Suspend( IFusionSound *thiz, IF
+      
+      ret = real->Suspend( real );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -418,7 +418,7 @@ Dispatch_Resume( IFusionSound *thiz, IFu
+      
+      ret = real->Resume( real );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+--- FusionSound-1.1.1/proxy/dispatcher/ifusionsoundbuffer_dispatcher.c.orig    2010-11-18 08:56:24.447102452 +0100
++++ FusionSound-1.1.1/proxy/dispatcher/ifusionsoundbuffer_dispatcher.c 2010-11-18 09:18:49.479101613 +0100
+@@ -186,7 +186,7 @@ Dispatch_GetDescription( IFusionSoundBuf
+      if (ret)
+           return ret;
+           
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     DR_OK, VOODOO_INSTANCE_NONE,
+                                     VMBT_DATA, sizeof(FSBufferDescription), &desc,
+                                     VMBT_NONE );
+@@ -208,7 +208,7 @@ Dispatch_SetPosition( IFusionSoundBuffer
+      
+      ret = real->SetPosition( real, position );
+           
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -250,7 +250,7 @@ Dispatch_Unlock( IFusionSoundBuffer *thi
+      
+      real->Unlock( real );
+      
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     DR_OK, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -282,7 +282,7 @@ Dispatch_Unlock_DPACK( IFusionSoundBuffe
+      
+      real->Unlock( real );
+      
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     DR_OK, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -303,7 +303,7 @@ Dispatch_Play( IFusionSoundBuffer *thiz,
+      
+      ret = real->Play( real, flags );
+      
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -318,7 +318,7 @@ Dispatch_Stop( IFusionSoundBuffer *thiz,
+      
+      ret = real->Stop( real );
+      
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -344,7 +344,7 @@ Dispatch_CreatePlayback( IFusionSoundBuf
+           return ret;
+      }
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     DR_OK, instance,
+                                     VMBT_NONE );
+ }
+--- FusionSound-1.1.1/proxy/dispatcher/ifusionsoundplayback_dispatcher.c.orig  2010-11-18 08:56:24.447102452 +0100
++++ FusionSound-1.1.1/proxy/dispatcher/ifusionsoundplayback_dispatcher.c       2010-11-18 09:19:48.907101613 +0100
+@@ -211,7 +211,7 @@ Dispatch_Start( IFusionSoundPlayback *th
+      
+      ret = real->Start( real, start, stop );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -226,7 +226,7 @@ Dispatch_Stop( IFusionSoundPlayback *thi
+      
+      ret = real->Stop( real );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -241,7 +241,7 @@ Dispatch_Continue( IFusionSoundPlayback
+      
+      ret = real->Continue( real );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -256,7 +256,7 @@ Dispatch_Wait( IFusionSoundPlayback *thi
+      
+      ret = real->Wait( real );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -275,7 +275,7 @@ Dispatch_GetStatus( IFusionSoundPlayback
+      if (ret)
+           return ret;
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     DR_OK, VOODOO_INSTANCE_NONE,
+                                     VMBT_INT, playing,
+                                     VMBT_INT, position,
+@@ -298,7 +298,7 @@ Dispatch_SetVolume( IFusionSoundPlayback
+      
+      ret = real->SetVolume( real, level );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -319,7 +319,7 @@ Dispatch_SetPan( IFusionSoundPlayback *t
+      
+      ret = real->SetPan( real, value );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -340,7 +340,7 @@ Dispatch_SetPitch( IFusionSoundPlayback
+      
+      ret = real->SetPitch( real, value );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -361,7 +361,7 @@ Dispatch_SetDirection( IFusionSoundPlayb
+      
+      ret = real->SetDirection( real, direction );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -384,7 +384,7 @@ Dispatch_SetDownmixLevels( IFusionSoundP
+      
+      ret = real->SetDownmixLevels( real, center, rear );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+--- FusionSound-1.1.1/proxy/dispatcher/ifusionsoundstream_dispatcher.c.orig    2010-11-18 08:56:24.475097423 +0100
++++ FusionSound-1.1.1/proxy/dispatcher/ifusionsoundstream_dispatcher.c 2010-11-18 09:20:43.463101613 +0100
+@@ -216,7 +216,7 @@ Dispatch_GetDescription( IFusionSoundStr
+      if (ret)
+           return ret;
+           
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     DR_OK, VOODOO_INSTANCE_NONE,
+                                     VMBT_DATA, sizeof(FSStreamDescription), &desc,
+                                     VMBT_NONE );
+@@ -240,7 +240,7 @@ Dispatch_Write( IFusionSoundStream *thiz
+      
+      ret = real->Write( real, samples, length );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -268,7 +268,7 @@ Dispatch_Write_DPACK( IFusionSoundStream
+      
+      ret = real->Write( real, samples, length );
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -289,7 +289,7 @@ Dispatch_Wait( IFusionSoundStream *thiz,
+      
+      ret = real->Wait( real, length );
+      
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -309,7 +309,7 @@ Dispatch_GetStatus( IFusionSoundStream *
+      ret = real->GetStatus( real, &filled, &total, &read_pos, &write_pos, &playing );
+      
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_INT, filled,
+                                     VMBT_INT, total,
+@@ -329,7 +329,7 @@ Dispatch_Flush( IFusionSoundStream *thiz
+      
+      ret = real->Flush( real );
+      
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -344,7 +344,7 @@ Dispatch_Drop( IFusionSoundStream *thiz,
+      
+      ret = real->Drop( real );
+      
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_NONE );
+ }
+@@ -360,7 +360,7 @@ Dispatch_GetPresentationDelay( IFusionSo
+      
+      ret = real->GetPresentationDelay( real, &delay );
+      
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     ret, VOODOO_INSTANCE_NONE,
+                                     VMBT_INT, delay,
+                                     VMBT_NONE );
+@@ -387,7 +387,7 @@ Dispatch_GetPlayback( IFusionSoundStream
+           return ret;
+      }
+-     return voodoo_manager_respond( manager, msg->header.serial,
++     return voodoo_manager_respond( manager, true, msg->header.serial,
+                                     DR_OK, instance,
+                                     VMBT_NONE );
+ }
+--- FusionSound-1.1.1/tools/fsproxy.c.orig     2010-11-18 08:56:24.839107480 +0100
++++ FusionSound-1.1.1/tools/fsproxy.c  2010-11-18 09:30:10.919102452 +0100
+@@ -162,7 +162,7 @@ server_run()
+      DirectResult  ret;
+      VoodooServer *server;
+-     ret = voodoo_server_create( &server );
++     ret = voodoo_server_create( NULL, 0, false, &server );
+      if (ret) {
+           D_ERROR( "Voodoo/Proxy: Could not create the server (%s)!\n", FusionSoundErrorString(ret) );
+           return ret;
index c1fc9eed1888aab299563dd611190ef99d492d11..bad4d37d4613479bbfaf1465c456bbcbf592cb8b 100644 (file)
@@ -11,8 +11,9 @@ Patch0:               %{name}-conf.patch
 Patch1:                %{name}-git.patch
 Patch2:                %{name}-leck.patch
 Patch3:                compile.patch
+Patch4:                %{name}-update.patch
 URL:           http://www.directfb.org/index.php?path=Platform/FusionSound
-BuildRequires: DirectFB-devel >= 1:1.2.0
+BuildRequires: DirectFB-devel >= 1:1.4.0
 # for examples
 BuildRequires: LiTE-devel >= 0.8.9
 BuildRequires: alsa-lib-devel >= 0.9
@@ -27,6 +28,8 @@ BuildRequires:        libvorbis-devel >= 1:1.0.0
 BuildRequires: pkgconfig >= 1:0.9
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                dfblibdir       %{_libdir}/directfb-1.4-5
+
 %description
 FusionSound supports multiple applications using Fusion IPC. It
 provides streams, static sound buffers and control over any number of
@@ -46,7 +49,7 @@ Summary:      Development files for the FusionSound
 Summary(pl.UTF-8):     Pliki rozwojowe dla FusionSound
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      DirectFB-devel >= 1:1.2.0
+Requires:      DirectFB-devel >= 1:1.4.0
 
 %description devel
 Header files required for development using FusionSound.
@@ -134,6 +137,7 @@ Moduł FusionSound dostarczający muzykę Ogg Vorbis.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__libtoolize}
@@ -171,26 +175,26 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/fsvolume
 %attr(755,root,root) %{_libdir}/libfusionsound-1.1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libfusionsound-1.1.so.1
-%dir %{_libdir}/directfb-1.2-0/interfaces/IFusionSound
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/interfaces/IFusionSound/libifusionsound.so
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/interfaces/IFusionSound/libifusionsound_dispatcher.so
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/interfaces/IFusionSound/libifusionsound_requestor.so
-%dir %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundBuffer
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundBuffer/libifusionsoundbuffer_dispatcher.so
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundBuffer/libifusionsoundbuffer_requestor.so
-%dir %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundMusicProvider
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundMusicProvider/libifusionsoundmusicprovider_playlist.so
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundMusicProvider/libifusionsoundmusicprovider_wave.so
-%dir %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundPlayback
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundPlayback/libifusionsoundplayback_dispatcher.so
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundPlayback/libifusionsoundplayback_requestor.so
-%dir %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundStream
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundStream/libifusionsoundstream_dispatcher.so
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundStream/libifusionsoundstream_requestor.so
-%dir %{_libdir}/directfb-1.2-0/snddrivers
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/snddrivers/libfusionsound_alsa.so
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/snddrivers/libfusionsound_oss.so
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/snddrivers/libfusionsound_wave.so
+%dir %{dfblibdir}/interfaces/IFusionSound
+%attr(755,root,root) %{dfblibdir}/interfaces/IFusionSound/libifusionsound.so
+%attr(755,root,root) %{dfblibdir}/interfaces/IFusionSound/libifusionsound_dispatcher.so
+%attr(755,root,root) %{dfblibdir}/interfaces/IFusionSound/libifusionsound_requestor.so
+%dir %{dfblibdir}/interfaces/IFusionSoundBuffer
+%attr(755,root,root) %{dfblibdir}/interfaces/IFusionSoundBuffer/libifusionsoundbuffer_dispatcher.so
+%attr(755,root,root) %{dfblibdir}/interfaces/IFusionSoundBuffer/libifusionsoundbuffer_requestor.so
+%dir %{dfblibdir}/interfaces/IFusionSoundMusicProvider
+%attr(755,root,root) %{dfblibdir}/interfaces/IFusionSoundMusicProvider/libifusionsoundmusicprovider_playlist.so
+%attr(755,root,root) %{dfblibdir}/interfaces/IFusionSoundMusicProvider/libifusionsoundmusicprovider_wave.so
+%dir %{dfblibdir}/interfaces/IFusionSoundPlayback
+%attr(755,root,root) %{dfblibdir}/interfaces/IFusionSoundPlayback/libifusionsoundplayback_dispatcher.so
+%attr(755,root,root) %{dfblibdir}/interfaces/IFusionSoundPlayback/libifusionsoundplayback_requestor.so
+%dir %{dfblibdir}/interfaces/IFusionSoundStream
+%attr(755,root,root) %{dfblibdir}/interfaces/IFusionSoundStream/libifusionsoundstream_dispatcher.so
+%attr(755,root,root) %{dfblibdir}/interfaces/IFusionSoundStream/libifusionsoundstream_requestor.so
+%dir %{dfblibdir}/snddrivers
+%attr(755,root,root) %{dfblibdir}/snddrivers/libfusionsound_alsa.so
+%attr(755,root,root) %{dfblibdir}/snddrivers/libfusionsound_oss.so
+%attr(755,root,root) %{dfblibdir}/snddrivers/libfusionsound_wave.so
 %{_mandir}/man5/fusionsoundrc.5*
 
 %files devel
@@ -207,29 +211,29 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libfusionsound.a
 # .la makes no sense in -devel (it's module); here for DFB static linking hacks
-%{_libdir}/directfb-1.2-0/interfaces/IFusionSound/lib*.[la]*
-%{_libdir}/directfb-1.2-0/interfaces/IFusionSoundBuffer/lib*.[la]*
-%{_libdir}/directfb-1.2-0/interfaces/IFusionSoundMusicProvider/lib*.[la]*
-%{_libdir}/directfb-1.2-0/interfaces/IFusionSoundPlayback/lib*.[la]*
-%{_libdir}/directfb-1.2-0/interfaces/IFusionSoundStream/lib*.[la]*
-%{_libdir}/directfb-1.2-0/snddrivers/libfusionsound*.[la]*
+%{dfblibdir}/interfaces/IFusionSound/lib*.[la]*
+%{dfblibdir}/interfaces/IFusionSoundBuffer/lib*.[la]*
+%{dfblibdir}/interfaces/IFusionSoundMusicProvider/lib*.[la]*
+%{dfblibdir}/interfaces/IFusionSoundPlayback/lib*.[la]*
+%{dfblibdir}/interfaces/IFusionSoundStream/lib*.[la]*
+%{dfblibdir}/snddrivers/libfusionsound*.[la]*
 
 %files musicprovider-cdda
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundMusicProvider/libifusionsoundmusicprovider_cdda.so
+%attr(755,root,root) %{dfblibdir}/interfaces/IFusionSoundMusicProvider/libifusionsoundmusicprovider_cdda.so
 
 %files musicprovider-ffmpeg
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundMusicProvider/libifusionsoundmusicprovider_ffmpeg.so
+%attr(755,root,root) %{dfblibdir}/interfaces/IFusionSoundMusicProvider/libifusionsoundmusicprovider_ffmpeg.so
 
 %files musicprovider-mad
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundMusicProvider/libifusionsoundmusicprovider_mad.so
+%attr(755,root,root) %{dfblibdir}/interfaces/IFusionSoundMusicProvider/libifusionsoundmusicprovider_mad.so
 
 %files musicprovider-timidity
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundMusicProvider/libifusionsoundmusicprovider_timidity.so
+%attr(755,root,root) %{dfblibdir}/interfaces/IFusionSoundMusicProvider/libifusionsoundmusicprovider_timidity.so
 
 %files musicprovider-vorbis
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/interfaces/IFusionSoundMusicProvider/libifusionsoundmusicprovider_vorbis.so
+%attr(755,root,root) %{dfblibdir}/interfaces/IFusionSoundMusicProvider/libifusionsoundmusicprovider_vorbis.so
This page took 0.043161 seconds and 4 git commands to generate.