]> git.pld-linux.org Git - packages/CodeEditor.git/blob - CodeEditor.spec
- pl, missing dirs
[packages/CodeEditor.git] / CodeEditor.spec
1 Summary:        Code Editor for Objective C
2 Summary(pl):    Edytor kodu dla jêzyka Objective C
3 Name:           CodeEditor
4 Version:        0.4.1
5 Release:        1
6 License:        GPL
7 Group:          X11/Applications
8 Source0:        http://savannah.nongnu.org/download/codeeditor/CodeEditor.pkg/0.4.1/%{name}-%{version}.tar.gz
9 # Source0-md5:  4906152cd85fe0bd8b61ae1b17db9323
10 URL:            http://www.nongnu.org/codeeditor/
11 BuildRequires:  gnustep-gui-devel >= 0.8.7
12 Requires:       gnustep-gui >= 0.8.7
13 Requires:       %{name}-libs = %{version}
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         libcombo        gnu-gnu-gnu
17 %define         gsos            linux-gnu
18 %ifarch %{ix86}
19 %define         gscpu           ix86
20 %else
21 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
22 %define         gscpu           %{_target_cpu}
23 %endif
24 %define appdir     %{_libdir}/GNUstep/System/Applications/CodeEditor.app
25 %define supportdir %{_libdir}/GNUstep/System/Library/ApplicationSupport/CodeEditorView
26
27 %description
28 This is CodeEditor, a programmer's editor and library for GNUstep.
29
30 %description -l pl
31 To jest CodeEditor - edytor programisty oraz biblioteka dla GNUstepa.
32
33 %package libs
34 Summary:        CodeEditorView bundle
35 Summary(pl):    Paczka CodeEditorView
36 Group:          Development/Tools
37
38 %description libs
39 CodeEditorView bundle for embedding CodeEditor in other apps.
40
41 %description libs -l pl
42 Paczka CodeEditorView do osadzania CodeEditora w innych aplikacjach.
43
44 %package devel
45 Summary:        CodeEditorView bundle headers
46 Summary(pl):    Pliki nag³ówkowe paczki CodeEditorView
47 Group:          Development/Tools
48 Requires:       %{name}-libs = %{version}
49
50 %description devel
51 CodeEditorView bundle headers.
52
53 %description devel -l pl
54 Pliki nag³ówkowe paczki CodeEditorView.
55
56 %prep
57 %setup -q -n codeeditor
58
59 %build
60 . %{_libdir}/GNUstep/System/Library/Makefiles/GNUstep.sh
61 %{__make} \
62         OPTFLAG="%{rpmcflags}" \
63         messages=yes
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 . %{_libdir}/GNUstep/System/Library/Makefiles/GNUstep.sh
68
69 %{__make} install \
70         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_libdir}/GNUstep/System
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc README TODO
78 %dir %{appdir}
79 %attr(755,root,root) %{appdir}/%{name}
80 %dir %{appdir}/Resources
81 %{appdir}/Resources/*.desktop
82 %{appdir}/Resources/*.plist
83 %{appdir}/Resources/*.tiff
84 %{appdir}/Resources/*.gorm
85 %{appdir}/Resources/Scripts
86 %dir %{appdir}/%{gscpu}
87 %dir %{appdir}/%{gscpu}/%{gsos}
88 %dir %{appdir}/%{gscpu}/%{gsos}/%{libcombo}
89 %attr(755,root,root) %{appdir}/%{gscpu}/%{gsos}/%{libcombo}/%{name}
90 %{appdir}/%{gscpu}/%{gsos}/%{libcombo}/*.openapp
91
92 %files libs
93 %defattr(644,root,root,755)
94 %dir %{supportdir}
95 %dir %{supportdir}/ObjCHandler.bundle
96 %dir %{supportdir}/ObjCHandler.bundle/Resources
97 %{supportdir}/ObjCHandler.bundle/Resources/*.plist
98 %dir %{supportdir}/ObjCHandler.bundle/%{gscpu}
99 %dir %{supportdir}/ObjCHandler.bundle/%{gscpu}/%{gsos}
100 %dir %{supportdir}/ObjCHandler.bundle/%{gscpu}/%{gsos}/%{libcombo}
101 %{supportdir}/ObjCHandler.bundle/%{gscpu}/%{gsos}/%{libcombo}/ObjCHandler
102
103 %files devel
104 %defattr(644,root,root,755)
105 %{_libdir}/GNUstep/System/Library/Headers/CodeEditorView
This page took 0.111843 seconds and 3 git commands to generate.