]> git.pld-linux.org Git - packages/Atari800.git/blob - Atari800.spec
decd7ff96dfad958089d1c61bca2c81842275bef
[packages/Atari800.git] / Atari800.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # with unzipped ROM files instead of xf25.zip
4 %bcond_without  svga                    # without SVGA version
5 #
6 Summary:        Atari 800 Emulator
7 Summary(pl):    Emulator Atari 800
8 Name:           Atari800
9 Version:        2.0.2
10 Release:        1
11 License:        GPL (Atari800), distributable if unmodified (xf25 with ROMs)
12 Group:          Applications/Emulators
13 Source0:        http://dl.sourceforge.net/atari800/atari800-%{version}.tar.gz
14 # Source0-md5:  a81f8a5ace5fd89eb6094faef7c936af
15 # NOTE: ROMs probably can be redistributed only in original XF25 archive
16 Source1:        http://joy.sophics.cz/www/xf25.zip
17 # Source1-md5:  4dc3b6b4313e9596c4d474785a37b94d
18 Source2:        %{name}-chooser
19 URL:            http://atari800.atari.org/
20 BuildRequires:  SDL-devel
21 BuildRequires:  automake
22 %{?with_svga:BuildRequires:     svgalib-devel}
23 %if %{with license_agreement}
24 BuildRequires:  unzip
25 %endif
26 BuildRequires:  xorg-lib-libXext-devel
27 BuildRequires:  zlib-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         specflags       -fomit-frame-pointer
31
32 %description
33 This is Atari 800, 800XL, 130XE and 5200 emulator.
34
35 %description -l pl
36 To jest emulator Atari 800, 800XL, 130XE i 5200.
37
38 %package common
39 Summary:        Atari 800 Emulator - common files for svgalib and X11 versions
40 Summary(pl):    Emulator Atari 800 - pliki wspólne dla wersji svgalib oraz X11
41 Group:          Applications/Emulators
42 Obsoletes:      Atari800
43 %if !%{with license_agreement}
44 Requires(post): unzip
45 %endif
46
47 %description common
48 This is Atari 800, 800XL, 130XE and 5200 emulator.
49
50 This package contains common files for both svgalib and X11 versions
51 of Atari800.
52 %if !%{with license_agreement}
53 Note: because of license problems we had to include whole X-Former
54 archive (xf25.zip). If you don't want it - rebuild Atari800 (--with
55 license_agreement)
56 %endif 
57
58 %description common -l pl
59 To jest emulator Atari 800, 800XL, 130XE i 5200.
60
61 Ten pakiet zawiera pliki wspólne dla wersji dzia³aj±cych pod svgalib
62 oraz X11.
63 %if !%{with license_agreement}
64 Uwaga: z powodu problemów z licencj± musieli¶my za³±czyæ ca³± paczkê
65 z emulatorem X-Former (xf25.zip). Je¶li jej nie chcesz w pakiecie -
66 przebuduj pakiet z opcja --with license_agreement.
67 %endif
68
69 %package svga
70 Summary:        Atari 800 Emulator - svgalib version
71 Summary(pl):    Emulator Atari 800 - wersja pod svgalib
72 License:        GPL
73 Group:          Applications/Emulators
74 Requires:       %{name}-common = %{version}-%{release}
75
76 %description svga
77 This is Atari 800, 800XL, 130XE and 5200 emulator.
78
79 This package contains Atari800 executable file configured for svgalib
80 with sound and joystick support.
81
82 %description svga -l pl
83 To jest emulator Atari 800, 800XL, 130XE i 5200.
84
85 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla
86 svgalib z obs³ug± d¼wiêku i joysticka.
87
88 %package x11
89 Summary:        Atari 800 Emulator - X Window version
90 Summary(pl):    Emulator Atari 800 - wersja pod X Window
91 License:        GPL
92 Group:          Applications/Emulators
93 Requires:       %{name}-common = %{version}-%{release}
94
95 %description x11
96 This is Atari 800, 800XL, 130XE and 5200 emulator.
97
98 This package contains Atari800 executable file configured for X11 with
99 sound and joystick support.
100
101 %description x11 -l pl
102 To jest emulator Atari 800, 800XL, 130XE i 5200.
103
104 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla X11 z
105 obs³ug± d¼wiêku i joysticka.
106
107 %package SDL
108 Summary:        Atari 800 Emulator - SDL version
109 Summary(pl):    Emulator Atari 800 - wersja pod SDL
110 License:        GPL
111 Group:          Applications/Emulators
112 Requires:       %{name}-common = %{version}-%{release}
113
114 %description SDL
115 This is Atari 800, 800XL, 130XE and 5200 emulator.
116
117 This package contains Atari800 executable file configured for SDL with
118 sound and joystick support.
119
120 %description SDL -l pl
121 To jest emulator Atari 800, 800XL, 130XE i 5200.
122
123 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla SDL z
124 obs³ug± d¼wiêku i joysticka.
125
126 %prep
127 %setup -q -n atari800-%{version}
128
129 %build
130 cd src
131 rm config.sub
132 cp -f /usr/share/automake/config.sub .
133
134 CFLAGS="%{rpmcflags}"
135
136 %if %{with svga}
137 %configure \
138         --target=svgalib \
139         --enable-crashmenu \
140         --enable-cursorblock \
141         --disable-stereosound
142
143 %{__make}
144
145 mv -f atari800 atari800-svga
146
147 %{__make} clean
148 %endif
149
150 %configure \
151         --target=sdl \
152         --enable-crashmenu \
153         --disable-stereosound
154
155 %{__make}
156
157 mv -f atari800 atari800-SDL
158
159 %{__make} clean
160
161 %configure \
162         --target=shm \
163         --enable-crashmenu \
164         --disable-stereosound
165
166 %{__make}
167
168 mv -f atari800 atari800-x11
169
170 %install
171 rm -rf $RPM_BUILD_ROOT
172 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/atari800,%{_mandir}/man1}
173
174 %if %{with svga}
175 install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}
176 %endif
177 install src/atari800-x11 $RPM_BUILD_ROOT%{_bindir}
178 install src/atari800-SDL $RPM_BUILD_ROOT%{_bindir}
179 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
180 install src/atari800.man $RPM_BUILD_ROOT%{_mandir}/man1/atari800.1
181
182 %if %{with license_agreement}
183 unzip -q -L %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/atari800
184 rm -f $RPM_BUILD_ROOT%{_datadir}/atari800/xf25.*
185 %else
186 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/atari800
187 %endif
188
189 %clean
190 rm -rf $RPM_BUILD_ROOT
191
192 %if !%{with license_agreement}
193 %post common
194 cd %{_datadir}/atari800
195 if [ "`echo *.rom`" = "*.rom" ]; then
196         umask 022
197         unzip -q -L xf25.zip
198         rm -f xf25.doc xf25.exe
199 fi
200 %endif
201
202 %files common
203 %defattr(644,root,root,755)
204 %doc DOC/{BUGS,CREDITS,ChangeLog,FAQ,NEWS,README,TODO,USAGE,*.txt} README.1ST
205 %attr(755,root,root) %{_bindir}/atari800
206 %{_datadir}/atari800
207 %{_mandir}/man1/atari800.1*
208
209 %files x11
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_bindir}/atari800-x11
212
213 %files SDL
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_bindir}/atari800-SDL
216
217 %if %{with svga}
218 %files svga
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_bindir}/atari800-svga
221 %endif
This page took 0.069501 seconds and 2 git commands to generate.