]> git.pld-linux.org Git - packages/Atari800.git/blob - Atari800.spec
5bad2a5db24ef718673e2b3c970acffdf85deb90
[packages/Atari800.git] / Atari800.spec
1 #
2 # Conditional build:
3 # _with_license_agreement       - with unzipped ROM files instead of xf25.zip
4 # _without_svga                 - without SVGA version
5 #
6 Summary:        Atari 800 Emulator
7 Summary(pl):    Emulator Atari 800
8 Name:           Atari800
9 Version:        1.3.1
10 Release:        1
11 License:        GPL (Atari800), distributable if unmodified (xf25 with ROMs)
12 Group:          Applications/Emulators
13 Source0:        http://dl.sourceforge.net/atari800/atari800-%{version}.tar.gz
14 # Source0-md5:  02c824a4648732a3646d377ee02efd7d
15 # NOTE: ROMs probably can be redistributed only in original XF25 archive
16 Source1:        http://joy.sophics.cz/www/xf25.zip
17 # Source1-md5:  4dc3b6b4313e9596c4d474785a37b94d
18 Source2:        %{name}-chooser
19 URL:            http://atari800.atari.org/
20 BuildRequires:  SDL-devel
21 BuildRequires:  XFree86-devel
22 %ifarch %{ix86} alpha ppc
23 %{!?_without_svga:BuildRequires:        svgalib-devel}
24 %endif
25 BuildRequires:  unzip
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         specflags       -fomit-frame-pointer
30
31 %description
32 This is Atari 800, 800XL, 130XE and 5200 emulator.
33
34 %description -l pl
35 To jest emulator Atari 800, 800XL, 130XE i 5200.
36
37 %package common
38 Summary:        Atari 800 Emulator - common files for svgalib and X11 versions
39 Summary(pl):    Emulator Atari 800 - pliki wspólne dla wersji svgalib oraz X11
40 Group:          Applications/Emulators
41 Obsoletes:      Atari800
42 %{!?_with_license_agreement:Prereq:     unzip}
43
44 %description common
45 This is Atari 800, 800XL, 130XE and 5200 emulator.
46
47 This package contains common files for both svgalib and X11 versions
48 of Atari800.
49
50 %{!?_with_license_agreement:Note: because of license problems we had to include whole X-Former}
51 %{!?_with_license_agreement:archive (xf25.zip). If you don't want it - rebuild Atari800 by:}
52 %{!?_with_license_agreement:rpm --rebuild --with license_agreement ftp://ftp.pld-linux.org/PLD-1.0/SRPMS/SRPMS/%{name}-%{version}-%{release}.src.rpm}
53
54 %description common -l pl
55 To jest emulator Atari 800, 800XL, 130XE i 5200.
56
57 Ten pakiet zawiera pliki wspólne dla wersji dzia³aj±cych pod svgalib
58 oraz X11.
59
60 %{!?_with_license_agreement:Uwaga: z powodu problemów z licencj± musieli¶my za³±czyæ ca³± paczkê}
61 %{!?_with_license_agreement:z emulatorem X-Former (xf25.zip). Je¶li jej nie chcesz w pakiecie -}
62 %{!?_with_license_agreement:przebuduj pakiet poleceniem:}
63 %{!?_with_license_agreement:rpm --rebuild --with license_agreement ftp://ftp.pld-linux.org/PLD-1.0/SRPMS/SRPMS/%{name}-%{version}-%{release}.src.rpm}
64
65 %package svga
66 Summary:        Atari 800 Emulator - svgalib version
67 Summary(pl):    Emulator Atari 800 - wersja pod svgalib
68 License:        GPL
69 Group:          Applications/Emulators
70 Requires:       %{name}-common = %{version}
71
72 %description svga
73 This is Atari 800, 800XL, 130XE and 5200 emulator.
74
75 This package contains Atari800 executable file configured for svgalib
76 with sound and joystick support.
77
78 %description svga -l pl
79 To jest emulator Atari 800, 800XL, 130XE i 5200.
80
81 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla
82 svgalib z obs³ug± d¼wiêku i joysticka.
83
84 %package x11
85 Summary:        Atari 800 Emulator - X Window version
86 Summary(pl):    Emulator Atari 800 - wersja pod X Window
87 License:        GPL
88 Group:          Applications/Emulators
89 Requires:       %{name}-common = %{version}
90
91 %description x11
92 This is Atari 800, 800XL, 130XE and 5200 emulator.
93
94 This package contains Atari800 executable file configured for X11 with
95 sound and joystick support.
96
97 %description x11 -l pl
98 To jest emulator Atari 800, 800XL, 130XE i 5200.
99
100 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla X11 z
101 obs³ug± d¼wiêku i joysticka.
102
103 %package SDL
104 Summary:        Atari 800 Emulator - SDL version
105 Summary(pl):    Emulator Atari 800 - wersja pod SDL
106 License:        GPL
107 Group:          Applications/Emulators
108 Requires:       %{name}-common = %{version}
109
110 %description SDL
111 This is Atari 800, 800XL, 130XE and 5200 emulator.
112
113 This package contains Atari800 executable file configured for SDL with
114 sound and joystick support.
115
116 %description SDL -l pl
117 To jest emulator Atari 800, 800XL, 130XE i 5200.
118
119 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla SDL z
120 obs³ug± d¼wiêku i joysticka.
121
122 %prep
123 %setup -q -n atari800-%{version}
124
125 %build
126 cd src
127
128 CFLAGS="%{rpmcflags}"
129 %if %{?_without_svga:0}%{!?_without_svga:1}
130 %ifarch %{ix86} alpha ppc
131
132 %configure \
133         --target=svgalib \
134         --disable-VERY_SLOW \
135         --enable-NO_CYCLE_EXACT \
136         --enable-CRASH_MENU \
137         --enable-MONITOR_BREAK \
138         --enable-MONITOR_HINTS \
139         --enable-MONITOR_ASSEMBLER \
140         --enable-COMPILED_PALETTE \
141         --enable-SNAILMETER \
142         --disable-SVGA_SPEEDUP \
143         --enable-USE_CURSORBLOCK \
144         --disable-JOYMOUSE \
145         --enable-LINUX_JOYSTICK \
146         --enable-SOUND \
147         --enable-NO_VOL_ONLY \
148         --enable-NO_CONSOL_SOUND \
149         --disable-SERIO_SOUND \
150         --enable-NOSNDINTER \
151         --disable-CLIP \
152         --disable-STEREO \
153         --disable-BUFFERED_LOG \
154         --enable-SET_LED \
155         --enable-NO_LED_ON_SCREEN
156
157 %{__make}
158
159 mv -f atari800 atari800-svga
160
161 %{__make} clean
162 %endif
163 %endif
164
165 %configure \
166         --target=sdl \
167         --disable-VERY_SLOW \
168         --enable-NO_CYCLE_EXACT \
169         --enable-CRASH_MENU \
170         --enable-MONITOR_BREAK \
171         --enable-MONITOR_HINTS \
172         --enable-MONITOR_ASSEMBLER \
173         --enable-COMPILED_PALETTE \
174         --enable-SNAILMETER \
175         --enable-LINUX_JOYSTICK \
176         --enable-SOUND \
177         --enable-NO_VOL_ONLY \
178         --enable-NO_CONSOL_SOUND \
179         --disable-SERIO_SOUND \
180         --enable-NOSNDINTER \
181         --disable-CLIP \
182         --disable-STEREO \
183         --disable-BUFFERED_LOG \
184         --enable-SET_LED \
185         --enable-NO_LED_ON_SCREEN
186
187 %{__make}
188
189 mv -f atari800 atari800-SDL
190
191 %{__make} clean
192
193 %configure \
194         --target=shm \
195         --disable-VERY_SLOW \
196         --enable-NO_CYCLE_EXACT \
197         --enable-CRASH_MENU \
198         --enable-MONITOR_BREAK \
199         --enable-MONITOR_HINTS \
200         --enable-MONITOR_ASSEMBLER \
201         --enable-COMPILED_PALETTE \
202         --enable-SNAILMETER \
203         --enable-LINUX_JOYSTICK \
204         --enable-SOUND \
205         --enable-NO_VOL_ONLY \
206         --enable-NO_CONSOL_SOUND \
207         --disable-SERIO_SOUND \
208         --enable-NOSNDINTER \
209         --disable-CLIP \
210         --disable-STEREO
211
212 %{__make}
213
214 mv -f atari800 atari800-x11
215
216 %install
217 rm -rf $RPM_BUILD_ROOT
218 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/atari800,%{_mandir}/man1}
219
220 %ifarch %{ix86} alpha ppc
221 %{!?_without_svga:install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}}
222 %endif
223 install src/atari800-x11 $RPM_BUILD_ROOT%{_bindir}
224 install src/atari800-SDL $RPM_BUILD_ROOT%{_bindir}
225 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
226 install src/atari800.man $RPM_BUILD_ROOT%{_mandir}/man1/atari800.1
227
228 %if %{?_with_license_agreement:1}%{!?_with_license_agreement:0}
229 unzip -q -L %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/atari800
230 rm -f $RPM_BUILD_ROOT%{_datadir}/atari800/xf25.*
231 %else
232 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/atari800
233 %endif
234
235 %clean
236 rm -rf $RPM_BUILD_ROOT
237
238 %if %{?_with_license_agreement:0}%{!?_with_license_agreement:1}
239 %post common
240 cd %{_datadir}/atari800
241 unzip -q -L xf25.zip
242 %endif
243
244 %files common
245 %defattr(644,root,root,755)
246 %doc DOC/{BUGS,CHANGES,CREDITS,FAQ,README,TODO,USAGE} README.1ST
247 %doc DOC/{LPTjoy.txt,cart.txt,emuos.txt,pokeysnd.txt}
248 %attr(755,root,root) %{_bindir}/atari800
249 %{_datadir}/atari800
250 %{_mandir}/man1/atari800.1*
251
252 %files x11
253 %defattr(644,root,root,755)
254 %attr(755,root,root) %{_bindir}/atari800-x11
255
256 %files SDL
257 %defattr(644,root,root,755)
258 %attr(755,root,root) %{_bindir}/atari800-SDL
259
260 %ifarch %{ix86} alpha ppc
261 %if %{?_without_svga:0}%{!?_without_svga:1}
262 %files svga
263 %defattr(644,root,root,755)
264 %attr(755,root,root) %{_bindir}/atari800-svga
265 %endif
266 %endif
This page took 0.261033 seconds and 2 git commands to generate.