]> git.pld-linux.org Git - packages/Atari800.git/blob - Atari800.spec
0d4cf452ff77e0ca25ee55f1ce6341bcd6a6d5e5
[packages/Atari800.git] / Atari800.spec
1 #
2 # Conditional build:
3 # bcond_on_license_agreement - with unzipped ROM files instead of xf25.zip
4 #
5 Summary:        Atari 800 Emulator
6 Summary(pl):    Emulator Atari 800
7 Name:           Atari800
8 %define         ver_short       107
9 Version:        1.0.7
10 Release:        1
11 Group:          Applications/Emulators
12 Group(de):      Applikationen/Emulators
13 Group(pl):      Aplikacje/Emulatory
14 License:        GPL (Atari800), distributable if unmodified (xf25 with ROMs)
15 URL:            http://atari800.atari.org
16 Source0:        ftp://ftp.sophics.cz/pub/Atari800/src/a800s%{ver_short}.zip
17 # NOTE: ROMs probably can be redistributed only in original XF25 archive
18 Source1:        http://joy.sophics.cz/www/xf25.zip
19 Source2:        %{name}-chooser
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21 BuildRequires:  unzip
22 BuildRequires:  svgalib-devel
23 BuildRequires:  XFree86-devel
24 BuildRequires:  zlib-devel
25
26 %define         _xbindir        %{_prefix}/X11R6/bin
27
28 %description
29
30 %package common
31 Summary:        Atari 800 Emulator - common files for svgalib and X11 versions
32 Summary(pl):    Emulator Atari 800 - pliki wspólne dla wersji svgalib oraz X11
33 Group:          Applications/Emulators
34 Group(de):      Applikationen/Emulators
35 Group(pl):      Aplikacje/Emulatory
36 Obsoletes:      Atari800
37 %{!?bcond_on_license_agreement:Requires:        unzip}
38
39 %description common
40 This is Atari 800, 800XL, 130XE and 5200 emulator.
41
42 This package contains common files for both svgalib and X11 versions
43 of Atari800.
44
45 %{!?bcond_on_license_agreement:Note: because of license problems we had to include whole X-Former}
46 %{!?bcond_on_license_agreement:archive (xf25.zip). If you don't want it - rebuild Atari800 by:}
47 %{!?bcond_on_license_agreement:rpm --rebuild --with license_agreement ftp://ftp.pld.org.pl/PLD-1.0/SRPMS/SRPMS/%{name}-%{version}-%{release}.src.rpm}
48
49 %description common -l pl
50 To jest emulator Atari 800, 800XL, 130XE i 5200.
51
52 Ten pakiet zawiera pliki wspólne dla wersji dzia³aj±cych pod svgalib
53 oraz X11.
54
55 %{!?bcond_on_license_agreement:Uwaga: z powodu problemów z licencj± musieli¶my za³±czyæ ca³± paczkê}
56 %{!?bcond_on_license_agreement:z emulatorem X-Former (xf25.zip). Je¶li jej nie chcesz w pakiecie -}
57 %{!?bcond_on_license_agreement:przebuduj pakiet poleceniem:}
58 %{!?bcond_on_license_agreement:rpm --rebuild --with license_agreement ftp://ftp.pld.org.pl/PLD-1.0/SRPMS/SRPMS/%{name}-%{version}-%{release}.src.rpm}
59
60 %package svga
61 Summary:        Atari 800 Emulator - svgalib version
62 Summary(pl):    Emulator Atari 800 - wersja pod svgalib
63 Group:          Applications/Emulators
64 Group(de):      Applikationen/Emulators
65 Group(pl):      Aplikacje/Emulatory
66 License:        GPL
67 Requires:       %{name}-common = %{version}
68
69 %description svga
70 This is Atari 800, 800XL, 130XE and 5200 emulator.
71
72 This package contains Atari800 executable file configured for svgalib
73 with sound and joystick support.
74
75 %description svga -l pl
76 To jest emulator Atari 800, 800XL, 130XE i 5200.
77
78 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla
79 svgalib z obs³ug± d¼wiêku i joysticka.
80
81 %package x11
82 Summary:        Atari 800 Emulator - X Window version
83 Summary(pl):    Emulator Atari 800 - wersja pod X Window
84 Group:          Applications/Emulators
85 Group(de):      Applikationen/Emulators
86 Group(pl):      Aplikacje/Emulatory
87 License:        GPL
88 Requires:       %{name}-common = %{version}
89
90 %description x11
91 This is Atari 800, 800XL, 130XE and 5200 emulator.
92
93 This package contains Atari800 executable file configured for X11 with
94 sound and joystick support.
95
96 %description x11 -l pl
97 To jest emulator Atari 800, 800XL, 130XE i 5200.
98
99 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla X11 z
100 obs³ug± d¼wiêku i joysticka.
101
102 %prep
103 %setup -q -c -T -n %{name}-%{version}
104 cd ..
105 unzip -q %{SOURCE0}
106
107 %build
108 cd src
109
110 %configure svgalib <<EOF
111 n
112 y
113 y
114 y
115 y
116 n
117 y
118 n
119 y
120 n
121 n
122 y
123 y
124 y
125 y
126 n
127 y
128 n
129 n
130 n
131 y
132 y
133 EOF
134 %{__make} \
135         CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}" \
136         LDFLAGS="%{rpmldflags}"
137 mv -f atari800 atari800-svga
138
139 %{__make} clean
140
141 %configure x11-shm <<EOF
142 n
143 y
144 y
145 y
146 y
147 n
148 n
149 n
150 y
151 y
152 y
153 y
154 y
155 y
156 n
157 n
158 EOF
159 %{__make} \
160         CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer} -I/usr/X11R6/include" \
161         LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
162 mv -f atari800 atari800-x11
163
164 sed s@/usr/local/lib/atari@%{_datadir}/atari800@g atari800.man >atari800.1
165
166 %install
167 rm -rf $RPM_BUILD_ROOT
168 install -d $RPM_BUILD_ROOT{%{_bindir},%{_xbindir}} \
169         $RPM_BUILD_ROOT{%{_datadir}/atari800,%{_mandir}/man1}
170
171 install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}
172 install src/atari800-x11 $RPM_BUILD_ROOT%{_xbindir}
173 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
174 install src/atari800.1 $RPM_BUILD_ROOT%{_mandir}/man1/atari800.1
175
176 %if "%{bcond_on_license_agreement:1}%{!?bcond_on_license_agreement:0}"
177 unzip -q -L %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/atari800
178 rm -f $RPM_BUILD_ROOT%{_datadir}/atari800/xf25.*
179 %else
180 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/atari800
181 %endif
182
183 gzip -9nf DOC/{BUGS,CHANGES,CREDITS,FAQ,README,TODO,USAGE} README.1ST \
184         DOC/{LPTjoy.txt,cart.txt,emuos.txt,pokeysnd.txt,usage1}
185
186 %clean
187 rm -rf $RPM_BUILD_ROOT
188
189 %if "%{bcond_on_license_agreement:0}%{!?bcond_on_license_agreement:1}"
190 %post common
191 cd %{_datadir}/atari800
192 unzip -q -L xf25.zip
193 %endif
194
195 %files common
196 %defattr(644,root,root,755)
197 %doc  *.gz DOC/*.gz
198 %{_datadir}/atari800
199 %{_mandir}/man1/atari800.1*
200 %attr(755,root,root) %{_bindir}/atari800
201
202 %files svga
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_bindir}/atari800-svga
205
206 %files x11
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_xbindir}/atari800-x11
This page took 0.072673 seconds and 2 git commands to generate.