]> git.pld-linux.org Git - packages/anubis.git/blob - anubis.spec
- converted to UTF-8
[packages/anubis.git] / anubis.spec
1 #
2 # Conditional build:
3 %bcond_with     gnutls          # use GnuTLS library instead of OpenSSL
4 %bcond_without  gpgme           # disable using gpgme library for signing/encrypting with gnupg
5 %bcond_without  pam             # disable using of PAM authentication
6 %bcond_without  pcre            # disable using pcre library
7 %bcond_without  tcp_wrappers    # disable using tcp_wrappers for access control
8 %bcond_with     mysql           # enable MySQL support
9 %bcond_with     postgres        # enable PostgreSQL support
10 #
11 %include        /usr/lib/rpm/macros.perl
12 Summary:        An outgoing mail processor, and the SMTP tunnel
13 Summary(pl.UTF-8):   Procesor wychodzącej poczty i tunel SMTP
14 Name:           anubis
15 Version:        4.0
16 Release:        3
17 License:        GPL
18 Group:          Applications/Mail
19 Source0:        ftp://ftp.gnu.org/gnu/anubis/%{name}-%{version}.tar.gz
20 # Source0-md5:  cded94ad14e528e899f5e8f7fd1aa022
21 Source1:        %{name}.init
22 Source2:        %{name}.pamd
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-nolibnsl.patch
25 URL:            http://www.gnu.org/software/anubis/
26 BuildRequires:  autoconf >= 2.54
27 BuildRequires:  automake >= 1:1.7
28 BuildRequires:  bison
29 BuildRequires:  gettext-devel >= 0.12.1
30 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
31 %{?with_gpgme:BuildRequires:    gpgme-devel >= 1:1.0.0}
32 BuildRequires:  guile-devel >= 5:1.6
33 %{?with_tcp_wrappers:BuildRequires:     libwrap-devel}
34 %{?with_mysql:BuildRequires:    mysql-devel}
35 %{!?with_gnutls:BuildRequires:  openssl-devel >= 0.9.7d}
36 %{?with_postgres:BuildRequires: postgres-devel}
37 BuildRequires:  rpm-perlprov
38 BuildRequires:  rpmbuild(macros) >= 1.268
39 BuildRequires:  texinfo
40 Requires(post,preun):   /sbin/chkconfig
41 Requires:       identserver
42 Requires:       pam >= 0.77.3
43 Requires:       rc-scripts
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 GNU Anubis is an outgoing mail processor. It goes between the MUA
48 (Mail User Agent) and the MTA (Mail Transport Agent), and can perform
49 on the fly various sorts of processing and conversion on the outgoing
50 mail in accord with the sender's specified rules, based on a highly
51 configurable regular expressions system. It operates as a proxy
52 server, independently from mail user agents. GNU Anubis can edit
53 outgoing mail headers, encrypt and/or sign mail with the GNU Privacy
54 Guard, build secure SMTP tunnels (Simple Mail Transport Protocol)
55 using the TLS/SSL encryption even if your mail user agent doesn't
56 support it, or tunnel a connection through a SOCKS proxy. Moreover,
57 GNU Anubis supports the remailers (it allows sending mail in an
58 anonymous way).
59
60 Remember, that to use per-user configuration files ident server has to
61 be running. Without it only system-wide configuration file is used.
62
63 If you want to use GNU Anubis with mutt mail client, install msg2smtp
64 package.
65
66 %description -l pl.UTF-8
67 GNU Anubis zajmuje się przetwarzaniem poczty wychodzącej. Znajduje się
68 on pomiędzy MUA (Mail User Agent) i MTA (Mail Transport Agent) i może
69 wykonywać w locie różne rodzaje przetwarzania i konwersji poczty
70 wychodzącej zależnie od podanych reguł, bazujących na wysoce
71 konfigurowalnym systemie wyrażeń regularnych. GNU Anubis działa jako
72 serwer proxy, niezależnie od programów pocztowych. Potrafi on zmieniać
73 nagłówki listów, szyfrować lub podpisywać jest przy pomocy GNU Privacy
74 Guard, tworzyć bezpieczne tunele SMTP używając szyfrowania TLS/SSL
75 nawet, gdy Twój program pocztowy nie ma takich możliwości. Możliwe
76 jest też tunelowanie połączeń przez SOCKS proxy. Co więcej, GNU Anubis
77 wspiera także remailery (czyli pozawala na anonimowe wysyłanie
78 poczty).
79
80 Pamiętaj, że aby używać plików konfiguracyjnych użytkowników, serwer
81 ident musi być aktywny. Inaczej, użyty będzie tylko główny plik
82 konfiguracyjny.
83
84 Jeśli chcesz używać GNU Anubis z klientem poczty mutt, zainstaluj
85 pakiet msg2smtp.
86
87 %package -n msg2smtp
88 Summary:        msg2smtp takes mail at input and relays it to an SMTP server
89 Summary(pl.UTF-8):   msg2smtp wysyła pocztę przyjmowaną na wejściu do serwera SMTP
90 Group:          Applications/Mail
91
92 %description -n msg2smtp
93 The msg2smtp script is a bridge between MUA programs which use
94 "sendmail" command to send mail (such as Mutt) and smtp servers. It is
95 particularly useful when used in connection with GNU Anubis mail
96 processor.
97
98 %description -n msg2smtp -l pl.UTF-8
99 Skrypt msg2smtp jest pomostem między programami pocztowymi używającymi
100 polecenia "sendmail" do wysyłania listów (np. Mutt), a serwerem smtp.
101 Jest on szczególnie przydatny w połączeniu z procesorem poczty GNU
102 Anubis.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107 %patch1 -p1
108
109 %build
110 %{__gettextize}
111 %{__aclocal} -I m4
112 %{__autoconf}
113 %{__automake}
114 %configure \
115 %{!?with_gnutls:        --without-gnutls} \
116 %{!?with_gnutls:        --with-openssl} \
117 %{?with_pam:            --with-pam} \
118 %{?with_pcre:           --with-pcre} \
119 %{!?with_gpgme:         --without-gpgme} \
120 %{?with_mysql:          --with-mysql} \
121 %{?with_postgres:       --with-postgres} \
122 %{?with_tcp_wrappers:   --with-tcp-wrappers} \
123         --disable-dependency-tracking
124
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/pam.d,%{_sysconfdir},%{_bindir}}
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 install ./contrib/msg2smtp.pl $RPM_BUILD_ROOT%{_bindir}
135 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/anubis
136 install ./examples/2anubisrc $RPM_BUILD_ROOT%{_sysconfdir}/anubisrc
137 %{?with_pam:install %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/anubis}
138 cp -f ./examples/1anubisrc examples/anubisrc
139
140 %find_lang %{name}
141 rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post
147 /sbin/chkconfig --add anubis
148 %service anubis restart
149 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
150
151
152 %preun
153 if [ "$1" = "0" ]; then
154         %service anubis stop
155         /sbin/chkconfig --del anubis
156 fi
157
158 %postun
159 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
160
161 %files -f %{name}.lang
162 %defattr(644,root,root,755)
163 %doc AUTHORS README INSTALL NEWS ChangeLog TODO examples/anubisrc
164 %{?with_pam:%doc examples/pam}
165 %attr(754,root,root) /etc/rc.d/init.d/anubis
166 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/anubisrc
167 %{?with_pam:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/anubis}
168 %attr(755,root,root) %{_sbindir}/anubis
169 %{_datadir}/anubis
170 %{_mandir}/man1/*
171 %{_infodir}/*.info*
172
173 %files -n msg2smtp
174 %defattr(644,root,root,755)
175 %doc contrib/msg2smtp.txt
176 %attr(755,root,root) %{_bindir}/msg2smtp.pl
This page took 0.066769 seconds and 3 git commands to generate.