]> git.pld-linux.org Git - packages/autossh.git/blame_incremental - autossh.spec
No empty pidfile/config.
[packages/autossh.git] / autossh.spec
... / ...
CommitLineData
1Summary: Automatically restart SSH sessions and tunnels
2Summary(pl.UTF-8): Automatyczny restart sesji i tuneli SSH
3Name: autossh
4Version: 1.4b
5Release: 4
6License: GPL
7Group: Applications/Networking
8Source0: http://www.harding.motd.ca/autossh/%{name}-%{version}.tgz
9Source1: %{name}.init
10Source2: %{name}.tab
11Source3: %{name}.tmpfiles
12# Source0-md5: 8f9aa006f6f69e912d3c2f504622d6f7
13URL: http://www.harding.motd.ca/autossh/
14Requires: openssh-clients
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%description
18Autossh is a program to start a copy of ssh and monitor it, restarting
19it as necessary should it die or stop passing traffic. The idea and
20the mechanism are from rstunnel (Reliable SSH Tunnel), but implemented
21in C. The author's view is that it is not as fiddly as rstunnel to get
22to work. Connection monitoring using a loop of port forwardings. Backs
23off on rate of connection attempts when experiencing rapid failures
24such as connection refused. Compiled and tested on OpenBSD, Linux, and
25Solaris; should work fine on other BSDs (except Mac OS 10).
26
27%description -l pl.UTF-8
28autossh jest programem uruchamiającym kopię ssh i monitorującym ją,
29restartując w miarę potrzeby, jeśli umrze lub przestanie przekazywać
30ruch. Idea i mechanizm pochodzą z rstunnela (Reliable SSH Tunnel), ale
31zaimplementowano je w C. Według autora nie trzeba się tak patyczkować,
32jak z rstunnelem, aby go uruchomić. Monitorowanie połączenia używa
33pętli przekazywania portów. Częstotliwość prób połączeń jest
34zmniejszana w przypadku napotkania nagłych awarii, takich jak
35odrzucenie połączenia. Program skompilowano i sprawdzono na OpenBSD,
36Linuksie i Solarisie; powinien działać także na innych BSD (oprócz
37MacOS 10).
38
39%package init
40Summary: autossh configuration as system service
41Summary(pl.UTF-8): konfiguracja autossh jako usługi systemowej
42Group: Networking/Daemons
43Requires(post,preun): /sbin/chkconfig
44Requires: autossh = %{epoch}:%{version}-%{release}
45Requires: awk
46Requires: rc-scripts >= 0.4.0.20
47
48%description init
49this package contains init script and example configuration file, that
50allows to run autossh as Unix system service.
51
52%description init -l pl.UTF-8
53Ten pakiet zawiera skrypt startowy oraz przykładowy plik
54konfiguracyjny, które pozwalają uruchamić autossh jako uniksową usługę
55systemową.
56
57%prep
58%setup -q
59
60%build
61%configure
62%{__make}
63
64%install
65rm -rf $RPM_BUILD_ROOT
66install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/var/run/%{name},%{_bindir},%{_mandir}/man1} \
67 $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
68
69install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
70install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/autossh.tab
71install %{SOURCE3} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
72
73install autossh $RPM_BUILD_ROOT%{_bindir}
74install autossh.1 $RPM_BUILD_ROOT%{_mandir}/man1
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%post init
80/sbin/chkconfig --add autossh
81%service autossh restart "autossh"
82
83%preun init
84if [ "$1" = "0" ]; then
85 %service autossh stop
86 /sbin/chkconfig --del autossh
87fi
88
89%files
90%defattr(644,root,root,755)
91%doc README CHANGES autossh.host rscreen
92%attr(755,root,root) %{_bindir}/autossh
93%{_mandir}/man1/autossh.1*
94
95%files init
96%defattr(644,root,root,755)
97%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.tab
98%attr(754,root,root) /etc/rc.d/init.d/%{name}
99/usr/lib/tmpfiles.d/%{name}.conf
100%dir /var/run/autossh
This page took 0.02087 seconds and 4 git commands to generate.