]> git.pld-linux.org Git - packages/apport.git/blame - apport.spec
- added glade patch for gtk client
[packages/apport.git] / apport.spec
CommitLineData
7ce35e5c
PZ
1Summary: Read, write, and modify problem reports
2Name: apport
ab4c69b5
PZ
3Version: 0.108.2
4Release: 1
7ce35e5c
PZ
5License: GPL
6Group: Applications/System
4f5ece38 7Source0: https://launchpad.net/ubuntu/hardy/+source/apport/%{version}/+files/%{name}_%{version}.tar.gz
ab4c69b5 8# Source0-md5: b2eb9a3b1168329ae7cdeb2a988d3443
7ce35e5c 9Source1: %{name}.init
c8193fa4 10Source2: %{name}-backend-pld.py
88d190c7
ER
11Patch0: %{name}-pager.patch
12Patch1: %{name}-crashdb.patch
37323b2f 13Patch2: %{name}-gtk-glade.patch
7ce35e5c
PZ
14URL: https://wiki.ubuntu.com/Apport
15BuildRequires: gettext
16BuildRequires: intltool
17BuildRequires: python-devel >= 1:2.5
25bc769a 18BuildRequires: rpmbuild(macros) >= 1.268
7ce35e5c
PZ
19#BuildRequires: tetex-format-pdflatex
20#BuildRequires: tetex-latex
7ce35e5c
PZ
21Requires(post,postun): hicolor-icon-theme
22Requires(post,postun): shared-mime-info
25bc769a 23Requires(post,preun): /sbin/chkconfig
56811d2d 24Requires: lsb-release
f8d8a6b1 25Requires: python-launchpad-bugs
7ce35e5c 26Requires: python-rpm
25bc769a 27Requires: rc-scripts
7ce35e5c 28Requires: yum
25bc769a
ER
29# Need the ability to use pipes in /proc/sys/kernel/core_pattern
30# seems only 2.6.24 allows command line params
31Requires: uname(release) >= 2.6.24
7ce35e5c
PZ
32BuildArch: noarch
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36apport automatically collects data from crashed processes and compiles
37a problem report in /var/crash/.
38
39This package also provides apport's python libraries and a command
40line frontend for browsing and handling the crash reports.
41
f8d8a6b1 42See <https://wiki.ubuntu.com/AutomatedProblemReports> for more
7ce35e5c
PZ
43information.
44
45%package gtk
46Summary: GTK frontend for the apport crash report system
47Group: Applications/System
48Requires: procps
7ce35e5c 49Requires: python-pygtk-glade
25bc769a 50Requires: python-pygtk-gtk
7ce35e5c
PZ
51Requires: python-pyxdg
52
53%description gtk
54apport automatically collects data from crashed processes and compiles
55a problem report in /var/crash/.
56
57This package provides a GTK frontend for browsing and handling the
58crash reports.
59
60%package qt
61Summary: Qt4 frontend for the apport crash report system
62Group: Applications/System
63Requires: procps
25bc769a 64Requires: python-PyQt4
7ce35e5c
PZ
65Requires: python-pyxdg
66
67%description qt
68apport automatically collects data from crashed processes and compiles
69a problem report in /var/crash/.
70
71This package provides a Qt4 frontend for browsing and handling the
72crash reports.
73
74%package retrace
75Summary: Tools for reprocessing Apport crash reports
76Group: Applications/System
77
78%description retrace
79apport-retrace recombines an Apport crash report (either a file or a
80Launchpad bug) and debug symbol packages (.ddebs) into fully symbolic
81stack traces.
82
83This package also ships apport-chroot. This tool can create and manage
84chroots for usage with apport-retrace. If the fakeroot and fakechroot
85libraries are available (either by installing the packages or by
86merely putting their libraries somewhere and setting two environment
87variables), the entire process of retracing crashes in chroots can
88happen with normal user privileges.
89
90%prep
ab4c69b5 91%setup -q -n hardy
88d190c7
ER
92%patch0 -p1
93%patch1 -p1
37323b2f 94%patch2 -p1
7ce35e5c 95
c8193fa4
PZ
96# only used by debian
97rm apport/packaging.py
f8d8a6b1
ER
98
99# set up the packaging backend
100cp backends/packaging_rpm.py apport
101cp %{SOURCE2} apport/packaging_pld.py
102ln -s packaging_pld.py apport/packaging_impl.py
103
104%build
7ce35e5c
PZ
105python setup.py build
106%{__make} -C po
107%{__make} -C gtk
108%{__make} -C qt4
f8d8a6b1 109
7ce35e5c 110#%{__make} -C doc
7ce35e5c
PZ
111
112%install
113rm -rf $RPM_BUILD_ROOT
114python setup.py install \
115 --optimize=2 \
ab4c69b5 116 --root=$RPM_BUILD_ROOT
7ce35e5c
PZ
117
118%py_postclean
119
120# Do the man pages
121install -d $RPM_BUILD_ROOT%{_mandir}/man1
122install man/apport-*.1 $RPM_BUILD_ROOT%{_mandir}/man1
123# cron job
124install -d $RPM_BUILD_ROOT/etc/cron.daily
125install debian/apport.cron.daily $RPM_BUILD_ROOT/etc/cron.daily/apport
126# create the dir for crash reports
127install -d $RPM_BUILD_ROOT/var/crash
128# install initscript
129install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
0cf0ec71
ER
130install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/apport
131
9adff5a3
ER
132# KDE integration
133install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_datadir}/mimelnk/text}
134# application
135cp -a qt4/apport-qt.desktop $RPM_BUILD_ROOT%{_desktopdir}
136# mimetype and associated action
137cp -a qt4/apport-qt-mimelnk.desktop $RPM_BUILD_ROOT%{_datadir}/mimelnk/text/x-apport.desktop
138cp -a qt4/apport-qt-mime.desktop $RPM_BUILD_ROOT%{_desktopdir}
139
0cf0ec71 140rm -f $RPM_BUILD_ROOT%{_docdir}/apport/package-hooks.txt
7ce35e5c
PZ
141
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145%post
7ce35e5c 146/sbin/chkconfig --add apport
39515a19 147%service apport restart
7ce35e5c
PZ
148%update_mime_database
149%update_icon_cache hicolor
150
151%preun
152if [ "$1" == "0" ]; then
39515a19
ER
153 %service apport stop
154 /sbin/chkconfig --del apport
7ce35e5c
PZ
155fi
156
7ce35e5c
PZ
157%update_mime_database
158%update_icon_cache hicolor
159
160%files
161%defattr(644,root,root,755)
0cf0ec71 162%doc doc/package-hooks.txt
7ce35e5c
PZ
163%dir /var/crash
164%{_mandir}/man1/*
165%{_iconsdir}/hicolor/*/apps/apport.svg
166%{_datadir}/mime/packages/apport.xml
39515a19 167%{py_sitescriptdir}/apport-*.egg-info
7ce35e5c 168%dir %{_datadir}/apport
ab4c69b5
PZ
169%attr(755,root,root) %{_bindir}/apport
170%attr(755,root,root) %{_bindir}/apport-cli
171%attr(755,root,root) %{_bindir}/gcc_ice_hook
172%attr(755,root,root) %{_bindir}/apport-checkreports
173%attr(755,root,root) %{_bindir}/package_hook
174%attr(755,root,root) %{_bindir}/kernel_hook
175%attr(755,root,root) %{_bindir}/apport-unpack
7ce35e5c
PZ
176%attr(755,root,root) %{_datadir}/apport/testsuite/
177%dir %{_datadir}/apport/general-hooks/
178%attr(755,root,root) %{_datadir}/apport/general-hooks/*.py
179%dir %{_datadir}/apport/package-hooks/
180%attr(755,root,root) %{_datadir}/apport/package-hooks/*.py
181%{py_sitescriptdir}/apport_python_hook.py[co]
182%{py_sitescriptdir}/problem_report*.py[co]
183%dir %{py_sitescriptdir}/apport
184%{py_sitescriptdir}/apport/*.py[co]
185%dir %{py_sitescriptdir}/apport/crashdb_impl
186%{py_sitescriptdir}/apport/crashdb_impl/*.py[co]
25bc769a
ER
187/etc/cron.daily/apport
188%attr(754,root,root) /etc/rc.d/init.d/apport
7ce35e5c
PZ
189%dir %{_sysconfdir}/apport
190%config %{_sysconfdir}/apport/crashdb.conf
191%{_sysconfdir}/apport/blacklist.d
192
193%files gtk
194%defattr(644,root,root,755)
ab4c69b5 195%attr(755,root,root) %{_bindir}/apport-gtk
7ce35e5c
PZ
196%{_datadir}/apport/apport-gtk.glade
197
198%files qt
199%defattr(644,root,root,755)
ab4c69b5 200%attr(755,root,root) %{_bindir}/apport-qt
7ce35e5c 201%{_datadir}/apport/*.ui
9adff5a3
ER
202%{_desktopdir}/apport-qt.desktop
203%{_desktopdir}/apport-qt-mime.desktop
204%{_datadir}/mimelnk/text/x-apport.desktop
7ce35e5c
PZ
205
206%files retrace
207%defattr(644,root,root,755)
208%{_mandir}/man1/apport-retrace.1*
ab4c69b5
PZ
209%attr(755,root,root) %{_bindir}/apport-retrace
210%attr(755,root,root) %{_bindir}/apport-chroot
211%attr(755,root,root) %{_bindir}/dupdb-admin
This page took 0.058765 seconds and 4 git commands to generate.