]> git.pld-linux.org Git - packages/apport.git/blame - apport.spec
- R: python-launchpad-bugs
[packages/apport.git] / apport.spec
CommitLineData
7ce35e5c
PZ
1Summary: Read, write, and modify problem reports
2Name: apport
46774820 3Version: 0.107
a0ffb924 4Release: 2
7ce35e5c
PZ
5License: GPL
6Group: Applications/System
4f5ece38 7Source0: https://launchpad.net/ubuntu/hardy/+source/apport/%{version}/+files/%{name}_%{version}.tar.gz
46774820 8# Source0-md5: 774dd4a28814b13bfbf5870abd5a65a8
7ce35e5c 9Source1: %{name}.init
c8193fa4
PZ
10Source2: %{name}-backend-pld.py
11Patch0: %{name}-rpm-platform.patch
12Patch1: %{name}-rpm-deps.patch
7ce35e5c
PZ
13URL: https://wiki.ubuntu.com/Apport
14BuildRequires: gettext
15BuildRequires: intltool
16BuildRequires: python-devel >= 1:2.5
25bc769a 17BuildRequires: rpmbuild(macros) >= 1.268
7ce35e5c
PZ
18#BuildRequires: tetex-format-pdflatex
19#BuildRequires: tetex-latex
7ce35e5c
PZ
20Requires(post,postun): hicolor-icon-theme
21Requires(post,postun): shared-mime-info
25bc769a 22Requires(post,preun): /sbin/chkconfig
56811d2d 23Requires: lsb-release
f8d8a6b1 24Requires: python-launchpad-bugs
7ce35e5c 25Requires: python-rpm
25bc769a 26Requires: rc-scripts
7ce35e5c 27Requires: yum
25bc769a
ER
28# Need the ability to use pipes in /proc/sys/kernel/core_pattern
29# seems only 2.6.24 allows command line params
30Requires: uname(release) >= 2.6.24
7ce35e5c
PZ
31BuildArch: noarch
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35apport automatically collects data from crashed processes and compiles
36a problem report in /var/crash/.
37
38This package also provides apport's python libraries and a command
39line frontend for browsing and handling the crash reports.
40
f8d8a6b1 41See <https://wiki.ubuntu.com/AutomatedProblemReports> for more
7ce35e5c
PZ
42information.
43
44%package gtk
45Summary: GTK frontend for the apport crash report system
46Group: Applications/System
47Requires: procps
7ce35e5c 48Requires: python-pygtk-glade
25bc769a 49Requires: python-pygtk-gtk
7ce35e5c
PZ
50Requires: python-pyxdg
51
52%description gtk
53apport automatically collects data from crashed processes and compiles
54a problem report in /var/crash/.
55
56This package provides a GTK frontend for browsing and handling the
57crash reports.
58
59%package qt
60Summary: Qt4 frontend for the apport crash report system
61Group: Applications/System
62Requires: procps
25bc769a 63Requires: python-PyQt4
7ce35e5c
PZ
64Requires: python-pyxdg
65
66%description qt
67apport automatically collects data from crashed processes and compiles
68a problem report in /var/crash/.
69
70This package provides a Qt4 frontend for browsing and handling the
71crash reports.
72
73%package retrace
74Summary: Tools for reprocessing Apport crash reports
75Group: Applications/System
76
77%description retrace
78apport-retrace recombines an Apport crash report (either a file or a
79Launchpad bug) and debug symbol packages (.ddebs) into fully symbolic
80stack traces.
81
82This package also ships apport-chroot. This tool can create and manage
83chroots for usage with apport-retrace. If the fakeroot and fakechroot
84libraries are available (either by installing the packages or by
85merely putting their libraries somewhere and setting two environment
86variables), the entire process of retracing crashes in chroots can
87happen with normal user privileges.
88
89%prep
f8d8a6b1
ER
90%setup -qc
91mv ubuntu/* .
c8193fa4
PZ
92%patch0 -p1
93%patch1 -p1
7ce35e5c 94
c8193fa4
PZ
95# only used by debian
96rm apport/packaging.py
f8d8a6b1
ER
97
98# set up the packaging backend
99cp backends/packaging_rpm.py apport
100cp %{SOURCE2} apport/packaging_pld.py
101ln -s packaging_pld.py apport/packaging_impl.py
102
103%build
7ce35e5c
PZ
104python setup.py build
105%{__make} -C po
106%{__make} -C gtk
107%{__make} -C qt4
f8d8a6b1 108
7ce35e5c 109#%{__make} -C doc
7ce35e5c
PZ
110
111%install
112rm -rf $RPM_BUILD_ROOT
113python setup.py install \
114 --optimize=2 \
115 --root=$RPM_BUILD_ROOT \
116 --install-scripts %{_datadir}/apport
117
118%py_postclean
119
120# Do the man pages
121install -d $RPM_BUILD_ROOT%{_mandir}/man1
122install man/apport-*.1 $RPM_BUILD_ROOT%{_mandir}/man1
123# cron job
124install -d $RPM_BUILD_ROOT/etc/cron.daily
125install debian/apport.cron.daily $RPM_BUILD_ROOT/etc/cron.daily/apport
126# create the dir for crash reports
127install -d $RPM_BUILD_ROOT/var/crash
128# install initscript
129install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
130install %SOURCE1 $RPM_BUILD_ROOT/etc/rc.d/init.d/apport
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%post
7ce35e5c 136/sbin/chkconfig --add apport
39515a19 137%service apport restart
7ce35e5c
PZ
138%update_mime_database
139%update_icon_cache hicolor
140
141%preun
142if [ "$1" == "0" ]; then
39515a19
ER
143 %service apport stop
144 /sbin/chkconfig --del apport
7ce35e5c
PZ
145fi
146
7ce35e5c
PZ
147%update_mime_database
148%update_icon_cache hicolor
149
150%files
151%defattr(644,root,root,755)
152%dir /var/crash
153%{_mandir}/man1/*
154%{_iconsdir}/hicolor/*/apps/apport.svg
155%{_datadir}/mime/packages/apport.xml
39515a19 156%{py_sitescriptdir}/apport-*.egg-info
7ce35e5c
PZ
157%dir %{_datadir}/apport
158%attr(755,root,root) %{_datadir}/apport/apport
159%attr(755,root,root) %{_datadir}/apport/apport-cli
160%attr(755,root,root) %{_datadir}/apport/gcc_ice_hook
161%attr(755,root,root) %{_datadir}/apport/apport-checkreports
162%attr(755,root,root) %{_datadir}/apport/package_hook
163%attr(755,root,root) %{_datadir}/apport/kernel_hook
164%attr(755,root,root) %{_datadir}/apport/apport-unpack
165%attr(755,root,root) %{_datadir}/apport/testsuite/
166%dir %{_datadir}/apport/general-hooks/
167%attr(755,root,root) %{_datadir}/apport/general-hooks/*.py
168%dir %{_datadir}/apport/package-hooks/
169%attr(755,root,root) %{_datadir}/apport/package-hooks/*.py
170%{py_sitescriptdir}/apport_python_hook.py[co]
171%{py_sitescriptdir}/problem_report*.py[co]
172%dir %{py_sitescriptdir}/apport
173%{py_sitescriptdir}/apport/*.py[co]
174%dir %{py_sitescriptdir}/apport/crashdb_impl
175%{py_sitescriptdir}/apport/crashdb_impl/*.py[co]
25bc769a
ER
176/etc/cron.daily/apport
177%attr(754,root,root) /etc/rc.d/init.d/apport
7ce35e5c
PZ
178%dir %{_sysconfdir}/apport
179%config %{_sysconfdir}/apport/crashdb.conf
180%{_sysconfdir}/apport/blacklist.d
181
182%files gtk
183%defattr(644,root,root,755)
184%attr(755,root,root) %{_datadir}/apport/apport-gtk
185%{_datadir}/apport/apport-gtk.glade
186
187%files qt
188%defattr(644,root,root,755)
189%attr(755,root,root) %{_datadir}/apport/apport-qt
190%{_datadir}/apport/*.ui
191
192%files retrace
193%defattr(644,root,root,755)
194%{_mandir}/man1/apport-retrace.1*
195%attr(755,root,root) %{_datadir}/apport/apport-retrace
196%attr(755,root,root) %{_datadir}/apport/apport-chroot
197%attr(755,root,root) %{_datadir}/apport/dupdb-admin
This page took 0.078153 seconds and 4 git commands to generate.