summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2022-09-25 20:19:05 (GMT)
committerJakub Bogusz2022-09-25 20:19:05 (GMT)
commit4efe07397c6fb426a65b2eec6999d3c7e683848a (patch)
tree66770b77e4cabc8f6e3ddb248959f8b7a436b55c
parent4caf371fa5cb5712171fc0da701ac6c20bad1abb (diff)
downloadxqilla-master.zip
xqilla-master.tar.gz
- added gcc11 patch (fix for gcc 11+); release 3HEADauto/th/xqilla-2.3.4-3master
-rw-r--r--xqilla-gcc11.patch11
-rw-r--r--xqilla.spec4
2 files changed, 14 insertions, 1 deletions
diff --git a/xqilla-gcc11.patch b/xqilla-gcc11.patch
new file mode 100644
index 0000000..c9e28be
--- /dev/null
+++ b/xqilla-gcc11.patch
@@ -0,0 +1,11 @@
+--- XQilla-2.3.4/include/xqilla/ast/XQDocumentOrder.hpp.orig 2018-07-03 20:37:15.000000000 +0200
++++ XQilla-2.3.4/include/xqilla/ast/XQDocumentOrder.hpp 2022-09-25 20:51:54.768846899 +0200
+@@ -68,7 +68,7 @@ private:
+ public:
+ uniqueLessThanCompareFn(const DynamicContext *context)
+ : context_(context) {}
+- bool operator()(const Node::Ptr &first, const Node::Ptr &second)
++ bool operator()(const Node::Ptr &first, const Node::Ptr &second) const
+ {
+ return first->uniqueLessThan(second, context_);
+ }
diff --git a/xqilla.spec b/xqilla.spec
index 85cda84..4980aa5 100644
--- a/xqilla.spec
+++ b/xqilla.spec
@@ -6,13 +6,14 @@ Summary: XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C
Summary(pl.UTF-8): XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece Xerces-C
Name: xqilla
Version: 2.3.4
-Release: 2
+Release: 3
License: Apache v2.0
Group: Libraries
Source0: http://downloads.sourceforge.net/xqilla/XQilla-%{version}.tar.gz
# Source0-md5: 9b77644c8b0d0741d895d3ccfbfe0016
Patch0: %{name}-link.patch
Patch1: %{name}-soname.patch
+Patch2: %{name}-gcc11.patch
URL: http://xqilla.sourceforge.net/
BuildRequires: autoconf >= 2.59
BuildRequires: automake
@@ -77,6 +78,7 @@ Dokumentacja API biblioteki XQilla.
%setup -q -n XQilla-%{version}
%patch0 -p1
%patch1 -p1
+%patch2 -p1
%build
%{__libtoolize}