summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--format-security.patch11
-rw-r--r--uucp.spec2
2 files changed, 13 insertions, 0 deletions
diff --git a/format-security.patch b/format-security.patch
new file mode 100644
index 0000000..35c26de
--- /dev/null
+++ b/format-security.patch
@@ -0,0 +1,11 @@
+--- uucp-1.07/uuconv.c~ 2003-05-29 08:08:47.000000000 +0200
++++ uucp-1.07/uuconv.c 2015-08-06 21:46:20.878894404 +0200
+@@ -676,7 +676,7 @@
+ {
+ if ((*pz)[0] != '-' && pz != pzarg)
+ fprintf (e, " ");
+- fprintf (e, *pz);
++ fputs (*pz, e);
+ }
+ }
+
diff --git a/uucp.spec b/uucp.spec
index 53438c6..07c21f5 100644
--- a/uucp.spec
+++ b/uucp.spec
@@ -24,6 +24,7 @@ Patch1: %{name}-debian.patch
Patch2: %{name}-ac.patch
Patch3: %{name}-pipe.patch
Patch4: %{name}-no_libnsl.patch
+Patch5: format-security.patch
URL: http://lists.cirr.com/cgi-bin/wilma/taylor-uucp/
BuildRequires: autoconf
BuildRequires: automake
@@ -107,6 +108,7 @@ Serwer GNU uucp.
%patch2 -p1
%patch3 -p1
%patch4 -p1
+%patch5 -p1
find . -name "*.perlpath" | xargs rm -f