summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2003-11-02 12:23:48 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitfe7266929a8d26f3b6c7354eaffec45df2cee1dd (patch)
tree5305ca2c5f8e62fc23d527fcd7b6d45353da5615
downloadstarlink-ast-fe7266929a8d26f3b6c7354eaffec45df2cee1dd.zip
starlink-ast-fe7266929a8d26f3b6c7354eaffec45df2cee1dd.tar.gz
- new
Changed files: starlink-ast-make.patch -> 1.1 starlink-ast.spec -> 1.1
-rw-r--r--starlink-ast-make.patch79
-rw-r--r--starlink-ast.spec102
2 files changed, 181 insertions, 0 deletions
diff --git a/starlink-ast-make.patch b/starlink-ast-make.patch
new file mode 100644
index 0000000..f25bf4c
--- /dev/null
+++ b/starlink-ast-make.patch
@@ -0,0 +1,79 @@
+--- starlink-ast-2.0_9.218/mk.orig 2003-05-08 17:19:01.000000000 +0200
++++ starlink-ast-2.0_9.218/mk 2003-11-02 12:22:32.499775512 +0100
+@@ -295,11 +295,11 @@
+ # ----------------------
+ ix86_Linux)
+ AR_IN='ar r'
+- BLD_SHR='f() { ld -shared -soname $$1 -o $$1 $$2;}; f'
++ BLD_SHR='f() { $(CC) -shared $$3 -Wl,-soname=$$1 -o $$1 $$2;}; f'
+ CC='gcc'
+- CFLAGS='-ansi -O2 -fPIC'
++ CFLAGS='-ansi $(OPT) -fPIC'
+ FC='g77'
+- FFLAGS='-fno-second-underscore -O2 -fPIC'
++ FFLAGS='-fno-second-underscore $(OPT) -fPIC'
+ FLIBS='-lg2c'
+ LINK='ln -s'
+ RANLIB='ranlib'
+--- starlink-ast-2.0_9.218/makefile.orig 2003-05-08 17:19:01.000000000 +0200
++++ starlink-ast-2.0_9.218/makefile 2003-11-02 12:30:58.289883728 +0100
+@@ -236,6 +236,7 @@
+ STAR_HELP = $(STARLINK)/help
+ STAR_INC = $(STARLINK)/include
+ STAR_LIB = $(STARLINK)/lib
++STAR_SHARE = $(STARLINK)/share
+
+ # Pathname of the root directory beneath which the built files for
+ # this package should be installed for use. This defaults to the
+@@ -609,7 +610,39 @@
+ # them. The third argument to $(BLD_SHR) should provide the information
+ # necessary to link any libraries called by this package.
+
+-SHAREABLE_LIBRARIES =
++SHAREABLE_LIBRARIES = lib$(PKG_NAME)_wcslib$(SHARE) lib$(PKG_NAME)_ems$(SHARE) \
++ lib$(PKG_NAME)_err$(SHARE) lib$(PKG_NAME)_grf$(SHARE) \
++ lib$(PKG_NAME)_pgplot$(SHARE) lib$(PKG_NAME)_slalib$(SHARE) \
++ lib$(PKG_NAME)$(SHARE)
++
++# This library contains the main modules for the package.
++lib$(PKG_NAME)$(SHARE): $(MAIN_OBJECT_FILES)
++ $(BLD_SHR) $@ '$(MAIN_OBJECT_FILES)' '-lm -L. -last_slalib -last_wcslib -last_err'
++
++# This contains the default error reporting system.
++lib$(PKG_NAME)_err$(SHARE): $(ERR_OBJECT_FILES)
++ $(BLD_SHR) $@ '$(ERR_OBJECT_FILES)'
++
++# This contains the EMS-based error reporting system.
++lib$(PKG_NAME)_ems$(SHARE): $(EMS_OBJECT_FILES)
++ $(BLD_SHR) $@ '$(EMS_OBJECT_FILES)' '-L$(STAR_SHARE) -lems'
++
++# This contains the default (null) graphics system.
++lib$(PKG_NAME)_grf$(SHARE): $(GRF_OBJECT_FILES)
++ $(BLD_SHR) $@ '$(GRF_OBJECT_FILES)'
++
++# This contains the PGPLOT-based graphics system.
++lib$(PKG_NAME)_pgplot$(SHARE): $(PGPLOT_OBJECT_FILES)
++ $(BLD_SHR) $@ '$(PGPLOT_OBJECT_FILES)' '-lpgplot -lm'
++
++# This contains the interface between C code and the FORTRAN version of
++# SLALIB.
++lib$(PKG_NAME)_slalib$(SHARE): $(SLALIB_OBJECT_FILES)
++ $(BLD_SHR) $@ '$(SLALIB_OBJECT_FILES)' '-L$(STAR_SHARE) -lsla'
++
++# This contains the code adapted from the wcslib library.
++lib$(PKG_NAME)_wcslib$(SHARE): $(WCSLIB_OBJECT_FILES)
++ $(BLD_SHR) $@ '$(WCSLIB_OBJECT_FILES)' '-lm'
+
+ # Name of the date stamp file. This is used to record the time of the
+ # most recent build for use in subsequent operations that require it.
+@@ -888,8 +888,9 @@
+ #
+ # Form a second link to the main object library. This is used when a second
+ # pass through the library is needed during linking.
+- - rm -f $(INSTALL_LIB)/lib$(PKG_NAME)_pass2.a
++ - rm -f $(INSTALL_LIB)/lib$(PKG_NAME)_pass2.a $(INSTALL_SHARE)/lib$(PKG_NAME)_pass2$(SHARE)
+ cd $(INSTALL_LIB); $(LINK) lib$(PKG_NAME).a lib$(PKG_NAME)_pass2.a
++ cd $(INSTALL_SHARE); $(LINK) lib$(PKG_NAME)$(SHARE) lib$(PKG_NAME)_pass2$(SHARE)
+ #
+ # Install shareable libraries, giving them read permission (unless
+ # they are dummy, zero size, files in which case they are left in
diff --git a/starlink-ast.spec b/starlink-ast.spec
new file mode 100644
index 0000000..a7964de
--- /dev/null
+++ b/starlink-ast.spec
@@ -0,0 +1,102 @@
+Summary: AST - Astrometry and World Coordinate System library
+Summary(pl): AST - biblioteka do astronometrii i systemu współrzędnych ziemskich
+Name: starlink-ast
+Version: 2.0_9.218
+Release: 1
+License: LGPL (wcslib), non-commercial use and distribution (see AST_CONDITIONS)
+Group: Libraries
+Source0: ftp://ftp.starlink.rl.ac.uk/pub/ussc/store/ast/ast.tar.Z
+# Source0-md5: 71dec6919d6dd2bf5656415d2f1fb49c
+Patch0: %{name}-make.patch
+URL: http://www.starlink.rl.ac.uk/static_www/soft_further_AST.html
+BuildRequires: gcc-g77
+BuildRequires: pgplot-devel
+BuildRequires: starlink-ems-devel
+BuildRequires: starlink-sae-devel
+BuildRequires: starlink-sla-devel
+Requires: starlink-sae
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define stardir /usr/lib/star
+
+%description
+The AST library provides a comprehensive range of facilities for
+attaching world coordinate systems to astronomical data, for
+retrieving and interpreting that information and for generating
+graphical output based on it.
+
+%description -l pl
+Biblioteka AST dostarcza wyczerpujący zakres możliwości do
+przywiązywania systemów współrzędnych ziemskich do danych
+astronomicznych, uzyskiwania i interpretowania takich informacji oraz
+do generowania w oparciu o nie grafiki.
+
+%package devel
+Summary: Header files for AST library
+Summary(pl): Pliki nagłówkowe biblioteki AST
+Group: Development/Libraries
+Requires: %{name} = %{version}
+Requires: starlink-ems-devel
+Requires: starlink-sla-devel
+
+%description devel
+Header files for AST library.
+
+%description devel -l pl
+Pliki nagłówkowe biblioteki AST.
+
+%package static
+Summary: Static Starlink AST library
+Summary(pl): Statyczna biblioteka Starlink AST
+Group: Development/Libraries
+Requires: %{name}-devel = %{version}
+
+%description static
+Static Starlink AST library.
+
+%description static -l pl
+Statyczna biblioteka Starlink AST.
+
+%prep
+%setup -q -c
+%patch -p1
+
+%build
+OPT="%{rpmcflags}" \
+SYSTEM=ix86_Linux \
+./mk build \
+ STARLINK=%{stardir} \
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{stardir}/help
+
+SYSTEM=ix86_Linux \
+./mk install \
+ STARLINK=%{stardir} \
+ INSTALL=$RPM_BUILD_ROOT%{stardir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc AST_CONDITIONS ast.news
+%{stardir}/dates/*
+%docdir %{stardir}/docs
+%{stardir}/docs/sun*
+%{stardir}/help/fac*
+%attr(755,root,root) %{stardir}/share/*.so
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{stardir}/bin/ast_dev
+%attr(755,root,root) %{stardir}/bin/ast_link*
+%{stardir}/include/*
+
+%files static
+%defattr(644,root,root,755)
+%{stardir}/lib/*.a