summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcvs2git2009-03-13 20:07:13 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit5082dd56d18b87e91744228eac686b4db74c93bd (patch)
treeea3524453185267d966cd14207a67fbd912560b2
parent383f9989479303ff46e98f46652ab49989c530fb (diff)
downloadsip-DEVEL.zip
sip-DEVEL.tar.gz
This commit was manufactured by cvs2git to create branch 'DEVEL'.DEVEL
Cherrypick from master 2009-03-13 20:07:13 UTC hawk <hawk@pld-linux.org> '- release 2': sip.spec -> 1.74
-rw-r--r--sip.spec106
1 files changed, 106 insertions, 0 deletions
diff --git a/sip.spec b/sip.spec
new file mode 100644
index 0000000..8e94317
--- /dev/null
+++ b/sip.spec
@@ -0,0 +1,106 @@
+# TODO: Check if really v 4.5 is python 2.5 compatible, if so,
+# kill python2.5.patch
+Summary: Python bindings generator for C++ class libraries
+Summary(pl.UTF-8): Generator powiązań Pythona z bibliotekami klas C++
+Name: sip
+Version: 4.7.9
+Release: 2
+Epoch: 2
+License: redistributable (see LICENSE)
+Group: Development/Languages/Python
+Source0: http://www.riverbankcomputing.com/static/Downloads/sip4/sip-%{version}.tar.gz
+# Source0-md5: 597d7ff7edb42a18421c806ffd18a136
+URL: http://www.riverbankcomputing.com/software/sip/
+# Patch0: %{name}-python2.5.patch
+BuildRequires: libstdc++-devel
+BuildRequires: python-devel >= 2.3
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.167
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define _sipfilesdir %{_datadir}/sip
+
+%description
+Generates Python bindings for C++ class libraries from a set of class
+specification files.
+
+%description -l pl.UTF-8
+Generuje powiązania Pythona z bibliotekami klas C++ ze zbioru plików
+ze specyfikacjami klas.
+
+%package -n python-sip
+Summary: Python module needed by generated bindings
+Summary(pl.UTF-8): Moduł Pythona wymagany przez wygenerowane powiązania
+Group: Libraries/Python
+%pyrequires_eq python-libs
+
+%description -n python-sip
+Generates Python bindings for C++ class libraries from a set of class
+specification files. This package includes runtime library needed by
+all generated bindings.
+
+%description -n python-sip -l pl.UTF-8
+Generuje powiązania Pythona z bibliotekami klas C++ ze zbioru plików
+ze specyfikacjami klas. Ten pakiet zawiera bibliotekę potrzebną do
+uruchomienia wszystkich wygenerowanych powiązań.
+
+%package -n python-sip-devel
+Summary: Development files needed to build bindings
+Summary(pl.UTF-8): Pliki programistyczne potrzebne do budowania powiązań
+Group: Development/Libraries
+Requires: %{name} = %{epoch}:%{version}-%{release}
+Requires: python-devel >= 2.3
+%pyrequires_eq python-libs
+
+%description -n python-sip-devel
+Development files needed to build bindings for C++ classes.
+
+%description -n python-sip-devel -l pl.UTF-8
+Pliki programistyczne potrzebne do budowania powiązań z klasami C++.
+
+%prep
+%setup -q
+#%%patch0 -p1
+
+%build
+# configure.py notes:
+# - macros overrides must be last
+# - cannot pass CXXFLAGS+="%{rpmcflags}" or so - builtin -O2 overrides rpmcflags
+python configure.py \
+ -b %{_bindir} \
+ -e %{py_incdir} \
+ -v %{_sipfilesdir} \
+ -d %{py_sitedir} \
+ CC="%{__cc}" \
+ CXX="%{__cxx}" \
+ CFLAGS="%{rpmcflags}" \
+ CXXFLAGS="%{rpmcxxflags}" \
+ LINK="%{__cxx}" \
+ LINK_SHLIB="%{__cxx}"
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_sipfilesdir}
+
+%{__make} install \
+ DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc ChangeLog LICENSE NEWS README TODO doc/*
+%attr(755,root,root) %{_bindir}/*
+
+%files -n python-sip
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py_sitedir}/sip.so
+
+%files -n python-sip-devel
+%defattr(644,root,root,755)
+%{py_sitedir}/sip*.py
+%{py_incdir}/*.h
+%dir %{_sipfilesdir}