summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Gołaszewski2001-12-07 21:33:49 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit808364052bc51e83632f2188d64291715e599ae5 (patch)
tree7d9de2a716306b949f6d9bb125ffa24c9d040b3e
parent36f94478019cb9dfec9e396590d0e7c22728090b (diff)
downloadqps-808364052bc51e83632f2188d64291715e599ae5.zip
qps-808364052bc51e83632f2188d64291715e599ae5.tar.gz
- partialy fixes building
Changed files: qps-makefile.patch -> 1.1
-rw-r--r--qps-makefile.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/qps-makefile.patch b/qps-makefile.patch
new file mode 100644
index 0000000..fece218
--- /dev/null
+++ b/qps-makefile.patch
@@ -0,0 +1,30 @@
+--- ./Makefile.org Tue Apr 4 18:34:06 2000
++++ ./Makefile Fri Dec 7 22:32:14 2001
+@@ -4,7 +4,8 @@
+ # First, make sure INCLUDES and LDPATHS lines contain paths to the include
+ # and library directories for Qt.
+ #
+-INCLUDES=-I$(QTDIR)/include
++QTDIR=/usr/X11R6
++INCLUDES=-I$(QTDIR)/include/qt
+ LDPATHS=-L$(QTDIR)/lib
+
+ #
+@@ -20,7 +21,7 @@
+ # if moc (the Qt meta object compiler) is not in your $PATH, you might need
+ # to specify its location here.
+ #
+-MOC=$(QTDIR)/bin/moc
++MOC=moc
+
+ #
+ # Your C++-compiler here.
+@@ -32,7 +33,7 @@
+ # line. Qps runs on MOSIX systems without it, but this gives it added
+ # functionality. See http://www.mosix.cs.huji.ac.il/ for more info.
+ #
+-#MOSIX=-DMOSIX
++MOSIX=-DMOSIX
+
+ # You may need -fno-rtti in CXXFLAGS to compile with recent gcc/egcs versions.
+ CXXFLAGS= -g $(MOSIX) -O2 -Wall -W -Wconversion $(INCLUDES)