summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Rękorajski2018-06-06 06:43:40 (GMT)
committerJan Rękorajski2018-06-06 06:43:40 (GMT)
commitd8ccba758b75a048440b4d69c1ef384325a65630 (patch)
treee86631fb52c692816fe3dd05d56e2d1b6e59da22
parentded1f0a9aac6652951fc626092232b416d7748e2 (diff)
downloadprotobuf-d8ccba758b75a048440b4d69c1ef384325a65630.zip
protobuf-d8ccba758b75a048440b4d69c1ef384325a65630.tar.gz
- stop messing with memcpy version, we don't care and it breaks build on x32
- rel 2
-rw-r--r--no-wrap-memcpy.patch21
-rw-r--r--protobuf.spec8
2 files changed, 24 insertions, 5 deletions
diff --git a/no-wrap-memcpy.patch b/no-wrap-memcpy.patch
new file mode 100644
index 0000000..ed20e7a
--- /dev/null
+++ b/no-wrap-memcpy.patch
@@ -0,0 +1,21 @@
+--- protobuf-3.5.1.1/ruby/ext/google/protobuf_c/extconf.rb~ 2018-01-05 22:42:10.000000000 +0100
++++ protobuf-3.5.1.1/ruby/ext/google/protobuf_c/extconf.rb 2018-06-06 08:25:28.643970843 +0200
+@@ -2,16 +2,10 @@
+
+ require 'mkmf'
+
+-$CFLAGS += " -std=c99 -O3 -DNDEBUG"
++$CFLAGS += " -std=c99 -DNDEBUG"
+
+
+-if RUBY_PLATFORM =~ /linux/
+- # Instruct the linker to point memcpy calls at our __wrap_memcpy wrapper.
+- $LDFLAGS += " -Wl,-wrap,memcpy"
+-end
+-
+ $objs = ["protobuf.o", "defs.o", "storage.o", "message.o",
+- "repeated_field.o", "map.o", "encode_decode.o", "upb.o",
+- "wrap_memcpy.o"]
++ "repeated_field.o", "map.o", "encode_decode.o", "upb.o"]
+
+ create_makefile("google/protobuf_c")
diff --git a/protobuf.spec b/protobuf.spec
index fc7744c..69512dd 100644
--- a/protobuf.spec
+++ b/protobuf.spec
@@ -9,15 +9,11 @@
%bcond_without ruby # Ruby bindings
%bcond_without tests # perform "make check"
-%ifarch x32
-%undefine with_ruby
-%endif
-
Summary: Protocol Buffers - Google's data interchange format
Summary(pl.UTF-8): Protocol Buffers - format wymiany danych Google
Name: protobuf
Version: 3.5.1.1
-Release: 1
+Release: 2
License: BSD
Group: Libraries
#Source0Download: https://github.com/google/protobuf/releases
@@ -25,6 +21,7 @@ Source0: https://github.com/google/protobuf/archive/v%{version}/%{name}-%{versio
# Source0-md5: 5005003ae6b94773c4bbca87a644b131
Source1: ftdetect-proto.vim
Patch0: system-gtest.patch
+Patch1: no-wrap-memcpy.patch
URL: https://github.com/google/protobuf/
BuildRequires: autoconf >= 2.59
BuildRequires: automake >= 1:1.9
@@ -208,6 +205,7 @@ opisów buforów protokołowych (Protocol Buffers).
%prep
%setup -q
%patch0 -p1
+%patch1 -p1
ln -s /usr/src/gmock/src/gmock*.cc src