summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2021-01-19 05:30:48 (GMT)
committerJakub Bogusz2021-01-19 05:30:48 (GMT)
commit810b501560a1db36f0a8b2942195a1f22acf65d3 (patch)
tree6658c5b9b93bbcc0ec94cae14c36c66c06991e59
parent6085fc9793b6c634cb843ac57a49a3d0e5f37503 (diff)
downloadprotobuf-810b501560a1db36f0a8b2942195a1f22acf65d3.zip
protobuf-810b501560a1db36f0a8b2942195a1f22acf65d3.tar.gz
- updated to 3.14.0 (new sonames)auto/th/protobuf-3.14.0-1
- removed obsolete no-wheel patch - added disable-64bitptr-test patch (applied on 32-bit targets: disable test which requires >4GB buffer)
-rw-r--r--protobuf-disable-64bitptr-test.patch23
-rw-r--r--protobuf-no-wheel.patch10
-rw-r--r--protobuf.spec20
3 files changed, 34 insertions, 19 deletions
diff --git a/protobuf-disable-64bitptr-test.patch b/protobuf-disable-64bitptr-test.patch
new file mode 100644
index 0000000..312a485
--- /dev/null
+++ b/protobuf-disable-64bitptr-test.patch
@@ -0,0 +1,23 @@
+--- protobuf-3.14.0/src/google/protobuf/io/zero_copy_stream_unittest.cc.orig 2020-11-13 23:55:22.000000000 +0100
++++ protobuf-3.14.0/src/google/protobuf/io/zero_copy_stream_unittest.cc 2021-01-18 21:39:55.771550717 +0100
+@@ -712,20 +712,6 @@
+ }
+ }
+
+-// Verifies that outputs up to kint32max can be created.
+-TEST_F(IoTest, LargeOutput) {
+- std::string str;
+- StringOutputStream output(&str);
+- void* unused_data;
+- int size;
+- // Repeatedly calling Next should eventually grow the buffer to kint32max.
+- do {
+- EXPECT_TRUE(output.Next(&unused_data, &size));
+- } while (str.size() < std::numeric_limits<int>::max());
+- // Further increases should be possible.
+- output.Next(&unused_data, &size);
+- EXPECT_GT(size, 0);
+-}
+
+
+ // To test files, we create a temporary file, write, read, truncate, repeat.
diff --git a/protobuf-no-wheel.patch b/protobuf-no-wheel.patch
deleted file mode 100644
index 4b9a288..0000000
--- a/protobuf-no-wheel.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- protobuf-3.13.0/python/setup.py.orig 2020-08-15 01:24:06.000000000 +0200
-+++ protobuf-3.13.0/python/setup.py 2020-09-08 21:07:02.277138265 +0200
-@@ -279,7 +279,6 @@
- 'build_py': build_py,
- 'test_conformance': test_conformance,
- },
-- setup_requires = ['wheel'],
- install_requires=install_requires,
- ext_modules=ext_module_list,
- )
diff --git a/protobuf.spec b/protobuf.spec
index 3d209b5..0c855c1 100644
--- a/protobuf.spec
+++ b/protobuf.spec
@@ -7,23 +7,23 @@
%bcond_without python2 # Python 2.x bindings
%bcond_without python3 # Python 3.x bindings
%bcond_without ruby # Ruby bindings
-%bcond_without tests # perform "make check"
+%bcond_without tests # perform "make check" (requires 4+GB RAM on 64-bit archs)
Summary: Protocol Buffers - Google's data interchange format
Summary(pl.UTF-8): Protocol Buffers - format wymiany danych Google
Name: protobuf
-Version: 3.13.0
-Release: 3
+Version: 3.14.0
+Release: 1
License: BSD
Group: Libraries
#Source0Download: https://github.com/google/protobuf/releases
Source0: https://github.com/google/protobuf/releases/download/v%{version}/%{name}-all-%{version}.tar.gz
-# Source0-md5: cafa623d51361228c83c874d95f51992
+# Source0-md5: d0a7dd930210af5285c08c8a2c2304ab
Source1: ftdetect-proto.vim
Patch0: system-gtest.patch
Patch1: no-wrap-memcpy.patch
-Patch2: %{name}-no-wheel.patch
-Patch3: %{name}-x32.patch
+Patch2: %{name}-x32.patch
+Patch3: %{name}-disable-64bitptr-test.patch
URL: https://github.com/google/protobuf/
BuildRequires: autoconf >= 2.59
BuildRequires: automake >= 1:1.9
@@ -211,7 +211,9 @@ opisów buforów protokołowych (Protocol Buffers).
%patch0 -p1
%patch1 -p1
%patch2 -p1
+%ifnarch %{x8664} aarch64 alpha ia64 mips64 ppc64 s390x sparc64
%patch3 -p1
+%endif
%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' \
examples/add_person.py \
@@ -309,17 +311,17 @@ rm -rf $RPM_BUILD_ROOT
%doc CHANGES.txt CONTRIBUTORS.txt LICENSE README.md
%attr(755,root,root) %{_bindir}/protoc
%attr(755,root,root) %{_libdir}/libprotoc.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libprotoc.so.24
+%attr(755,root,root) %ghost %{_libdir}/libprotoc.so.25
%files libs
%defattr(644,root,root,755)
%attr(755,root,root) %{_libdir}/libprotobuf.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libprotobuf.so.24
+%attr(755,root,root) %ghost %{_libdir}/libprotobuf.so.25
%files lite
%defattr(644,root,root,755)
%attr(755,root,root) %{_libdir}/libprotobuf-lite.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libprotobuf-lite.so.24
+%attr(755,root,root) %ghost %{_libdir}/libprotobuf-lite.so.25
%files devel
%defattr(644,root,root,755)