summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2014-10-14 15:59:43 (GMT)
committerJakub Bogusz2014-10-14 15:59:43 (GMT)
commit72bc381c4a534ff630f1491f1f0b1f3093aa1a97 (patch)
tree95fc77635d300731bf069ce3112e2b4c66ca50aa
parent36397081275917744037e3ac1cfe1d1a86fe83ae (diff)
downloadprotobuf-72bc381c4a534ff630f1491f1f0b1f3093aa1a97.zip
protobuf-72bc381c4a534ff630f1491f1f0b1f3093aa1a97.tar.gz
- new URLs, updated to 2.6.0auto/th/protobuf-2.6.0-1
- updated system-gtest patch
-rw-r--r--protobuf.spec28
-rw-r--r--system-gtest.patch22
2 files changed, 25 insertions, 25 deletions
diff --git a/protobuf.spec b/protobuf.spec
index 82aae87..601d456 100644
--- a/protobuf.spec
+++ b/protobuf.spec
@@ -8,23 +8,23 @@
Summary: Protocol Buffers - Google's data interchange format
Summary(pl.UTF-8): Protocol Buffers - format wymiany danych Google
Name: protobuf
-Version: 2.5.0
-Release: 2
+Version: 2.6.0
+Release: 1
License: BSD
Group: Libraries
-#Source0Download: http://code.google.com/p/protobuf/downloads/list
-Source0: http://protobuf.googlecode.com/files/%{name}-%{version}.tar.bz2
-# Source0-md5: a72001a9067a4c2c4e0e836d0f92ece4
+Source0: https://github.com/google/protobuf/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 99d5f73dcd473594bf8f245d7b0cfb77
Source1: ftdetect-proto.vim
Patch0: system-gtest.patch
-URL: http://code.google.com/p/protobuf/
-BuildRequires: autoconf
+URL: https://github.com/google/protobuf/
+BuildRequires: autoconf >= 2.59
BuildRequires: automake
%{?with_tests:BuildRequires: gtest-devel}
BuildRequires: libstdc++-devel
+BuildRequires: libtool
BuildRequires: pkgconfig
BuildRequires: rpmbuild(macros) >= 1.219
-BuildRequires: zlib-devel
+BuildRequires: zlib-devel >= 1.2.0.4
%if %{with python}
BuildRequires: python-setuptools
BuildRequires: rpm-pythonprov
@@ -71,6 +71,7 @@ języków programowania.
Summary: Protocol Buffers library
Summary(pl.UTF-8): Biblioteka buforów protokołowych (Protocol Buffers)
Group: Libraries
+Requires: zlib >= 1.2.0.4
%description libs
Protocol Buffers library.
@@ -158,11 +159,12 @@ opisów buforów protokołowych (Protocol Buffers).
%prep
%setup -q
%patch0 -p1
-%{__rm} -r gtest
%build
+%{__libtoolize}
%{__aclocal} -I m4
%{__autoconf}
+%{__autoheader}
%{__automake}
# Additional variables defined according to https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=192821
%configure \
@@ -221,20 +223,20 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(644,root,root,755)
-%doc CHANGES.txt CONTRIBUTORS.txt README.txt
+%doc CHANGES.txt CONTRIBUTORS.txt COPYING.txt README.txt
%attr(755,root,root) %{_bindir}/protoc
%attr(755,root,root) %{_libdir}/libprotoc.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libprotoc.so.8
+%attr(755,root,root) %ghost %{_libdir}/libprotoc.so.9
%files libs
%defattr(644,root,root,755)
%attr(755,root,root) %{_libdir}/libprotobuf.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libprotobuf.so.8
+%attr(755,root,root) %ghost %{_libdir}/libprotobuf.so.9
%files lite
%defattr(644,root,root,755)
%attr(755,root,root) %{_libdir}/libprotobuf-lite.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libprotobuf-lite.so.8
+%attr(755,root,root) %ghost %{_libdir}/libprotobuf-lite.so.9
%files devel
%defattr(644,root,root,755)
diff --git a/system-gtest.patch b/system-gtest.patch
index 3ae0f5b..501a0b4 100644
--- a/system-gtest.patch
+++ b/system-gtest.patch
@@ -57,10 +57,9 @@ diff -up protobuf-2.3.0/Makefile.am.orig protobuf-2.3.0/Makefile.am
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = protobuf.pc protobuf-lite.pc
-diff -up protobuf-2.3.0/src/Makefile.am.orig protobuf-2.3.0/src/Makefile.am
---- protobuf-2.3.0/src/Makefile.am.orig 2010-04-21 18:56:57.342268786 -0600
-+++ protobuf-2.3.0/src/Makefile.am 2010-04-21 20:02:40.168268698 -0600
-@@ -276,10 +276,8 @@ COMMON_TEST_SOURCES =
+--- protobuf-2.6.1/src/Makefile.am.orig 2014-10-11 07:50:39.000000000 +0200
++++ protobuf-2.6.1/src/Makefile.am 2014-10-13 21:17:00.879286908 +0200
+@@ -325,10 +325,8 @@
check_PROGRAMS = protoc protobuf-test protobuf-lazy-descriptor-test \
protobuf-lite-test test_plugin $(GZCHECKPROGRAMS)
protobuf_test_LDADD = $(PTHREAD_LIBS) libprotobuf.la libprotoc.la \
@@ -73,21 +72,20 @@ diff -up protobuf-2.3.0/src/Makefile.am.orig protobuf-2.3.0/src/Makefile.am
# Disable optimization for tests unless the user explicitly asked for it,
# since test_util.cc takes forever to compile with optimization (with GCC).
# See configure.ac for more info.
-@@ -319,11 +317,8 @@ nodist_protobuf_test_SOURCES = $(protoc_
-
+@@ -375,10 +373,8 @@
# Run cpp_unittest again with PROTOBUF_TEST_NO_DESCRIPTORS defined.
protobuf_lazy_descriptor_test_LDADD = $(PTHREAD_LIBS) libprotobuf.la \
-- $(top_builddir)/gtest/lib/libgtest.la \
+ libprotoc.la \
+- $(top_builddir)/gtest/lib/libgtest.la \
- $(top_builddir)/gtest/lib/libgtest_main.la
-protobuf_lazy_descriptor_test_CPPFLAGS = -I$(top_srcdir)/gtest/include \
- -I$(top_builddir)/gtest/include \
-- -DPROTOBUF_TEST_NO_DESCRIPTORS
-+ -lgtest -lgtest_main
-+protobuf_lazy_descriptor_test_CPPFLAGS = -DPROTOBUF_TEST_NO_DESCRIPTORS
++ -lgtest -lgtest_main
++protobuf_lazy_descriptor_test_CPPFLAGS = \
+ -DPROTOBUF_TEST_NO_DESCRIPTORS
protobuf_lazy_descriptor_test_CXXFLAGS = $(NO_OPT_CXXFLAGS)
protobuf_lazy_descriptor_test_SOURCES = \
- google/protobuf/compiler/cpp/cpp_unittest.cc \
-@@ -341,7 +336,7 @@ nodist_protobuf_lite_test_SOURCES = $(pr
+@@ -397,7 +393,7 @@
# Test plugin binary.
test_plugin_LDADD = $(PTHREAD_LIBS) libprotobuf.la libprotoc.la \