summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2024-02-17 15:06:36 (GMT)
committerJakub Bogusz2024-02-17 15:06:36 (GMT)
commit84120e83f0ff607ea430f007c116be9022e8a698 (patch)
tree8d01aed5b7e855438b0754643fd879057096ecd0
parentac7b4bfa687ad783add293bfc6e3635565a93430 (diff)
downloadplymouth-84120e83f0ff607ea430f007c116be9022e8a698.zip
plymouth-84120e83f0ff607ea430f007c116be9022e8a698.tar.gz
- updated to 24.004.60; uses meson nowauto/th/plymouth-24.004.60-1
-rw-r--r--plymouth-glibc.patch10
-rw-r--r--plymouth-link.patch11
-rw-r--r--plymouth-paths.patch38
-rw-r--r--plymouth-systemd-prefix.patch10
-rw-r--r--plymouth.spec104
-rw-r--r--plymouth.tmpfiles1
-rw-r--r--text-colors.patch28
7 files changed, 120 insertions, 82 deletions
diff --git a/plymouth-glibc.patch b/plymouth-glibc.patch
deleted file mode 100644
index 27392a3..0000000
--- a/plymouth-glibc.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- plymouth-22.02.122/src/libply/ply-utils.c.orig 2021-10-27 22:22:15.000000000 +0200
-+++ plymouth-22.02.122/src/libply/ply-utils.c 2022-08-27 21:29:43.083131469 +0200
-@@ -46,7 +46,6 @@
- #include <sys/user.h>
- #include <sys/wait.h>
- #include <time.h>
--#include <linux/fs.h>
- #include <linux/vt.h>
-
- #include <dlfcn.h>
diff --git a/plymouth-link.patch b/plymouth-link.patch
deleted file mode 100644
index 7a7eec8..0000000
--- a/plymouth-link.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- plymouth-0.9.5/src/libply-splash-graphics/Makefile.am.orig 2020-06-15 16:16:47.000000000 +0200
-+++ plymouth-0.9.5/src/libply-splash-graphics/Makefile.am 2020-07-20 22:30:24.853900043 +0200
-@@ -26,7 +26,7 @@
- -DPLYMOUTH_BACKGROUND_END_COLOR=$(background_end_color) \
- -DPLYMOUTH_BACKGROUND_START_COLOR=$(background_start_color) \
- -DPLYMOUTH_PLUGIN_PATH=\"$(PLYMOUTH_PLUGIN_PATH)\"
--libply_splash_graphics_la_LIBADD = $(PLYMOUTH_LIBS) $(IMAGE_LIBS) ../libply/libply.la ../libply-splash-core/libply-splash-core.la
-+libply_splash_graphics_la_LIBADD = ../libply/libply.la ../libply-splash-core/libply-splash-core.la $(PLYMOUTH_LIBS) $(IMAGE_LIBS)
- libply_splash_graphics_la_LDFLAGS = -export-symbols-regex '^[^_].*' \
- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
- -no-undefined
diff --git a/plymouth-paths.patch b/plymouth-paths.patch
new file mode 100644
index 0000000..f3812b0
--- /dev/null
+++ b/plymouth-paths.patch
@@ -0,0 +1,38 @@
+--- plymouth-24.004.60/meson_options.txt.orig 2024-01-04 22:08:14.000000000 +0100
++++ plymouth-24.004.60/meson_options.txt 2024-02-17 07:49:24.640032483 +0100
+@@ -83,3 +83,8 @@ option('docs',
+ value: true,
+ description: 'Build documentation',
+ )
++option('systemd_ask_password_agent_path',
++ type: 'string',
++ value: '',
++ description: 'path to systemd-tty-ask-password-agent',
++)
+--- plymouth-24.004.60/systemd-units/meson.build.orig 2024-01-04 22:08:14.000000000 +0100
++++ plymouth-24.004.60/systemd-units/meson.build 2024-02-17 07:51:17.026090302 +0100
+@@ -21,7 +21,7 @@ foreach unit_templ : systemd_unit_templa
+ 'PLYMOUTH_CLIENT_DIR': get_option('prefix') / get_option('bindir'),
+ 'PLYMOUTH_DAEMON_DIR': get_option('prefix') / get_option('sbindir'),
+ 'plymouthruntimedir': plymouth_runtime_dir,
+- 'SYSTEMD_ASK_PASSWORD_AGENT': systemd_ask_password_agent.full_path(),
++ 'SYSTEMD_ASK_PASSWORD_AGENT': systemd_ask_password_agent_path,
+ },
+ install: true,
+ install_dir: systemd_unit_dir,
+--- plymouth-24.004.60/meson.build.orig 2024-02-17 07:52:35.985662541 +0100
++++ plymouth-24.004.60/meson.build 2024-02-17 07:52:39.992307502 +0100
+@@ -44,7 +44,12 @@ if get_option('systemd-integration')
+ systemd_unit_dir = systemd_dep.get_variable('systemdsystemunitdir',
+ pkgconfig_define: [ 'rootprefix', get_option('prefix') ],
+ )
+- systemd_ask_password_agent = find_program('systemd-tty-ask-password-agent')
++ if get_option('systemd_ask_password_agent_path') == ''
++ systemd_ask_password_agent = find_program('systemd-tty-ask-password-agent')
++ systemd_ask_password_agent_path = systemd_ask_password_agent.full_path()
++ else
++ systemd_ask_password_agent_path = get_option('systemd_ask_password_agent_path')
++ endif
+ endif
+
+ if get_option('upstart-monitoring')
diff --git a/plymouth-systemd-prefix.patch b/plymouth-systemd-prefix.patch
new file mode 100644
index 0000000..d61ac3d
--- /dev/null
+++ b/plymouth-systemd-prefix.patch
@@ -0,0 +1,10 @@
+--- plymouth-24.004.60/meson.build.orig 2024-02-17 14:27:42.077235621 +0100
++++ plymouth-24.004.60/meson.build 2024-02-17 14:33:58.655195523 +0100
+@@ -42,7 +42,6 @@ xkeyboard_config_dep = dependency('xkeyb
+ if get_option('systemd-integration')
+ systemd_dep = dependency('systemd')
+ systemd_unit_dir = systemd_dep.get_variable('systemdsystemunitdir',
+- pkgconfig_define: [ 'rootprefix', get_option('prefix') ],
+ )
+ if get_option('systemd_ask_password_agent_path') == ''
+ systemd_ask_password_agent = find_program('systemd-tty-ask-password-agent')
diff --git a/plymouth.spec b/plymouth.spec
index 0fab5d6..8e8de6e 100644
--- a/plymouth.spec
+++ b/plymouth.spec
@@ -9,38 +9,41 @@
Summary: Graphical Boot Animation and Logger
Summary(pl.UTF-8): Graficzna animacja i logowanie startu systemu
Name: plymouth
-Version: 22.02.122
+Version: 24.004.60
Release: 1
License: GPL v2+
Group: Base
Source0: https://www.freedesktop.org/software/plymouth/releases/%{name}-%{version}.tar.xz
-# Source0-md5: 07281db83aa3132f7941f4d0b277a68e
+# Source0-md5: 6a6d6ec1a6d6e9bd776f368619864949
Source1: %{name}-logo.png
# Source1-md5: 6b38a868585adfd3a96a4ad16973c1f8
-Source2: %{name}.tmpfiles
-Source4: boot-duration
-Source6: %{name}-update-initrd
+Source2: boot-duration
+Source3: %{name}-update-initrd
Patch0: text-colors.patch
Patch1: %{name}-restore-suspend.patch
-Patch2: %{name}-link.patch
-Patch3: %{name}-glibc.patch
+# allow to specify systemd-tty-ask-password-agent path even if not installed at build time
+Patch2: %{name}-paths.patch
+Patch3: %{name}-systemd-prefix.patch
URL: https://www.freedesktop.org/wiki/Software/Plymouth
-BuildRequires: autoconf >= 2.50
-BuildRequires: automake >= 1:1.11
BuildRequires: cairo-devel
BuildRequires: docbook-dtd42-xml
BuildRequires: docbook-style-xsl-nons
+BuildRequires: freetype-devel >= 2.0
BuildRequires: gettext-tools >= 0.19.8
BuildRequires: gtk+3-devel >= 3.14.0
%{?with_drm:BuildRequires: libdrm-devel}
+BuildRequires: libevdev-devel
BuildRequires: libpng-devel >= 2:1.2.16
-BuildRequires: libtool >= 2:2
BuildRequires: libxslt-progs
+BuildRequires: meson >= 0.61
+BuildRequires: ninja >= 1.5
BuildRequires: pango-devel >= 1:1.21.0
BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.736
BuildRequires: systemd-units
BuildRequires: udev-devel
-BuildRequires: xorg-lib-libpciaccess-devel
+BuildRequires: xkeyboard-config
+BuildRequires: xorg-lib-libxkbcommon-devel
Requires: %{name}-graphics-libs = %{version}-%{release}
Requires(post): %{name}-scripts = %{version}-%{release}
Requires: /etc/os-release
@@ -161,12 +164,12 @@ Group: Base
Requires: %{name}-graphics-libs = %{version}-%{release}
%description plugin-label
-This package contains the label control plugin for Plymouth. It
-provides the ability to render text on graphical boot splashes using
+This package contains the label control plugins for Plymouth. They
+provide the ability to render text on graphical boot splashes using
pango and cairo.
%description plugin-label -l pl.UTF-8
-Ten pakiet zawiera wtyczkę Plymouth sterującą etykietami. Daje ona
+Ten pakiet zawiera wtyczki Plymouth sterujące etykietami. Dają one
możliwość renderowania tekstu na graficznych ekranach startowych przy
użyciu bibliotek pango i cairo.
@@ -359,62 +362,44 @@ Odznacza się on małym kółkiem kręcącym się na ciemnym tle.
%patch3 -p1
# Change the default theme
-%{__sed} -i -e 's/Theme=.*/Theme=tribar/ig' -e 's/ShowDelay=.*//ig' src/plymouthd.defaults
+%{__sed} -i -e 's/Theme=.*/Theme=tribar/' -e 's/ShowDelay=.*//' src/plymouthd.defaults
%build
-#{__autopoint}
-%{__libtoolize}
-%{__aclocal} -I m4
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-%configure \
- UDEVADM=/sbin/udevadm \
- SYSTEMD_ASK_PASSWORD_AGENT=/bin/systemd-tty-ask-password-agent \
- --enable-static \
- %{__enable_disable drm drm} \
- --disable-silent-rules \
- --enable-documentation \
- --enable-systemd-integration \
- --enable-tracing \
- --without-rhgb-compat-link \
- --with-background-start-color-stop=0x009431 \
- --with-background-end-color-stop=0x006300 \
- --with-background-color=0x00c663 \
- --with-logo=%{_pixmapsdir}/plymouth-logo.png \
- --with-release-file=/etc/os-release \
- --with-system-root-install
-
-%{__make}
+%meson build \
+ -Dbackground-color=0x00c663 \
+ -Dbackground-start-color-stop=0x009431 \
+ -Dbackground-end-color-stop=0x006300 \
+ %{!?with_drm:-Ddrm=false} \
+ -Dlogo=%{_pixmapsdir}/plymouth-logo.png \
+ -Drelease-file=/etc/os-release \
+ -Dsystemd_ask_password_agent_path=/bin/systemd-tty-ask-password-agent
+
+%ninja_build -C build
%install
rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{systemdtmpfilesdir}}
+install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{systemdtmpfilesdir}}
+
+# meson/ninja symlinking requires target file to be already present
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}/plymouth-logo.png
-%{__make} install \
- DESTDIR=$RPM_BUILD_ROOT
+%ninja_install -C build
+# meson-based plymouth build doesn't support installing into split /usr
+install -d $RPM_BUILD_ROOT{/%{_lib},/bin,/sbin}
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/plymouth $RPM_BUILD_ROOT/bin
+%{__mv} $RPM_BUILD_ROOT%{_sbindir}/plymouthd $RPM_BUILD_ROOT/sbin
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/libply.so.* $RPM_BUILD_ROOT/%{_lib}
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/libply-splash-core.so.* $RPM_BUILD_ROOT/%{_lib}
ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libply.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libply.so
ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libply-splash-core.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libply-splash-core.so
-%{__rm} $RPM_BUILD_ROOT/%{_lib}/libply{,-splash-core}.so
install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/plymouth
-cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_datadir}/plymouth/default-boot-duration
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/plymouth/default-boot-duration
> $RPM_BUILD_ROOT%{_localstatedir}/lib/plymouth/boot-duration
# Override plymouth-update-initrd to work with dracut or mkinitrd
-cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_libexecdir}/plymouth/plymouth-update-initrd
-
-%{__rm} $RPM_BUILD_ROOT{/%{_lib},%{_libdir}}/*.la \
- $RPM_BUILD_ROOT%{_libdir}/plymouth/*.{a,la} \
- $RPM_BUILD_ROOT%{_libdir}/plymouth/renderers/*.{a,la}
-
-%{__mv} $RPM_BUILD_ROOT/%{_lib}/{libply,libply-splash-core}.a $RPM_BUILD_ROOT%{_libdir}
-
-install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/plymouth
-
-cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}/plymouth-logo.png
-cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_libexecdir}/plymouth/plymouth-update-initrd
ln -s plymouth-logo.png $RPM_BUILD_ROOT%{_pixmapsdir}/system-logo-white.png
@@ -439,7 +424,7 @@ fi
%files -f %{name}.lang
%defattr(644,root,root,755)
-%doc AUTHORS README TODO
+%doc AUTHORS README.md
%dir %{_sysconfdir}/plymouth
%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/plymouth/plymouthd.conf
%{_mandir}/man8/plymouth.8*
@@ -466,10 +451,8 @@ fi
%{_datadir}/plymouth/themes/tribar/tribar.plymouth
%{_pixmapsdir}/plymouth-logo.png
%{_pixmapsdir}/system-logo-white.png
-%{systemdtmpfilesdir}/%{name}.conf
%dir %{_localstatedir}/lib/plymouth
%ghost %{_localstatedir}/lib/plymouth/boot-duration
-%{_localstatedir}/run/plymouth
%{_localstatedir}/spool/plymouth
%{_mandir}/man1/plymouth.1*
%{_mandir}/man8/plymouthd.8*
@@ -551,7 +534,8 @@ fi
%files plugin-label
%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/plymouth/label.so
+%attr(755,root,root) %{_libdir}/plymouth/label-freetype.so
+%attr(755,root,root) %{_libdir}/plymouth/label-pango.so
%files plugin-script
%defattr(644,root,root,755)
diff --git a/plymouth.tmpfiles b/plymouth.tmpfiles
deleted file mode 100644
index 6422754..0000000
--- a/plymouth.tmpfiles
+++ /dev/null
@@ -1 +0,0 @@
-d /var/run/plymouth 0755 root root -
diff --git a/text-colors.patch b/text-colors.patch
index bf14387..0dfb91e 100644
--- a/text-colors.patch
+++ b/text-colors.patch
@@ -31,3 +31,31 @@
ply_text_display_set_background_color (view->display,
PLY_TERMINAL_COLOR_BLACK);
+--- plymouth-24.004.60/src/plugins/splash/tribar/meson.build.orig 2024-01-04 22:08:14.000000000 +0100
++++ plymouth-24.004.60/src/plugins/splash/tribar/meson.build 2024-02-17 09:44:34.175933648 +0100
+@@ -3,6 +3,11 @@ tribar_plugin = shared_module('tribar',
+ dependencies: [
+ libply_splash_core_dep,
+ ],
++ c_args: [
++ '-DPLYMOUTH_BACKGROUND_COLOR=@0@'.format(get_option('background-color')),
++ '-DPLYMOUTH_BACKGROUND_START_COLOR=@0@'.format(get_option('background-start-color-stop')),
++ '-DPLYMOUTH_BACKGROUND_END_COLOR=@0@'.format(get_option('background-end-color-stop')),
++ ],
+ include_directories: config_h_inc,
+ name_prefix: '',
+ install: true,
+--- plymouth-24.004.60/src/plugins/splash/text/meson.build.orig 2024-01-04 22:08:14.000000000 +0100
++++ plymouth-24.004.60/src/plugins/splash/text/meson.build 2024-02-17 09:41:08.590380734 +0100
+@@ -4,6 +4,11 @@ text_plugin = shared_module('text',
+ libply_splash_core_dep,
+ libply_splash_graphics_dep,
+ ],
++ c_args: [
++ '-DPLYMOUTH_BACKGROUND_COLOR=@0@'.format(get_option('background-color')),
++ '-DPLYMOUTH_BACKGROUND_START_COLOR=@0@'.format(get_option('background-start-color-stop')),
++ '-DPLYMOUTH_BACKGROUND_END_COLOR=@0@'.format(get_option('background-end-color-stop')),
++ ],
+ include_directories: config_h_inc,
+ name_prefix: '',
+ install: true,