summaryrefslogtreecommitdiff
path: root/fix-test-run.patch
diff options
context:
space:
mode:
authorElan Ruusamäe2014-04-27 12:08:12 (GMT)
committerElan Ruusamäe2014-04-27 12:08:24 (GMT)
commit5dd69fe13236e68d8f381dbbbee52b9bc817c076 (patch)
tree4e5392cf190d35cbc1b68b3bbdab7c6a48c88eb1 /fix-test-run.patch
parent3790806ad7e619390fb9e7bd31b20187d283e18f (diff)
downloadphp-5dd69fe13236e68d8f381dbbbee52b9bc817c076.zip
php-5dd69fe13236e68d8f381dbbbee52b9bc817c076.tar.gz
rediff fix-test-run.patch
Diffstat (limited to 'fix-test-run.patch')
-rw-r--r--fix-test-run.patch25
1 files changed, 7 insertions, 18 deletions
diff --git a/fix-test-run.patch b/fix-test-run.patch
index 3de5b43..feb4cb4 100644
--- a/fix-test-run.patch
+++ b/fix-test-run.patch
@@ -12,19 +12,19 @@
PHP_SUBST_OLD(PHP_INSTALLED_SAPIS)
PHP_SUBST(PHP_EXECUTABLE)
---- php-5.5.0alpha2/Makefile.global~ 2013-01-02 15:26:29.000000000 +0200
-+++ php-5.5.0alpha2/Makefile.global 2013-01-02 15:29:53.064968422 +0200
-@@ -77,7 +77,8 @@
+--- php-5.5.11.pre/Makefile.global 2014-04-27 15:04:43.224682666 +0300
++++ php-5.5.11/Makefile.global 2014-04-27 15:05:38.963814051 +0300
+@@ -81,7 +81,8 @@
done; \
fi
-PHP_TEST_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1'
+PHP_TEST_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1' -d 'safe_mode=0'
-+PHP_TEST_SHARED_SYSTEM_EXTENSIONS = pcre
++PHP_TEST_SHARED_SYSTEM_EXTENSIONS =
PHP_TEST_SHARED_EXTENSIONS = ` \
if test "x$(PHP_MODULES)" != "x"; then \
for i in $(PHP_MODULES)""; do \
-@@ -88,6 +89,12 @@
+@@ -92,6 +93,12 @@
for i in $(PHP_ZEND_EX)""; do \
. $$i; $(top_srcdir)/build/shtool echo -n -- " -d $(ZEND_EXT_TYPE)=$(top_builddir)/modules/$$dlname"; \
done; \
@@ -35,9 +35,9 @@
+ $(top_srcdir)/build/shtool echo -n -- " -d extension=$(EXTENSION_DIR)/$$dlname"; \
+ done; \
fi`
- PHP_DEPRECATED_DIRECTIVES_REGEX = '^(define_syslog_variables|register_(globals|long_arrays)?|safe_mode|magic_quotes_(gpc|runtime|sybase)?|(zend_)?extension(_debug)?(_ts)?)[\t\ ]*='
+ PHP_DEPRECATED_DIRECTIVES_REGEX = '^(magic_quotes_(gpc|runtime|sybase)?|(zend_)?extension(_debug)?(_ts)?)[\t\ ]*='
-@@ -118,7 +118,10 @@
+@@ -111,7 +118,10 @@
TEST_PHP_EXECUTABLE=$(PHP_EXECUTABLE) \
TEST_PHP_SRCDIR=$(top_srcdir) \
CC="$(CC)" \
@@ -49,14 +49,3 @@
TEST_RESULT_EXIT_CODE=$$?; \
rm $(top_builddir)/tmp-php.ini; \
exit $$TEST_RESULT_EXIT_CODE; \
---- php-5.3.2/Makefile.global 2010-03-16 16:31:36.972576955 +0200
-+++ php-5.3.2/Makefile.global 2010-03-16 16:31:36.972576955 +0200
-@@ -296,7 +296,7 @@
- fi
-
- PHP_TEST_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1' -d 'safe_mode=0'
--PHP_TEST_SHARED_SYSTEM_EXTENSIONS = pcre
-+PHP_TEST_SHARED_SYSTEM_EXTENSIONS =
- PHP_TEST_SHARED_EXTENSIONS = ` \
- if test "x$(PHP_MODULES)" != "x"; then \
- for i in $(PHP_MODULES)""; do \