summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorradek2004-11-18 22:28:54 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitb2bc345ce1a90e304a28eba4bcc588bd7db6c95f (patch)
treeaa19a71d90721e8b5338eda8b16ae827df0b282c
downloadperl-Acme-Damn-b2bc345ce1a90e304a28eba4bcc588bd7db6c95f.zip
perl-Acme-Damn-b2bc345ce1a90e304a28eba4bcc588bd7db6c95f.tar.gz
- new
Changed files: perl-Acme-Damn.spec -> 1.1
-rw-r--r--perl-Acme-Damn.spec59
1 files changed, 59 insertions, 0 deletions
diff --git a/perl-Acme-Damn.spec b/perl-Acme-Damn.spec
new file mode 100644
index 0000000..5d5e6a1
--- /dev/null
+++ b/perl-Acme-Damn.spec
@@ -0,0 +1,59 @@
+#
+# Conditional build:
+%bcond_without tests # do not perform "make test"
+#
+%include /usr/lib/rpm/macros.perl
+%define pdir Acme
+%define pnam Damn
+Summary: Acme::Damn - 'Unbless' Perl objects.
+#Summary(pl):
+Name: perl-Acme-Damn
+Version: 0.02
+Release: 1
+# same as perl
+License: GPL v1+ or Artistic
+Group: Development/Languages/Perl
+Source0: http://www.cpan.org/modules/by-module/Acme/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 5728213d994298847d135192bd2f74b0
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Acme::Damn provides a single routine, damn(), which takes a blessed
+reference (a Perl object), and unblesses it, to return the original
+reference. I can't think of any reason why you might want to do this,
+but just because it's of no use doesn't mean that you shouldn't be able
+to do it.
+
+# %description -l pl
+# TODO
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%build
+%{__perl} Makefile.PL \
+ INSTALLDIRS=vendor
+%{__make} \
+ OPTIMIZE="%{rpmcflags}"
+
+%{?with_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+ DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc Changes README
+%{perl_vendorarch}/Acme/*.pm
+%dir %{perl_vendorarch}/auto/Acme/Damn
+%{perl_vendorarch}/auto/Acme/Damn/*.bs
+%attr(755,root,root) %{perl_vendorarch}/auto/Acme/Damn/*.so
+%{_mandir}/man3/*