summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2012-01-25 22:44:48 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit23edeb270ebd04895a161e6c4ac704238fb5a9f2 (patch)
treedc4f6d7a2af18be876909da2b8ffabc876e15d58
downloadnodejs-proto-list-23edeb270ebd04895a161e6c4ac704238fb5a9f2.zip
nodejs-proto-list-23edeb270ebd04895a161e6c4ac704238fb5a9f2.tar.gz
- initial node pkgs for npm depsauto/th/nodejs-proto-list-1_0_0-1
based on specs from http://nodejs.tchol.org/ repo Changed files: nodejs-proto-list.spec -> 1.1
-rw-r--r--nodejs-proto-list.spec45
1 files changed, 45 insertions, 0 deletions
diff --git a/nodejs-proto-list.spec b/nodejs-proto-list.spec
new file mode 100644
index 0000000..fe9da2b
--- /dev/null
+++ b/nodejs-proto-list.spec
@@ -0,0 +1,45 @@
+%define git_hash e1f8f25
+%define pkg proto-list
+Summary: A list of objects bound by prototype chain
+Name: nodejs-%{pkg}
+Version: 1.0.0
+Release: 1
+License: MIT
+Group: Development/Libraries
+URL: https://github.com/isaacs/proto-list
+# download from https://github.com/isaacs/%{pkg}/tarball/%%{version}
+Source0: isaacs-%{pkg}-%{version}-0-g%{git_hash}.tar.gz
+# Source0-md5: e69215f7828f63085ae8ab6a82cd9051
+#BuildRequires: nodejs-tap
+BuildRequires: rpmbuild(macros) >= 1.634
+Requires: nodejs
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+A list of objects bound by prototype chain. Used for the Node.js
+package manager (npm) configuration.
+
+%prep
+%setup -qc
+mv isaacs-%{pkg}-*/* .
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+install -d $RPM_BUILD_ROOT%{nodejs_libdir}
+cp -p %{pkg}.js $RPM_BUILD_ROOT%{nodejs_libdir}
+
+# We currently don't run tests because I'd have to file another ten or
+# so review reuqests for the node.js TAP testing framework and methinks there
+# are enough of those for now. ;-)
+##%%check
+##%%nodejs %{pkg}.js
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc LICENSE README.md
+%{nodejs_libdir}/%{pkg}.js