summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Rękorajski2012-04-04 12:01:20 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitc1e30cb7bacc23ef8e56f04af5462a2950597af4 (patch)
tree1e9950166687fe998bdaf56deb0e769fdebe3ebc
parentede3ac9c69d83000a6f6b036847605e03f098352 (diff)
downloadmpich-c1e30cb7bacc23ef8e56f04af5462a2950597af4.zip
mpich-c1e30cb7bacc23ef8e56f04af5462a2950597af4.tar.gz
- fix building with current g++/gfortran Changed files: mpich-c++.patch -> 1.1 mpich.spec -> 1.17
-rw-r--r--mpich-c++.patch52
-rw-r--r--mpich.spec7
2 files changed, 57 insertions, 2 deletions
diff --git a/mpich-c++.patch b/mpich-c++.patch
new file mode 100644
index 0000000..b271575
--- /dev/null
+++ b/mpich-c++.patch
@@ -0,0 +1,52 @@
+--- mpich-1.2.7p1/configure.in~ 2012-04-04 13:02:28.073692580 +0200
++++ mpich-1.2.7p1/configure.in 2012-04-04 13:55:29.800502795 +0200
+@@ -1804,7 +1804,7 @@
+ # (the autoconf tests are too GNU-centric)
+ if test -n "$GXXTRIAL" ; then
+ cat > conftest.cc <<EOF
+-#include <iostream.h>
++#include <iostream>
+ EOF
+ rm -f conftest.out
+ if $GXXTRIAL $CXXFLAGS -c conftest.cc >conftest.out 2>&1 ; then
+@@ -1845,10 +1845,10 @@
+ # used above is used only to *find* a compiler; if the user selected
+ # a compiler that doesn't work, we still need the test.
+ if test -n "$CPP_COMPILER" ; then
+- AC_MSG_CHECKING([whether selected C++ compiler can compile iostream.h])
++ AC_MSG_CHECKING([whether selected C++ compiler can compile iostream])
+ rm -f conftest*
+ cat > conftest.cc <<EOF
+-#include <iostream.h>
++#include <iostream>
+ EOF
+ if $CPP_COMPILER $CXXFLAGS -c conftest.cc>conftest.out 2>&1 ; then
+ AC_MSG_RESULT(yes)
+--- mpich-1.2.7p1/configure~ 2012-04-04 13:56:35.643839099 +0200
++++ mpich-1.2.7p1/configure 2012-04-04 13:57:10.133840656 +0200
+@@ -2748,7 +2748,7 @@
+ # (the autoconf tests are too GNU-centric)
+ if test -n "$GXXTRIAL" ; then
+ cat > conftest.cc <<EOF
+-#include <iostream.h>
++#include <iostream>
+ EOF
+ rm -f conftest.out
+ if $GXXTRIAL $CXXFLAGS -c conftest.cc >conftest.out 2>&1 ; then
+@@ -2844,13 +2844,13 @@
+
+ fi
+ if test -z "$ac_echo_test" -a 1 = 1 ; then
+-echo $ac_n "checking whether selected C++ compiler can compile iostream.h""... $ac_c"
++echo $ac_n "checking whether selected C++ compiler can compile iostream""... $ac_c"
+ else
+-echo $ac_n "checking whether selected C++ compiler can compile iostream.h""... $ac_c" 1>&1
++echo $ac_n "checking whether selected C++ compiler can compile iostream""... $ac_c" 1>&1
+ fi
+ rm -f conftest*
+ cat > conftest.cc <<EOF
+-#include <iostream.h>
++#include <iostream>
+ EOF
+ if $CPP_COMPILER $CXXFLAGS -c conftest.cc>conftest.out 2>&1 ; then
+ if test -z "$ac_echo_test" -a 1 = 1 ; then
diff --git a/mpich.spec b/mpich.spec
index 387646b..15096ed 100644
--- a/mpich.spec
+++ b/mpich.spec
@@ -2,7 +2,7 @@ Summary: Portable MPI Model Implementation
Summary(pl.UTF-8): Przenośna implementacja standardu MPI
Name: mpich
Version: 1.2.7p1
-Release: 2
+Release: 3
License: Open source (MPICH), BSD-like (MPI-2-C++)
Group: Development/Libraries
Source0: ftp://ftp.mcs.anl.gov/pub/mpi/%{name}-%{version}.tar.bz2
@@ -10,6 +10,7 @@ Source0: ftp://ftp.mcs.anl.gov/pub/mpi/%{name}-%{version}.tar.bz2
Patch0: %{name}-fuckssh.patch
Patch1: %{name}-opt.patch
Patch2: http://squishy.monkeysoft.net/mpich/%{name}-1.2.5-oM.patch
+Patch3: mpich-c++.patch
URL: http://www-unix.mcs.anl.gov/mpi/
BuildRequires: gcc-g77
BuildRequires: libstdc++-devel
@@ -33,6 +34,7 @@ części wersji MPI-2, szczególnie w zakresie równoległej komunikacji.
%patch0 -p1
%patch1 -p1
%patch2 -p1
+%patch3 -p1
sed -i -e 's|RCPCOMMAND-rcp|RCPCOMMAND-scp|' mpid/ch_p4/mpirun.ch_p4.in
@@ -55,7 +57,8 @@ messagecat_dir=%{_libdir} \
--sbindir=%{_sbindir} \
--mandir=%{_mandir} \
--docdir=%{_docdir} \
- -opt="%{rpmcflags} -fPIC"
+ -opt="%{rpmcflags} -fPIC -DPIC" \
+ -fc=gfortran
%{__make}