summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Krenski2009-12-05 00:35:10 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commita1645a6ab49e02d45e11469af9da43e2521ec491 (patch)
tree3f8460c794e431cfdae593d2563bd2afa85fc4dc
parentef7ebdf4fda4bf0b7d00ffdd171cae285a110378 (diff)
downloadmediainfo-a1645a6ab49e02d45e11469af9da43e2521ec491.zip
mediainfo-a1645a6ab49e02d45e11469af9da43e2521ec491.tar.gz
- macros used, cleanups
Changed files: mediainfo.spec -> 1.3
-rw-r--r--mediainfo.spec20
1 files changed, 12 insertions, 8 deletions
diff --git a/mediainfo.spec b/mediainfo.spec
index 385b941..481b4f5 100644
--- a/mediainfo.spec
+++ b/mediainfo.spec
@@ -73,7 +73,7 @@ What format (container) does MediaInfo support?
%prep
%setup -q -n MediaInfo
-dos2unix *.html *.txt Release/*.txt
+dos2unix *.html *.txt Release/*.txt
chmod 644 *.html *.txt Release/*.txt
%build
@@ -83,25 +83,29 @@ export CXXFLAGS="%{rpmcxxflags}"
# build CLI
cd Project/GNU/CLI
- chmod +x autogen
- ./autogen
+ %{__libtoolize}
+ %{__aclocal}
+ %{__autoconf}
+ %{__automake}
%configure
%{__make}
-cd ../../..
+cd -
# now build GUI
cd Project/GNU/GUI
- chmod +x autogen
- ./autogen
+ %{__libtoolize}
+ %{__aclocal}
+ %{__autoconf}
+ %{__automake}
%configure \
--with-wx-config=%{_bindir}/wx-gtk2-unicode-config
%{__make}
-cd ../../..
+cd -
%install
rm -rf $RPM_BUILD_ROOT
%{__make} -C Project/GNU/CLI \
- install \
+ install \
DESTDIR=$RPM_BUILD_ROOT
%{__make} -C Project/GNU/GUI \