summaryrefslogtreecommitdiff
path: root/kernel-small_fixes.patch
diff options
context:
space:
mode:
authorJan Rękorajski2017-12-29 20:44:23 (GMT)
committerJan Rękorajski2017-12-29 20:44:23 (GMT)
commitf4503efade3d793bef7abe1e0ca50e9b43ecb1f1 (patch)
tree8eb143c3b9d89560f0a98486f4cd521038d815f2 /kernel-small_fixes.patch
parentc0a33c076ab91493f661dc9a194c9e41d872fc93 (diff)
downloadkernel-f4503efade3d793bef7abe1e0ca50e9b43ecb1f1.zip
kernel-f4503efade3d793bef7abe1e0ca50e9b43ecb1f1.tar.gz
Diffstat (limited to 'kernel-small_fixes.patch')
-rw-r--r--kernel-small_fixes.patch45
1 files changed, 0 insertions, 45 deletions
diff --git a/kernel-small_fixes.patch b/kernel-small_fixes.patch
index 81d01fa..d4b6034 100644
--- a/kernel-small_fixes.patch
+++ b/kernel-small_fixes.patch
@@ -26,48 +26,3 @@
exit
fi
done
-
-; kernel-orc.patch
-Index: linux-2.6/tools/objtool/orc_dump.c
-===================================================================
---- linux-2.6.orig/tools/objtool/orc_dump.c
-+++ linux-2.6/tools/objtool/orc_dump.c
-@@ -76,7 +76,8 @@ int orc_dump(const char *_objname)
- int fd, nr_entries, i, *orc_ip = NULL, orc_size = 0;
- struct orc_entry *orc = NULL;
- char *name;
-- unsigned long nr_sections, orc_ip_addr = 0;
-+ size_t nr_sections;
-+ Elf64_Addr orc_ip_addr = 0;
- size_t shstrtab_idx;
- Elf *elf;
- Elf_Scn *scn;
-@@ -187,10 +188,10 @@ int orc_dump(const char *_objname)
- return -1;
- }
-
-- printf("%s+%lx:", name, rela.r_addend);
-+ printf("%s+%llx:", name, (unsigned long long)rela.r_addend);
-
- } else {
-- printf("%lx:", orc_ip_addr + (i * sizeof(int)) + orc_ip[i]);
-+ printf("%llx:", (unsigned long long)(orc_ip_addr + (i * sizeof(int)) + orc_ip[i]));
- }
-
-
-Index: linux-2.6/tools/objtool/Makefile
-===================================================================
---- linux-2.6.orig/tools/objtool/Makefile
-+++ linux-2.6/tools/objtool/Makefile
-@@ -7,8 +7,9 @@ ARCH := x86
- endif
-
- # always use the host compiler
--CC = gcc
--LD = ld
-+CC = $(HOSTCC)
-+HOSTLD ?= ld
-+LD = $(HOSTLD)
- AR = ar
-
- ifeq ($(srctree),)