summaryrefslogtreecommitdiff
path: root/kernel-plustek-sane-Makefile.patch
diff options
context:
space:
mode:
authorJakub Bogusz2003-02-12 12:36:40 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit3e36ca46042d19943d796477e71ef061227e5eef (patch)
treeecb59bbf1f1db1562cc97aa7193eb68057ad3afa /kernel-plustek-sane-Makefile.patch
parente68636fadf1e68298e0e735b110ce8c84e6e41e7 (diff)
downloadkernel-plustek-sane-3e36ca46042d19943d796477e71ef061227e5eef.zip
kernel-plustek-sane-3e36ca46042d19943d796477e71ef061227e5eef.tar.gz
- renamed from sane-backends-*.patch
Changed files: kernel-plustek-sane-Makefile.patch -> 1.1 kernel-plustek-sane-alpha.patch -> 1.1
Diffstat (limited to 'kernel-plustek-sane-Makefile.patch')
-rw-r--r--kernel-plustek-sane-Makefile.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/kernel-plustek-sane-Makefile.patch b/kernel-plustek-sane-Makefile.patch
new file mode 100644
index 0000000..9b4ea84
--- /dev/null
+++ b/kernel-plustek-sane-Makefile.patch
@@ -0,0 +1,37 @@
+diff -urN sane-backends-1.0.7.orig/backend/plustek_driver/Makefile sane-backends-1.0.7/backend/plustek_driver/Makefile
+--- sane-backends-1.0.7.orig/backend/plustek_driver/Makefile Tue Mar 12 22:46:19 2002
++++ sane-backends-1.0.7/backend/plustek_driver/Makefile Tue Mar 12 22:49:58 2002
+@@ -39,8 +39,10 @@
+ #
+ # Comment out if you are not running SMP. Someone take this out of here
+ # when the SMP stuff gets moved out of the kernel Makefile.
+-# SMP = 1
+-# SMP_PROF = 1
++ifdef BUILD_SMP
++SMP = 1
++SMP_PROF = 1
++endif
+
+ #
+ # add the following to get assembly listing
+@@ -72,9 +72,9 @@
+ endif
+
+ ifeq ($(DEBUG),y)
+- DEBFLAGS = -O -g -DDEBUG # "-O" is needed to expand inlines
++ DEBFLAGS = $(OPT_FLASG) -DDEBUG # "-O" is needed to expand inlines
+ else
+- DEBFLAGS = -O2
++ DEBFLAGS = $(OPT_FLAGS)
+ endif
+
+ #
+@@ -118,7 +118,7 @@
+ MODLIB = /lib/modules/$(LINUXVERSION)
+
+ ifdef SMP
+-CFLAGS += -D__SMP__
++CFLAGS += -D__SMP__ -DCONFIG_X86_LOCAL_APIC
+
+ ifdef SMP_PROF
+ CFLAGS += -D__SMP_PROF__