summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWitold Filipczyk2022-04-05 15:35:43 (GMT)
committerWitold Filipczyk2022-04-05 15:35:43 (GMT)
commit67d8ba8602e13aeab94e1d203cafdc0440369ab7 (patch)
tree3e399f21146e7100e7d15d3de679c871db806cfd
parent29f0041a949324b5a85245a5383931bbd2dff81e (diff)
downloadka5-okular-67d8ba8602e13aeab94e1d203cafdc0440369ab7.zip
ka5-okular-67d8ba8602e13aeab94e1d203cafdc0440369ab7.tar.gz
- bcond_with tests
-rw-r--r--ka5-okular.spec9
1 files changed, 9 insertions, 0 deletions
diff --git a/ka5-okular.spec b/ka5-okular.spec
index bafc97a..7fa9f9e 100644
--- a/ka5-okular.spec
+++ b/ka5-okular.spec
@@ -1,3 +1,6 @@
+#
+# Conditional build:
+%bcond_with tests # build with tests
%define kdeappsver 21.12.3
%define kframever 5.56.0
%define qtver 5.9.0
@@ -81,11 +84,17 @@ install -d build
cd build
%cmake \
-G Ninja \
+ %{!?with_tests:-DBUILD_TESTING=OFF} \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-DHTML_INSTALL_DIR=%{_kdedocdir} \
..
%ninja_build
+%if %{with tests}
+ctest
+%endif
+
+
%install
rm -rf $RPM_BUILD_ROOT
%ninja_install -C build