summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlisu2011-12-06 12:43:30 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitcc62fe114af6bb2e2733b9b29dde842d28160b5d (patch)
treeae91e1fcb093c05d56c0cd705a7a22c737dcbf8c
parent0858bdbb2f7d0adf5aeb4c00163b6e32b05e0c40 (diff)
downloadim-chooser-cc62fe114af6bb2e2733b9b29dde842d28160b5d.zip
im-chooser-cc62fe114af6bb2e2733b9b29dde842d28160b5d.tar.gz
- fixed build
Changed files: im-chooser-imchooserui.patch -> 1.1 im-chooser.spec -> 1.5
-rw-r--r--im-chooser-imchooserui.patch21
-rw-r--r--im-chooser.spec2
2 files changed, 23 insertions, 0 deletions
diff --git a/im-chooser-imchooserui.patch b/im-chooser-imchooserui.patch
new file mode 100644
index 0000000..9e5a9f4
--- /dev/null
+++ b/im-chooser-imchooserui.patch
@@ -0,0 +1,21 @@
+diff --git a/libimchooseui/imchooseui.c b/libimchooseui/imchooseui.c
+index f135aff..dd5881a 100644
+--- a/libimchooseui/imchooseui.c
++++ b/libimchooseui/imchooseui.c
+@@ -41,14 +41,14 @@ static void _imchoose_ui_switch_im_finish (GObject *source_object,
+ GAsyncResult *res,
+ gpointer user_data);
+
+-typedef struct _IMChooseUIPrivate {
++struct _IMChooseUIPrivate {
+ IMSettingsClient *client;
+ gchar *default_im;
+ gchar *initial_im;
+ gchar *current_im;
+ guint note_type;
+ gboolean clicked:1;
+-} IMChooseUIPrivate;
++};
+ enum {
+ POS_ICON = 0,
+ POS_LABEL,
diff --git a/im-chooser.spec b/im-chooser.spec
index cb36d05..d3742f7 100644
--- a/im-chooser.spec
+++ b/im-chooser.spec
@@ -12,6 +12,7 @@ License: GPL v2
Group: Applications
Source0: http://fedorahosted.org/releases/i/m/im-chooser/%{name}-%{version}.tar.bz2
# Source0-md5: 9f53e2b27652c8149966f35634204f75
+Patch0: %{name}-imchooserui.patch
URL: http://fedorahosted.org/im-chooser/
BuildRequires: glib2-devel >= 1:2.16.0
BuildRequires: imsettings-devel >= 1.2.0
@@ -58,6 +59,7 @@ Ten pakiet zawiera aplikację przeznaczoną dla Xfce 4.
%prep
%setup -q
+%patch0 -p1
%build
%configure