summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2023-11-27 20:19:22 (GMT)
committerJakub Bogusz2023-11-27 20:19:22 (GMT)
commit95b521642f6d63b56ad8b84d40c12c9789cb630b (patch)
tree90cce30e7265f776450ece276c349106b551df7e
parentb96dcb629b152806d05552c5b0328f1d65827d3c (diff)
downloadideviceinstaller-95b521642f6d63b56ad8b84d40c12c9789cb630b.zip
ideviceinstaller-95b521642f6d63b56ad8b84d40c12c9789cb630b.tar.gz
- added patch for libzip function deprecation; release 2HEADauto/th/ideviceinstaller-1.1.1-2master
-rw-r--r--ideviceinstaller-libzip.patch11
-rw-r--r--ideviceinstaller.spec4
2 files changed, 14 insertions, 1 deletions
diff --git a/ideviceinstaller-libzip.patch b/ideviceinstaller-libzip.patch
new file mode 100644
index 0000000..8429ce8
--- /dev/null
+++ b/ideviceinstaller-libzip.patch
@@ -0,0 +1,11 @@
+--- ideviceinstaller-1.1.1/src/ideviceinstaller.c.orig 2020-06-07 17:02:44.000000000 +0200
++++ ideviceinstaller-1.1.1/src/ideviceinstaller.c 2023-11-27 21:08:55.034355773 +0100
+@@ -299,7 +299,7 @@ static int zip_get_contents(struct zip *
+ static int zip_get_app_directory(struct zip* zf, char** path)
+ {
+ int i = 0;
+- int c = zip_get_num_files(zf);
++ int c = zip_get_num_entries(zf, 0);
+ int len = 0;
+ const char* name = NULL;
+
diff --git a/ideviceinstaller.spec b/ideviceinstaller.spec
index 5ac56c9..c9d6762 100644
--- a/ideviceinstaller.spec
+++ b/ideviceinstaller.spec
@@ -2,12 +2,13 @@ Summary: Manage Applications of an iPhone or iPod Touch
Summary(pl.UTF-8): Zarządzanie aplikacjami na urządzeniach iPhone oraz iPod Touch
Name: ideviceinstaller
Version: 1.1.1
-Release: 1
+Release: 2
License: GPL v2+
Group: Applications
#Source0Download: https://libimobiledevice.org/
Source0: https://github.com/libimobiledevice/ideviceinstaller/releases/download/%{version}/%{name}-%{version}.tar.bz2
# Source0-md5: 824b1c6bcb2fab6a0788945c019f83be
+Patch0: %{name}-libzip.patch
URL: https://libimobiledevice.org/
BuildRequires: autoconf >= 2.64
BuildRequires: automake
@@ -34,6 +35,7 @@ zarchiwizowane aplikacje.
%prep
%setup -q
+%patch0 -p1
%build
%{__libtoolize}