summaryrefslogtreecommitdiff
path: root/http-parser.spec
diff options
context:
space:
mode:
authorJakub Bogusz2013-07-21 12:05:39 (GMT)
committerJakub Bogusz2013-07-21 12:05:39 (GMT)
commit1961ec031096de8f38af72a1bfa9b403bff50fa6 (patch)
tree1da5aa73e03941f6205cb4afc3f8712f895a5bba /http-parser.spec
parent1dcbed49668bd76ed367dc6d6a9637df3c6e6307 (diff)
downloadhttp-parser-1961ec031096de8f38af72a1bfa9b403bff50fa6.zip
http-parser-1961ec031096de8f38af72a1bfa9b403bff50fa6.tar.gz
- pl, cleanup
Diffstat (limited to 'http-parser.spec')
-rw-r--r--http-parser.spec42
1 files changed, 29 insertions, 13 deletions
diff --git a/http-parser.spec b/http-parser.spec
index 7c2db36..6409037 100644
--- a/http-parser.spec
+++ b/http-parser.spec
@@ -2,20 +2,21 @@
%define git_commit_hash cd01361
%define github_seq 7
Summary: HTTP request/response parser for C
+Summary(pl.UTF-8): Analizator żądań/odpowiedzi HTTP dla C
Name: http-parser
Version: 2.0
Release: 0.git%{git_commit_hash}
License: MIT
Group: Libraries
-URL: http://github.com/joyent/http-parser
# download from https://github.com/joyent/http-parser/tarball/%%{version}
Source0: http://pkgs.fedoraproject.org/repo/pkgs/http-parser/joyent-%{name}-v%{version}-%{github_seq}-g%{git_commit_hash}.tar.gz/340f2aab333c435cbaf49a4949645a06/joyent-http-parser-v%{version}-%{github_seq}-g%{git_commit_hash}.tar.gz
# Source0-md5: 340f2aab333c435cbaf49a4949645a06
-BuildRequires: libstdc++-devel
-BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
# Build shared library with SONAME using gyp and remove -O flags so optflags take over
# TODO: do this nicely upstream
-Patch1: %{name}-gyp-sharedlib.patch
+Patch0: %{name}-gyp-sharedlib.patch
+URL: http://github.com/joyent/http-parser
+BuildRequires: libstdc++-devel
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
BuildRequires: gyp
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -33,23 +34,38 @@ anytime. Depending on your architecture, it only requires about 40
bytes of data per message stream (in a web server that is per
connection).
+%description -l pl.UTF-8
+Ten pakiet zawiera analizator komunikatów HTTP napisany w C. Analizuje
+zarówno żądania, jak i odpowiedzi. Może być używany w zastosowaniach
+wymagających dużej wydajności. Nie wykonuje żadnych wywołań
+systemowych, nie przydziela pamięci, nie buforuje danych, może być
+przerwany w dowolnej chwili. W zależności od architektury wymaga
+jedynie około 40 bajtów danych dla strumienia komunikatów (w przypadku
+serwera WWW - dla połączenia).
+
%package devel
-Summary: Development headers and libraries for http-parser
+Summary: Development headers for http-parser library
+Summary(pl.UTF-8): Pliki nagłówkowe biblioteki http-parser
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
%description devel
-Development headers and libraries for http-parser.
+Development headers for http-parser library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki http-parser.
%prep
%setup -q -n joyent-%{name}-%{git_commit_hash}
-%patch1
+%patch0
%build
# TODO: fix -fPIC upstream
-export CFLAGS='%{optflags} -fPIC'
+export CFLAGS='%{rpmcflags} -fPIC'
gyp -f make --depth=. http_parser.gyp
-%{__make} V=1 BUILDTYPE=Release
+%{__make} \
+ BUILDTYPE=Release \
+ V=1
%if %{with tests}
export LD_LIBRARY_PATH='./out/Release/lib.target'
@@ -84,12 +100,12 @@ rm -rf $RPM_BUILD_ROOT
%defattr(644,root,root,755)
%doc AUTHORS CONTRIBUTIONS LICENSE-MIT README.md
%attr(755,root,root) %{_libdir}/libhttp_parser.so.*.*.*
-%ghost %{_libdir}/libhttp_parser.so.2
+%attr(755,root,root) %ghost %{_libdir}/libhttp_parser.so.2
%attr(755,root,root) %{_libdir}/libhttp_parser_strict.so.*.*.*
-%ghost %{_libdir}/libhttp_parser_strict.so.2
+%attr(755,root,root) %ghost %{_libdir}/libhttp_parser_strict.so.2
%files devel
%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libhttp_parser.so
+%attr(755,root,root) %{_libdir}/libhttp_parser_strict.so
%{_includedir}/http_parser.h
-%{_libdir}/libhttp_parser.so
-%{_libdir}/libhttp_parser_strict.so