summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Palus2023-07-04 23:19:09 (GMT)
committerJan Palus2023-07-04 23:19:09 (GMT)
commitb7c504c713a27033d15b6c0194d4537dfba74aeb (patch)
treed6bcb6c6f44551587cc44e2bc9660ff306aec99c
parentdbca578984a750fc5f498ae15b7fb3a161199ef8 (diff)
downloadguitarix-b7c504c713a27033d15b6c0194d4537dfba74aeb.zip
guitarix-b7c504c713a27033d15b6c0194d4537dfba74aeb.tar.gz
fix build with gcc >= 13
-rw-r--r--gcc13.patch11
-rw-r--r--guitarix.spec2
2 files changed, 13 insertions, 0 deletions
diff --git a/gcc13.patch b/gcc13.patch
new file mode 100644
index 0000000..f4f7c5c
--- /dev/null
+++ b/gcc13.patch
@@ -0,0 +1,11 @@
+diff -ur guitarix-0.44.1.orig/src/LV2/DSP/gx_common.h guitarix-0.44.1/src/LV2/DSP/gx_common.h
+--- guitarix-0.44.1.orig/src/LV2/DSP/gx_common.h 2022-05-02 20:38:03.000000000 +0200
++++ guitarix-0.44.1/src/LV2/DSP/gx_common.h 2023-07-05 00:27:25.237218722 +0200
+@@ -23,6 +23,7 @@
+ #define SRC_HEADERS_GX_COMMON_H_
+
+
++#include <cstdint>
+ #include <cstdlib>
+ #include <cmath>
+ #include <iostream>
diff --git a/guitarix.spec b/guitarix.spec
index f3ad0a6..3e90bcb 100644
--- a/guitarix.spec
+++ b/guitarix.spec
@@ -7,6 +7,7 @@ Group: Applications/Multimedia
Source0: http://downloads.sourceforge.net/guitarix/%{name}2-%{version}.tar.xz
# Source0-md5: d1757e08ddc54c4ec07defea6a30ac5b
Patch0: zita-resampler-1.10.patch
+Patch1: gcc13.patch
URL: https://guitarix.org/
BuildRequires: avahi-gobject-devel
BuildRequires: bluez-libs-devel
@@ -54,6 +55,7 @@ use the feedback and feedforward sliders.
%prep
%setup -q
%patch0 -p1
+%patch1 -p1
%build
CC="%{__cc}" \