summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Gołaszewski2006-07-20 11:38:57 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit30bacd6a363f22e7640cd360a22779d6c710d19d (patch)
tree6b8b03ea38d799ed53c06d33db69919a71e1268f
parent91b45e8d60f6d1f6d83106cfa90a26331c7d8dbb (diff)
downloadgallery-30bacd6a363f22e7640cd360a22779d6c710d19d.zip
gallery-30bacd6a363f22e7640cd360a22779d6c710d19d.tar.gz
- 2.1.1a - works...
Changed files: gallery.spec -> 1.40
-rw-r--r--gallery.spec73
1 files changed, 28 insertions, 45 deletions
diff --git a/gallery.spec b/gallery.spec
index 84b8f90..6959f54 100644
--- a/gallery.spec
+++ b/gallery.spec
@@ -1,31 +1,33 @@
+# TODO:
+# - use external libs, not the included ones: pear, smarty, adodb
+# - move to separate packages each: theme, module.
Summary: Web based photo album viewer and creator
Summary(pl): Przegl±darka i generator albumów zdjêæ w postaci stron WWW
Name: gallery
-Version: 1.5.3
+Version: 2.1.1a
Release: 1
License: GPL
Group: Applications/Publishing
-Source0: http://dl.sourceforge.net/gallery/%{name}-%{version}.tar.gz
-# Source0-md5: ed5fd4aeff5146552eaba5ff6d0de576
-Source1: http://dl.sourceforge.net/gallery/pl_PL-1.5.1.tar.gz
-# Source1-md5: efe8e359041c2c07463132ad0f7a8bea
-Source2: %{name}-apache.conf
-Patch0: %{name}-PLD.patch
+Source0: http://dl.sourceforge.net/gallery/%{name}-%{version}-full.tar.gz
+# Source0-md5: 0ff0857716a1473c319b6a468c47c877
+Source1: %{name}-apache.conf
URL: http://gallery.sourceforge.net/
BuildRequires: rpmbuild(macros) >= 1.268
Requires: webapps
Requires: php-gettext
+Requires: php-pcre
Requires: php >= 3:4.1.0
#Suggests: apache(mod_rewrite)
#Suggests: jhead
#Suggests: jpegtran
+#Suggests: php-gd
BuildArch: noarch
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
%define _webapps /etc/webapps
%define _webapp %{name}
%define _sysconfdir %{_webapps}/%{_webapp}
-%define _appdir %{_datadir}/%{_webapp}
+%define _appdir %{_datadir}/%{_webapp}
%description
Gallery is a photo album that includes a config wizard and lets users
@@ -58,30 +60,27 @@ pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
%prep
-%setup -q -n %{name}
-%patch0 -p1
+%setup -q -n %{name}2
-tar zxf %{SOURCE1} -C locale
rm -f LICENSE.txt *.bat
%install
rm -rf $RPM_BUILD_ROOT
install -d $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir},/var/lib/gallery/albums}
-cp -a *.{php,inc,sh} $RPM_BUILD_ROOT%{_appdir}
-cp -a classes contrib css docs help html html_wrap images $RPM_BUILD_ROOT%{_appdir}
-cp -a includes java js layout lib locale platform skins tools $RPM_BUILD_ROOT%{_appdir}
+cp -a *.{php,inc} $RPM_BUILD_ROOT%{_appdir}
+cp -a images lib modules themes $RPM_BUILD_ROOT%{_appdir}
+cp -a install upgrade $RPM_BUILD_ROOT%{_appdir}
# in /var because of setup/resetadmin file
-cp -a setup $RPM_BUILD_ROOT/var/lib/gallery
-ln -s /var/lib/gallery/setup $RPM_BUILD_ROOT%{_appdir}
-ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.php
-rm -f $RPM_BUILD_ROOT%{_appdir}/{AUTHORS,ChangeLog*,README}
+#cp -a setup $RPM_BUILD_ROOT/var/lib/gallery
+#ln -s /var/lib/gallery/setup $RPM_BUILD_ROOT%{_appdir}
-install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
-install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
touch $RPM_BUILD_ROOT%{_sysconfdir}/config.php
-touch $RPM_BUILD_ROOT%{_sysconfdir}/htaccess
-ln -s %{_sysconfdir}/htaccess $RPM_BUILD_ROOT%{_appdir}/.htaccess
+touch $RPM_BUILD_ROOT%{_sysconfdir}/login.txt
+ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.php
+ln -s %{_sysconfdir}/login.txt $RPM_BUILD_ROOT%{_appdir}/login.txt
%clean
rm -rf $RPM_BUILD_ROOT
@@ -104,41 +103,25 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(644,root,root,755)
-%doc AUTHORS ChangeLog* README
+%doc README*
%dir %attr(750,root,http) %{_sysconfdir}
%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
-%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/htaccess
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/login.txt
%dir %{_appdir}
%dir /var/lib/gallery
%dir %attr(770,root,http) /var/lib/gallery/albums
-%{_appdir}/.htaccess
%{_appdir}/*.php
%{_appdir}/*.inc
-%{_appdir}/classes
-%{_appdir}/contrib
-%{_appdir}/css
-%{_appdir}/docs
-%{_appdir}/html*
-%{_appdir}/help
%{_appdir}/images
-%{_appdir}/includes
-%{_appdir}/java
-%{_appdir}/js
-%{_appdir}/layout
%{_appdir}/lib
-%{_appdir}/platform
-%{_appdir}/skins
-%{_appdir}/tools
-
-%dir %{_appdir}/locale
-%{_appdir}/locale/en_US
-%lang(pl) %{_appdir}/locale/pl_PL
+%{_appdir}/modules
+%{_appdir}/themes
%files setup
%defattr(644,root,root,755)
-%attr(755,root,root) %{_appdir}/*.sh
-%{_appdir}/setup
%{_appdir}/config.php
-/var/lib/gallery/setup
+%{_appdir}/install
+%{_appdir}/upgrade
+#/var/lib/gallery/setup