summaryrefslogtreecommitdiff
path: root/fwf.spec
diff options
context:
space:
mode:
authoradasi2005-12-05 23:51:41 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commiteb3f95767afde842f48f2c5ee73e6075e336c3c7 (patch)
tree6a601a6b1a8757df1f56f479e793f8acb3623e21 /fwf.spec
downloadfwf-eb3f95767afde842f48f2c5ee73e6075e336c3c7.zip
fwf-eb3f95767afde842f48f2c5ee73e6075e336c3c7.tar.gz
- NFY, placeholder
Changed files: fwf.spec -> 1.1
Diffstat (limited to 'fwf.spec')
-rw-r--r--fwf.spec90
1 files changed, 90 insertions, 0 deletions
diff --git a/fwf.spec b/fwf.spec
new file mode 100644
index 0000000..7054ac3
--- /dev/null
+++ b/fwf.spec
@@ -0,0 +1,90 @@
+#
+# Conditional build:
+%bcond_with tests # build with tests
+%bcond_without tests # build without tests
+#
+Summary: Free Widgets Foundation
+Name: fwf
+Version: 0
+Release: 0.1
+License: GPL (?)
+Group: Applications
+Source0: ftp://sunsite.unc.edu/pub/X11/fwf/%{name}.tar.gz
+# Source0-md5: 4d0798a388cb6020a5b304256f300578
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+FWF
+
+%prep
+%setup -q -n FWF
+
+%build
+
+%{__make} \
+ CFLAGS="%{rpmcflags}" \
+ LDFLAGS="%{rpmldflags}"
+
+%install
+rm -rf $RPM_BUILD_ROOT
+# create directories if necessary
+#install -d $RPM_BUILD_ROOT
+#install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+
+%{__make} install \
+ DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%pre
+
+%post
+
+%preun
+
+%postun
+
+%if %{with ldconfig}
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+%endif
+
+%if %{with initscript}
+%post init
+/sbin/chkconfig --add %{name}
+%service %{name} restart
+
+%preun init
+if [ "$1" = "0" ]; then
+ %service -q %{name} stop
+ /sbin/chkconfig --del %{name}
+fi
+%endif
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
+
+%if 0
+# if _sysconfdir != /etc:
+#%%dir %{_sysconfdir}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
+%attr(755,root,root) %{_bindir}/*
+%{_datadir}/%{name}
+%endif
+
+# initscript and its config
+%if %{with initscript}
+%attr(754,root,root) /etc/rc.d/init.d/%{name}
+%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
+%endif
+
+#%{_examplesdir}/%{name}-%{version}
+
+%if %{with subpackage}
+%files subpackage
+%defattr(644,root,root,755)
+#%doc extras/*.gz
+#%{_datadir}/%{name}-ext
+%endif