summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Palus2023-12-06 10:48:07 (GMT)
committerJan Palus2023-12-06 10:48:07 (GMT)
commit3b3132c78cd7d3f64c9f03722c3fcebec8d6dffb (patch)
tree4c7039633654bd1260219a11454ffbed16b1ca50
parentddca8ee975f56bd94a4a5f75822b1a7ace57276c (diff)
downloadcurl-3b3132c78cd7d3f64c9f03722c3fcebec8d6dffb.zip
curl-3b3132c78cd7d3f64c9f03722c3fcebec8d6dffb.tar.gz
add static_libs bcondauto/th/curl-8.5.0-1
-rw-r--r--curl.spec4
1 files changed, 4 insertions, 0 deletions
diff --git a/curl.spec b/curl.spec
index d13e9b6..d392c37 100644
--- a/curl.spec
+++ b/curl.spec
@@ -1,6 +1,7 @@
# TODO: ngtpc2/nghttp3 or quiche or msh3 for HTTP3?
#
# Conditional build:
+%bcond_without static_libs # static library
%bcond_without ssh # SSH support
%bcond_without ssl # SSL support
%bcond_with gnutls # GnuTLS instead of OpenSSL
@@ -254,6 +255,7 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
%{__automake}
%configure \
ac_cv_header_gss_h=no \
+ %{__enable_disable static_libs static} \
%{__enable_disable ares} \
%{__with_without gsasl libgsasl} \
--enable-headers-api \
@@ -331,9 +333,11 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/CURLMOPT_*.3*
%{_mandir}/man3/CURLSHOPT_*.3*
+%if %{with static_libs}
%files static
%defattr(644,root,root,755)
%{_libdir}/libcurl.a
+%endif
%files -n fish-completion-%{name}
%defattr(644,root,root,755)