summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Gołębiowski2006-04-23 15:25:21 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitfb176567b47a72c89fffcdfb2b0c89d55a2f2852 (patch)
treea65150a760d9a147f9676c4bdd8ec199884157f6
downloadc-ares-fb176567b47a72c89fffcdfb2b0c89d55a2f2852.zip
c-ares-fb176567b47a72c89fffcdfb2b0c89d55a2f2852.tar.gz
- new
Changed files: c-ares.spec -> 1.1
-rw-r--r--c-ares.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/c-ares.spec b/c-ares.spec
new file mode 100644
index 0000000..aadd9ef
--- /dev/null
+++ b/c-ares.spec
@@ -0,0 +1,81 @@
+Summary: A library that performs asynchronous DNS operations
+Summary(pl): Biblioteka do wykonywania synchronicznych zapytań DNS
+Name: c-ares
+Version: 1.3.0
+Release: 1
+License: MIT
+Group: Libraries
+Source0: http://daniel.haxx.se/projects/c-ares/%{name}-%{version}.tar.gz
+# Source0-md5: badb4563a02d4188b478df31fa1b657d
+URL: http://daniel.haxx.se/projects/c-ares/
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+c-ares is a C library that performs DNS requests and name resolves
+asynchronously. c-ares is a fork of the library named 'ares', written
+by Greg Hudson at MIT.
+
+%description -l pl
+c-ares jest napisan± w C bibliotek± do asnchronicznego wykonywania
+zapytań DNS. c-ares jest to fork biblioteki 'ares' napisanej przez
+Grega Hudsona w MIT.
+
+%package devel
+Summary: Development files for c-ares library
+Summary: Pliki nagłówkowe dla biblioteki c-ares
+Group: Development/Libraries
+Requires: %{name} = %{version}-%{release}
+
+%description devel
+Header files for c-ares library.
+
+%description devel -l pl
+Pliki nagłówkowe biblioteki c-ares.
+
+%package static
+Summary: Static c-ares library
+Summary(pl): Statyczna biblioteka c-ares
+Group: Development/Libraries
+Requires: %{name}-devel = %{version}-%{release}
+
+%description static
+Static c-ares library.
+
+%description static -l pl
+Statyczna biblioteka c-ares.
+
+%prep
+%setup -q
+
+%build
+%configure \
+ --enable-shared
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__make} install \
+ DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc README README.cares CHANGES NEWS
+%attr(755,root,root) %{_libdir}/*.so.*.*.*
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/*.so
+%{_libdir}/*.la
+%{_includedir}/*
+%{_mandir}/man3/*
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/*.a