summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Palus2023-10-27 17:37:17 (GMT)
committerJan Palus2023-10-27 17:37:17 (GMT)
commit6625f4eda5a8f4e6621c8112db1007e99d431c9e (patch)
tree570db9c3a72156964770c05c94e045438cea4d26
parenta1d517ec5fa830f6dc31ed8ef329f5fadd5160b5 (diff)
downloadc-ares-6625f4eda5a8f4e6621c8112db1007e99d431c9e.zip
c-ares-6625f4eda5a8f4e6621c8112db1007e99d431c9e.tar.gz
-rw-r--r--c-ares-resolv.conf-reading-is-not-fatal.patch58
-rw-r--r--c-ares.spec4
2 files changed, 31 insertions, 31 deletions
diff --git a/c-ares-resolv.conf-reading-is-not-fatal.patch b/c-ares-resolv.conf-reading-is-not-fatal.patch
index 56e239c..8043879 100644
--- a/c-ares-resolv.conf-reading-is-not-fatal.patch
+++ b/c-ares-resolv.conf-reading-is-not-fatal.patch
@@ -1,34 +1,34 @@
---- c-ares-1.11.0/src/lib/ares_init.c.orig 2016-02-11 12:23:52.000000000 +0100
-+++ c-ares-1.11.0/src/lib/ares_init.c 2016-02-28 10:01:24.592903895 +0100
-@@ -1292,6 +1292,7 @@
- switch(error) {
- case ENOENT:
- case ESRCH:
-+ case EACCES:
- status = ARES_EOF;
- break;
- default:
-@@ -1319,6 +1320,7 @@
- switch(error) {
+--- c-ares-1.21.0/src/lib/ares_init.c.orig 2023-10-27 19:28:18.116859697 +0200
++++ c-ares-1.21.0/src/lib/ares_init.c 2023-10-27 19:31:32.347894291 +0200
+@@ -1516,6 +1516,7 @@
+ switch (error) {
case ENOENT:
case ESRCH:
+ case EACCES:
+ status = ARES_EOF;
break;
default:
- DEBUGF(fprintf(stderr, "fopen() failed with error: %d %s\n",
-@@ -1350,6 +1352,7 @@
- switch(error) {
- case ENOENT:
- case ESRCH:
-+ case EACCES:
- break;
- default:
- DEBUGF(fprintf(stderr, "fopen() failed with error: %d %s\n",
-@@ -1381,6 +1384,7 @@
- switch(error) {
- case ENOENT:
- case ESRCH:
-+ case EACCES:
- break;
- default:
- DEBUGF(fprintf(stderr, "fopen() failed with error: %d %s\n",
+@@ -1542,6 +1543,7 @@
+ switch (error) {
+ case ENOENT:
+ case ESRCH:
++ case EACCES:
+ break;
+ default:
+ DEBUGF(fprintf(stderr, "fopen() failed with error: %d %s\n", error,
+@@ -1572,6 +1574,7 @@
+ switch (error) {
+ case ENOENT:
+ case ESRCH:
++ case EACCES:
+ break;
+ default:
+ DEBUGF(fprintf(stderr, "fopen() failed with error: %d %s\n", error,
+@@ -1602,6 +1605,7 @@
+ switch (error) {
+ case ENOENT:
+ case ESRCH:
++ case EACCES:
+ break;
+ default:
+ DEBUGF(fprintf(stderr, "fopen() failed with error: %d %s\n", error,
diff --git a/c-ares.spec b/c-ares.spec
index 6bc4fd2..4ccfcaa 100644
--- a/c-ares.spec
+++ b/c-ares.spec
@@ -1,13 +1,13 @@
Summary: A library that performs asynchronous DNS operations
Summary(pl.UTF-8): Biblioteka do wykonywania asynchronicznych zapytaƄ DNS
Name: c-ares
-Version: 1.20.1
+Version: 1.21.0
Release: 1
License: MIT
Group: Libraries
#Source0Download: https://c-ares.haxx.se/
Source0: https://c-ares.haxx.se/download/%{name}-%{version}.tar.gz
-# Source0-md5: a35e8a925be1d2089da03655625c5b15
+# Source0-md5: cf0808e65175571ef23d7c4a6d4673d6
Patch0: %{name}-resolv.conf-reading-is-not-fatal.patch
URL: https://c-ares.haxx.se/
BuildRequires: autoconf >= 2.60