summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2010-02-07 13:06:50 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit5122b158dae9f9667e39a1b2788de3d666313a68 (patch)
tree4630afe32be3c508b1d8dd2003a1d302c8398fa9
parentcce9c713af247482e4c8ae75f417a7e6de608dde (diff)
downloadc-ares-5122b158dae9f9667e39a1b2788de3d666313a68.zip
c-ares-5122b158dae9f9667e39a1b2788de3d666313a68.tar.gz
- treat not readable resolv.conf (and other /etc files) as if it was empty, not give out fatal error on itauto/th/c-ares-1_6_0-2
- so curl-libs -> python-pycurl -> python-urlgrabber could be built on our builders see http://lists.pld-linux.org/mailman/pipermail/pld-cvs-commit/Week-of-Mon-20100201/265667.html - rel 2 Changed files: c-ares-resolv.conf-reading-is-not-fatal.patch -> 1.1 c-ares.spec -> 1.10
-rw-r--r--c-ares-resolv.conf-reading-is-not-fatal.patch34
-rw-r--r--c-ares.spec4
2 files changed, 37 insertions, 1 deletions
diff --git a/c-ares-resolv.conf-reading-is-not-fatal.patch b/c-ares-resolv.conf-reading-is-not-fatal.patch
new file mode 100644
index 0000000..392ae45
--- /dev/null
+++ b/c-ares-resolv.conf-reading-is-not-fatal.patch
@@ -0,0 +1,34 @@
+--- c-ares-1.6.0/ares_init.c~ 2010-02-07 14:22:41.480067790 +0200
++++ c-ares-1.6.0/ares_init.c 2010-02-07 14:22:42.962764879 +0200
+@@ -839,6 +839,7 @@
+ switch(error) {
+ case ENOENT:
+ case ESRCH:
++ case EACCES:
+ status = ARES_EOF;
+ break;
+ default:
+@@ -865,6 +866,7 @@
+ switch(error) {
+ case ENOENT:
+ case ESRCH:
++ case EACCES:
+ status = ARES_EOF;
+ break;
+ default:
+@@ -892,6 +894,7 @@
+ switch(error) {
+ case ENOENT:
+ case ESRCH:
++ case EACCES:
+ status = ARES_EOF;
+ break;
+ default:
+@@ -919,6 +922,7 @@
+ switch(error) {
+ case ENOENT:
+ case ESRCH:
++ case EACCES:
+ status = ARES_EOF;
+ break;
+ default:
diff --git a/c-ares.spec b/c-ares.spec
index 8d9bd22..1b7a19a 100644
--- a/c-ares.spec
+++ b/c-ares.spec
@@ -2,11 +2,12 @@ Summary: A library that performs asynchronous DNS operations
Summary(pl.UTF-8): Biblioteka do wykonywania asynchronicznych zapytań DNS
Name: c-ares
Version: 1.6.0
-Release: 1
+Release: 2
License: MIT
Group: Libraries
Source0: http://daniel.haxx.se/projects/c-ares/%{name}-%{version}.tar.gz
# Source0-md5: 4503b0db3dd79d3c1f58d87722dbab46
+Patch0: %{name}-resolv.conf-reading-is-not-fatal.patch
URL: http://daniel.haxx.se/projects/c-ares/
BuildRequires: autoconf
BuildRequires: automake
@@ -50,6 +51,7 @@ Statyczna biblioteka c-ares.
%prep
%setup -q
+%patch0 -p1
# we want our own debug flags, if any
sed -i -e 's/flags_dbg_off=".*"/flags_dbg_off="%{rpmcflags}"/' m4/cares-compilers.m4