summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcvs2git2003-03-07 12:35:35 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit953e34d74816b64df6cf94a18dcb83e9cbe828c0 (patch)
treeb71f8db7d15b76ff3ffa27e0be6fbc81197f0163
parent349f4d51ebcdfd7b374a73d471f869b41e6edb25 (diff)
downloadbind-953e34d74816b64df6cf94a18dcb83e9cbe828c0.zip
bind-953e34d74816b64df6cf94a18dcb83e9cbe828c0.tar.gz
This commit was manufactured by cvs2git to create tag 'STABLE'.STABLE
Sprout from master 2002-09-28 22:37:30 UTC Arkadiusz Miśkiewicz <arekm@maven.pl> '- move libbind includes to %%{_includedir}/bind' Cherrypick from master 2000-03-06 14:34:09 UTC kloczek <kloczek@pld-linux.org> '- fix TTL (patch from ISC).': bind-glibc21.patch -> 1.1 bind-host-forcetype.patch -> 1.2 bind-ttl.patch -> 1.1 Cherrypick from unlabeled-1.143.2 2003-03-07 12:35:35 UTC Jakub Bogusz <qboosh@pld-linux.org> '- require openssl 0.9.6i': bind.spec -> 1.143.2.2 Delete: bind9-openssl.patch
-rw-r--r--bind-glibc21.patch27
-rw-r--r--bind-host-forcetype.patch12
-rw-r--r--bind-ttl.patch56
-rw-r--r--bind.spec10
-rw-r--r--bind9-openssl.patch30
5 files changed, 99 insertions, 36 deletions
diff --git a/bind-glibc21.patch b/bind-glibc21.patch
new file mode 100644
index 0000000..161ec35
--- /dev/null
+++ b/bind-glibc21.patch
@@ -0,0 +1,27 @@
+--- bind-8.2/src/port/linux/include/port_after.h~ Sat Feb 27 02:04:21 1999
++++ bind-8.2/src/port/linux/include/port_after.h Tue Mar 16 19:30:14 1999
+@@ -63,24 +63,4 @@
+ #define PF_INET6 AF_INET6
+ #endif
+
+-#ifndef HAS_INET6_STRUCTS
+-/* Replace with structure from later rev of O/S if known. */
+-struct in6_addr {
+- u_int8_t s6_addr[16];
+-};
+-
+-/* Replace with structure from later rev of O/S if known. */
+-struct sockaddr_in6 {
+-#ifdef HAVE_SA_LEN
+- u_int8_t sin6_len; /* length of this struct */
+- u_int8_t sin6_family; /* AF_INET6 */
+-#else
+- u_int16_t sin6_family; /* AF_INET6 */
+-#endif
+- u_int16_t sin6_port; /* transport layer port # */
+- u_int32_t sin6_flowinfo; /* IPv6 flow information */
+- struct in6_addr sin6_addr; /* IPv6 address */
+- u_int32_t sin6_scope_id; /* set of interfaces for a scope */
+-};
+-#endif /* HAS_INET6_STRUCTS */
+ #endif /* ! PORT_AFTER_H */
diff --git a/bind-host-forcetype.patch b/bind-host-forcetype.patch
new file mode 100644
index 0000000..23bd8b8
--- /dev/null
+++ b/bind-host-forcetype.patch
@@ -0,0 +1,12 @@
+diff -ruN src.orig/bin/host/host.c src/bin/host/host.c
+--- src.orig/bin/host/host.c Thu Nov 11 20:39:10 1999
++++ src/bin/host/host.c Thu Nov 25 23:07:46 1999
+@@ -270,7 +270,7 @@
+ /*NOTREACHED*/
+ }
+ }
+- if (gettype == 0) {
++ if (gettype == 0 && (sigchase)) {
+ if (verbose)
+ printf ("Forcing `-t a' for signature trace.\n");
+ gettype = ns_t_a;
diff --git a/bind-ttl.patch b/bind-ttl.patch
new file mode 100644
index 0000000..4729705
--- /dev/null
+++ b/bind-ttl.patch
@@ -0,0 +1,56 @@
+--- bind-8.2.2_P5/src/bin/named/db_load.c.ttl Mon Feb 28 00:47:21 2000
++++ bind-8.2.2_P5/src/bin/named/db_load.c Mon Feb 28 00:50:13 2000
+@@ -292,6 +292,7 @@
+ default_warn = 1;
+ clev = nlabels(in_origin);
+ filenames = NULL;
++ zp->z_minimum = USE_MINIMUM;
+ }
+ ttl = default_ttl;
+
+@@ -742,7 +743,7 @@
+ zp->z_minimum = 0;
+ } else
+ zp->z_minimum = n;
+- if (default_ttl == USE_MINIMUM)
++ if (ttl == USE_MINIMUM)
+ ttl = n;
+ n = cp - (char *)data;
+ if (multiline) {
+@@ -750,6 +751,7 @@
+ buf[1] = '\0';
+ if (buf[0] != ')')
+ ERRTO("SOA \")\"");
++ multiline = 0;
+ endline(fp);
+ }
+ read_soa++;
+@@ -971,11 +973,14 @@
+ case ns_t_cert:
+ case ns_t_sig: {
+ char *errmsg = NULL;
+- int ret = parse_sec_rdata(buf, sizeof(buf), 0,
+- data, sizeof(data),
+- fp, zp, domain, ttl,
+- type, domain_ctx,
+- transport, &errmsg);
++ int ret;
++ if (ttl == USE_MINIMUM) /* no ttl set */
++ ttl = 0;
++ ret = parse_sec_rdata(buf, sizeof(buf), 0,
++ data, sizeof(data),
++ fp, zp, domain, ttl,
++ type, domain_ctx,
++ transport, &errmsg);
+ if (ret < 0) {
+ errtype = errmsg;
+ goto err;
+@@ -1022,6 +1027,8 @@
+ zp->z_origin);
+ continue;
+ }
++ if (ttl == USE_MINIMUM) /* no ttl set */
++ ttl = 0;
+ dp = savedata(class, type, (u_int32_t)ttl,
+ (u_char *)data, (int)n);
+ dp->d_zone = zp - zones;
diff --git a/bind.spec b/bind.spec
index a3da378..8c70da1 100644
--- a/bind.spec
+++ b/bind.spec
@@ -9,8 +9,8 @@ Summary(tr): DNS alan adý sunucusu
Summary(uk): BIND - cÅÒ×ÅÒ ÓÉÓÔÅÍÉ ÄÏÍÅÎÎÉÈ ¦ÍÅÎ (DNS)
Summary(zh_CN): Internet ÓòÃû·þÎñÆ÷
Name: bind
-Version: 9.2.1
-Release: 11
+Version: 9.2.2
+Release: 1
Epoch: 5
License: BSD-like
Group: Networking/Daemons
@@ -23,7 +23,6 @@ Source5: nslookup.8
Source6: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
Patch1: %{name}-time.patch
Patch2: %{name}-autoconf.patch
-Patch3: %{name}-sec-from-833.patch
Patch4: %{name}-includedir-libbind.patch
URL: http://www.isc.org/products/BIND/bind9.html
BuildRequires: autoconf
@@ -31,7 +30,7 @@ BuildRequires: automake
BuildRequires: bison
BuildRequires: flex
BuildRequires: libtool
-BuildRequires: openssl-devel
+BuildRequires: openssl-devel >= 0.9.6i
PreReq: %{name}-libs = %{version}
PreReq: rc-scripts >= 0.2.0
Requires(pre): fileutils
@@ -42,6 +41,7 @@ Requires(pre): /usr/sbin/useradd
Requires(post,preun): /sbin/chkconfig
Requires(postun): /usr/sbin/userdel
Requires(postun): /usr/sbin/groupdel
+Requires: openssl >= 0.9.6i
Requires: psmisc >= 20.1
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
Obsoletes: caching-nameserver
@@ -287,8 +287,6 @@ BIND.
%patch1 -p1
%patch2 -p1
%patch4 -p1
-cd lib/bind
-%patch3 -p3
%build
%{__libtoolize}
diff --git a/bind9-openssl.patch b/bind9-openssl.patch
deleted file mode 100644
index 6377eb9..0000000
--- a/bind9-openssl.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -urN bind-9.0.1rc2.org/configure.in bind-9.0.1rc2/configure.in
---- bind-9.0.1rc2.org/configure.in Tue Nov 7 11:04:02 2000
-+++ bind-9.0.1rc2/configure.in Wed Nov 8 11:15:29 2000
-@@ -184,12 +184,13 @@
- #
- AC_MSG_CHECKING(for compatible OpenSSL library)
-
--DST_PRIVATEOPENSSL='-DDST_USE_PRIVATE_OPENSSL'
--dst_privateopenssl='openssl'
--DST_OPENSSL_INC='-I${srcdir}/../openssl/include'
-+DNS_OPENSSL_LIBS="-lssl -lcrypto"
-+DST_PRIVATEOPENSSL=''
-+dst_privateopenssl=''
-+DST_OPENSSL_INC=''
- DST_OPENSSL_LIB=''
--DST_OPENSSL_OBJS='${OPENSSLOBJS}'
--AC_MSG_RESULT(using private library)
-+DST_OPENSSL_OBJS=''
-+AC_MSG_RESULT(using shared library)
-
- AC_SUBST(DST_PRIVATEOPENSSL)
- AC_SUBST(dst_privateopenssl)
-@@ -202,7 +203,6 @@
- # it as needed) if it is found.
- #
-
--DNS_OPENSSL_LIBS=""
- AC_SUBST(DNS_OPENSSL_LIBS)
-
- #