summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Palus2022-12-01 22:22:45 (GMT)
committerJan Palus2022-12-01 22:22:45 (GMT)
commit958c933ebc086e0e568bc061cb651f89213699d1 (patch)
tree4496c47e382041b4f51dbd8d4b599a490249a13b
parent9b8203d9756d0fd1ff85eb2f57ec3bbfd534b0b7 (diff)
downloadMesa-958c933ebc086e0e568bc061cb651f89213699d1.zip
Mesa-958c933ebc086e0e568bc061cb651f89213699d1.tar.gz
for %{arm} with hardfloat pass -mfloat-abi=hard to clang invoked by bindgenauto/th/Mesa-22.3.0-1
it appears that libclang preprocessing uses some minimal platform configuration which for %{arm} means soft float causing error on hard float targets: /usr/include/gnu/stubs.h:7:11: fatal error: 'gnu/stubs-soft.h' file not found panicked at 'Unable to generate bindings: ClangDiagnostic("/usr/include/gnu/stubs.h:7:11: fatal error: 'gnu/stubs-soft.h' file not found\n")', bindgen-cli/main.rs:52:36
-rw-r--r--Mesa.spec6
1 files changed, 6 insertions, 0 deletions
diff --git a/Mesa.spec b/Mesa.spec
index 47df97d..7309035 100644
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -1506,6 +1506,12 @@ freedreno broadcom imagination-experimental panfrost \
vulkan_drivers=$(echo $vulkan_drivers | xargs | tr ' ' ',')
+%if %{with gallium_rusticl}
+%ifarch %{arm32_with_hf}
+export BINDGEN_EXTRA_CLANG_ARGS="-mfloat-abi=hard"
+%endif
+%endif
+
%meson build \
-Dplatforms=x11%{?with_wayland:,wayland} \
-Ddri3=enabled \