summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2007-12-02 16:52:42 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit31a772c7930f8e027d117f69875af1e219e5ad71 (patch)
treed6007e9cb85d9113e4cb515f8c4f147f0d5961ee
parentf4a8c5f62e13dcdcdee62f4d7634d4fe46b37396 (diff)
downloadMesa-31a772c7930f8e027d117f69875af1e219e5ad71.zip
Mesa-31a772c7930f8e027d117f69875af1e219e5ad71.tar.gz
- use x86-64 targets for x86_64 assemblyauto/ti/Mesa-7_0_2-4auto/th/Mesa-7_0_2-4
- release 4 Changed files: Mesa.spec -> 1.164
-rw-r--r--Mesa.spec17
1 files changed, 12 insertions, 5 deletions
diff --git a/Mesa.spec b/Mesa.spec
index 92c5122..66c463c 100644
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -12,7 +12,7 @@ Summary: Free OpenGL implementation
Summary(pl.UTF-8): Wolnodostępna implementacja standardu OpenGL
Name: Mesa
Version: 7.0.2
-Release: 3.1%{?with_multigl:.mgl}
+Release: 4%{?with_multigl:.mgl}
License: MIT (core), SGI (GLU,libGLw) and others - see license.html file
Group: X11/Libraries
Source0: http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
@@ -608,11 +608,18 @@ sed -i -e 's/ sis / /' configs/linux-dri
%endif
%build
+# use $lib, not %{_lib} as Mesa uses lib64 only for *-x86-64* targets
+%ifarch %{x8664}
+targ=-x86-64
+lib=lib64
+%else
+lib=lib
%ifarch %{ix86}
targ=-x86
%else
targ=""
%endif
+%endif
%{__make} linux${targ}-static \
CC="%{__cc}" \
@@ -622,7 +629,7 @@ targ=""
GLW_SOURCES="GLwDrawA.c%{?with_motif: GLwMDrawA.c}" \
SRC_DIRS="mesa glu glw" \
PROGRAM_DIRS=
-mv -f lib lib-static
+mv -f ${lib} lib-static
%{__make} realclean
%{__make} linux-osmesa \
@@ -651,7 +658,7 @@ mv -f lib lib-osmesa
OPT_FLAGS="%{rpmcflags}" \
XLIB_DIR=%{_libdir} \
PROGS="glxgears" \
- APP_LIB_DEPS="-L../../lib -lGL"
+ APP_LIB_DEPS="-L../../${lib} -lGL"
%{__make} -C progs/xdemos \
CC="%{__cc}" \
@@ -659,9 +666,9 @@ mv -f lib lib-osmesa
OPT_FLAGS="%{rpmcflags}" \
XLIB_DIR=%{_libdir} \
PROGS="glxinfo" \
- APP_LIB_DEPS="-L../../lib -lGL -L../../lib-dri -lGLU"
+ APP_LIB_DEPS="-L../../${lib} -lGL -lGLU"
-mv -f lib lib-dri
+mv -f ${lib} lib-dri
# TODO: glw.pc (missing in 7.0.2 tarball)
for d in mesa glu ; do