]> git.pld-linux.org Git - projects/template-specs.git/blob - vim-plugin.spec
pecl: add example how to make failed tests as XFAIL
[projects/template-specs.git] / vim-plugin.spec
1 # TODO:
2 # - What to do with .vimup file?
3 %define         plugin  PLUGIN_NAME
4 Summary:        Vim plugin: PLUGIN_NAME
5 Name:           vim-plugin-%{plugin}
6 Version:        0.1
7 Release:        0.1
8 License:        Vim
9 Group:          Applications/Editors/Vim
10 Source0:        http://www.vim.org/scripts/download_script.php?src_id=xxx&/%{plugin}-%{version}.zip
11 # Source0-md5:  -
12 URL:            -
13 # for _vimdatadir
14 Requires:       vim-rt >= 4:7.2.170
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _vimdatadir     %{_datadir}/vim
19
20 %description
21 Vim plugin for foo and even bar.
22
23 %prep
24 %setup -qc
25
26 %install
27 rm -rf $RPM_BUILD_ROOT
28 install -d $RPM_BUILD_ROOT%{_vimdatadir}
29 cp -a . $RPM_BUILD_ROOT%{_vimdatadir}
30
31 %clean
32 rm -rf $RPM_BUILD_ROOT
33
34 %if 0
35 # if packaging doc/* files
36 %post
37 echo 'helptags %{_vimdatadir}/doc' | vim -e -s -V0 -R -n --noplugin
38
39 %postun
40 echo 'helptags %{_vimdatadir}/doc' | vim -e -s -V0 -R -n --noplugin
41 %endif
42
43 %files
44 %defattr(644,root,root,755)
45 %doc %{_vimdatadir}/doc/*.txt
46 %{_vimdatadir}/plugin/*.vim
This page took 0.036913 seconds and 3 git commands to generate.