]> git.pld-linux.org Git - projects/template-specs.git/blob - template.spec
- added webserver(cgi)
[projects/template-specs.git] / template.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %bcond_without  tests           # build without tests
5 #
6 Summary:        -
7 Summary(pl):    -
8 Name:           template
9 Version:        _
10 Release:        0.1
11 #Epoch:         -
12 License:        - (enter GPL/GPL v2/LGPL/BSD/BSD-like/other license name here)
13 Group:          Applications
14 Source0:        %{name}-%{version}.tar.gz
15 # Source0-md5:  -
16 #Source1:       -
17 # Source1-md5:  -
18 #Patch0:                %{name}-DESTDIR.patch
19 URL:            -
20 %if %{with initscript}
21 BuildRequires:  rpmbuild(macros) >= 1.228
22 Requires(post,preun):   /sbin/chkconfig
23 %endif
24 #BuildRequires: -
25 #BuildRequires: autoconf
26 #BuildRequires: automake
27 #BuildRequires: intltool
28 #BuildRequires: libtool
29 #Requires(postun):      -
30 #Requires(pre,post):    -
31 #Requires(preun):       -
32 #Requires:      -
33 #Provides:      -
34 #Provides:      group(foo)
35 #Provides:      user(foo)
36 #Obsoletes:     -
37 #Conflicts:     -
38 #BuildArch:     noarch
39 #ExclusiveArch: %{ix86}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43
44 %description -l pl
45
46 %package subpackage
47 Summary:        -
48 Summary(pl):    -
49 Group:          -
50
51 %description subpackage
52
53 %description subpackage -l pl
54
55 %package libs
56 Summary:        -
57 Summary(pl):    -
58 Group:          Libraries
59
60 %description libs
61
62 %description libs -l pl
63
64
65 %package devel
66 Summary:        Header files for ... library
67 Summary(pl):    Pliki nag³ówkowe biblioteki ...
68 Group:          Development/Libraries
69 #Requires:      %{name} = %{version}-%{release}
70
71 %description devel
72 This is the package containing the header files for ... library.
73
74 %description devel -l pl
75 Ten pakiet zawiera pliki nag³ówkowe biblioteki ....
76
77 %package static
78 Summary:        Static ... library
79 Summary(pl):    Statyczna biblioteka ...
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static ... library.
85
86 %description static -l pl
87 Statyczna biblioteka ....
88
89 %prep
90 %setup -q
91 #%setup -q -c -T
92 #%setup -q -n %{name}
93 #%%setup -q -n %{name}-%{version}.orig -a 1
94 #%patch0 -p1
95
96 # undos the source
97 #find '(' -name '*.php' -o -name '*.inc' ')' -print0 | xargs -0 sed -i -e 's,\r$,,'
98
99 # remove CVS control files
100 #find -name CVS -print0 | xargs -0 rm -rf
101
102 # you'll need this if you cp -a complete dir in source
103 # cleanup backups after patching
104 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
105
106 %build
107 # if ac/am/* rebuilding is necessary, do it in this order and add
108 # appropriate BuildRequires
109 #%%{__intltoolize}
110 #%%{__gettextize}
111 #%%{__libtoolize}
112 #%%{__aclocal}
113 #%%{__autoconf}
114 #%%{__autoheader}
115 #%%{__automake}
116 #cp -f /usr/share/automake/config.sub .
117 %configure
118 %{__make}
119
120 #%{__make} \
121 #       CFLAGS="%{rpmcflags}" \
122 #       LDFLAGS="%{rpmldflags}"
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 # create directories if necessary
127 #install -d $RPM_BUILD_ROOT
128 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %pre
137
138 %post
139
140 %preun
141
142 %postun
143
144 %if %{with ldconfig}
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147 %endif
148
149 %if %{with initscript}
150 %post init
151 /sbin/chkconfig --add %{name}
152 %service %{name} restart
153
154 %preun init
155 if [ "$1" = "0" ]; then
156         %service -q %{name} stop
157         /sbin/chkconfig --del %{name}
158 fi
159 %endif
160
161 %files
162 %defattr(644,root,root,755)
163 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
164
165 %if 0
166 # if _sysconfdir != /etc:
167 #%%dir %{_sysconfdir}
168 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
169 %attr(755,root,root) %{_bindir}/*
170 %{_datadir}/%{name}
171 %endif
172
173 # initscript and its config
174 %if %{with initscript}
175 %attr(754,root,root) /etc/rc.d/init.d/%{name}
176 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
177 %endif
178
179 #%{_examplesdir}/%{name}-%{version}
180
181 %if %{with subpackage}
182 %files subpackage
183 %defattr(644,root,root,755)
184 #%doc extras/*.gz
185 #%{_datadir}/%{name}-ext
186 %endif
This page took 0.076346 seconds and 3 git commands to generate.