]> git.pld-linux.org Git - projects/template-specs.git/blob - tcl.spec
pecl: add example how to make failed tests as XFAIL
[projects/template-specs.git] / tcl.spec
1
2 # as th tcl is broken, use rpmdb:
3 #%%define               tcl_version             %(echo 'puts $tcl_version' | tclsh)
4 %define         tcl_version             %(rpm -q --qf %{V} tcl-devel | cut -d. -f1,2)
5 %define         tcl_sitearch    %{_libdir}/tcl%{tcl_version}
6 # pld tcl doesn't use %{_datadir}
7 #%%define               tcl_sitelib             %{_datadir}/tcl%{tcl_version}
8 %define         tcl_sitelib             %{_libdir}/tcl%{tcl_version}
9
10 Summary:        Tcl TEMPLATE
11 Name:           tcl-TEMPLATE
12 Version:        0.1
13 Release:        0.1
14 License:        BSD-like
15 Group:          Libraries
16 Source0:        http://dl.sourceforge.net/tcl/TEMPLATE%{version}.tar.gz
17 # Source0-md5:  3c69b4a891590f23bb79a1fa98d879f7
18 URL:            http://tcl.sourceforge.net/
19 BuildRequires:  tcl-devel >= 8.4
20 Requires:       tcl >= %{tcl_version}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 ....
25
26 %prep
27 %setup -q
28
29 %build
30 %configure
31 %{__make}
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35 %{__make} install \
36         DESTDIR=$RPM_BUILD_ROOT
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %files
42 %defattr(644,root,root,755)
43 %doc ChangeLog README
44 %dir %{_libdir}/TEMPLATE%{version}
45 %attr(755,root,root) %{_libdir}/TEMPLATE%{version}/libTEMPLATE*.so
46 %{_libdir}/TEMPLATE%{version}/*.tcl
47 %{_mandir}/mann/*.n*
This page took 0.046268 seconds and 3 git commands to generate.