]> git.pld-linux.org Git - projects/template-specs.git/blob - ruby.spec
- updated
[projects/template-specs.git] / ruby.spec
1 Summary:        -
2 Name:           ruby-
3 Version:        -
4 Release:        0.1
5 License:        - (enter GPL/GPL v2/GPL v3+/LGPL/MIT/Ruby License/other license name here)
6 Source0:        http://rubyforge.org/frs/download.php/...
7 # Source0-md5:  -
8 Group:          Development/Languages
9 URL:            http://rubyforge.org/projects/.../
10 BuildRequires:  rpmbuild(macros) >= 1.484
11 BuildRequires:  ruby >= 1:1.8.6
12 BuildRequires:  ruby-modules
13 %{?ruby_mod_ver_requires_eq}
14 #BuildArch:     noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 # nothing to be placed there. we're not noarch only because of ruby packaging
18 %define         _enable_debug_packages  0
19
20 %description
21 ...
22
23 %package rdoc
24 Summary:        Documentation files for ...
25 Group:          Documentation
26 Requires:       ruby >= 1:1.8.7-4
27
28 %description rdoc
29 Documentation files for ....
30
31 %prep
32 %setup -q -n ...-%{version}
33
34 # gem install
35 %{__tar} xf %{SOURCE0} -O data.tar.gz | %{__tar} xz
36 find -newer README  -o -print | xargs touch --reference %{SOURCE0}
37
38 cp /usr/share/setup.rb .
39
40 # cleanup backups after patching
41 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
42
43 %build
44 rdoc --ri --op ri lib
45 rdoc --op rdoc lib
46 rm -f ri/created.rid
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir},%{ruby_rdocdir}}
51 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
52 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
53 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc CHANGELOG README
61
62 %files rdoc
63 %defattr(644,root,root,755)
64 %{ruby_rdocdir}/%{name}-%{version}
65 %{ruby_ridir}/...
This page took 0.060816 seconds and 4 git commands to generate.