]> git.pld-linux.org Git - projects/template-specs.git/blob - ocaml.spec
- added webserver(cgi)
[projects/template-specs.git] / ocaml.spec
1 Summary:        TEMPLATE binding for OCaml
2 Summary(pl):    Wi±zania TEMPLATE dla OCamla
3 Name:           ocaml-template
4 Version:
5 Release:        1
6 License:
7 Group:          Libraries
8 Vendor:
9 Source0:        template-%{version}.tar.gz
10 BuildRequires:  -devel
11 BuildRequires:  ocaml >= 3.04-7
12 %requires_eq    ocaml-runtime
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 This package contains files needed to run bytecode executables using
17 this library.
18
19 %description -l pl
20 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
21 u¿ywaj±cych tej biblioteki.
22
23 %package devel
24 Summary:        TEMPLATE binding for OCaml - development part
25 Summary(pl):    Wi±zania TEMPLATE dla OCamla - cze¶æ programistyczna
26 Group:          Development/Libraries
27 Requires:       %{name} = %{version}-%{release}
28 %requires_eq    ocaml
29
30 %description devel
31 This package contains files needed to develop OCaml programs using
32 this library.
33
34 %description devel -l pl
35 Pakiet ten zawiera pliki niezbêdne do tworzenia programów u¿ywaj±cych
36 tej biblioteki.
37
38 %prep
39 %setup -q -n template-%{version}
40
41 %build
42 %{__make} CC="%{__cc} %{rpmcflags} -fPIC" all opt
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/{template,stublibs}
48 install *.cm[ixa]* *.a dll*.so $RPM_BUILD_ROOT%{_libdir}/ocaml/template
49 install dll*.so $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
50
51 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52 cp -r foo bar $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53
54 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/template
55 cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/template/META <<EOF
56 requires = ""
57 version = "%{version}"
58 directory = "+template"
59 archive(byte) = "template.cma"
60 archive(native) = "template.cmxa"
61 linkopts = ""
62 EOF
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %attr(755,root,root) %{_libdir}/ocaml/stublibs/*.so
70
71 %files devel
72 %defattr(644,root,root,755)
73 %doc LICENSE *.mli
74 %dir %{_libdir}/ocaml/template
75 %{_libdir}/ocaml/template/*.cm[ixa]*
76 %{_libdir}/ocaml/template/*.a
77 %{_examplesdir}/%{name}-%{version}
78 %{_libdir}/ocaml/site-lib/template
This page took 0.030783 seconds and 3 git commands to generate.