]> git.pld-linux.org Git - projects/template-specs.git/blob - ocaml.spec
pecl: add example how to make failed tests as XFAIL
[projects/template-specs.git] / ocaml.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # skip building native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 %define         module  %{module}
11 Summary:        %{module} binding for OCaml
12 Summary(pl.UTF-8):      Wiązania %{module} dla OCamla
13 Name:           ocaml-%{module}
14 Version:        -
15 Release:        1
16 License:        - (enter GPL/LGPL/BSD/BSD-like/other license name here)
17 Group:          Libraries
18 Source0:        %{module}-%{version}.tar.gz
19 URL:            -
20 # Source0-md5:  -
21 #BuildRequires: -devel
22 BuildRequires:  ocaml >= 3.04-7
23 %requires_eq    ocaml-runtime
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         debug_package   %{nil}
27 %if %{without ocaml_opt}
28 %define         no_install_post_strip   1
29 # no opt means no native binary, stripping bytecode breaks such programs
30 %define         _enable_debug_packages  0
31 %endif
32
33 %description
34 This package contains files needed to run bytecode executables using
35 TEMPLATE library.
36
37 %description -l pl.UTF-8
38 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
39 używających biblioteki TEMPLATE.
40
41 %package devel
42 Summary:        TEMPLATE binding for OCaml - development part
43 Summary(pl.UTF-8):      Wiązania TEMPLATE dla OCamla - cześć programistyczna
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 %requires_eq    ocaml
47
48 %description devel
49 This package contains files needed to develop OCaml programs using
50 TEMPLATE library.
51
52 %description devel -l pl.UTF-8
53 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
54 biblioteki TEMPLATE.
55
56 %prep
57 %setup -q -n %{module}-%{version}
58
59 %build
60 %{__make} -j1 all %{?with_ocaml_opt:opt} \
61         CC="%{__cc} %{rpmcflags} -fPIC"
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
66 install -d $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71 #cp -r foo bar $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72
73 # move to dir pld ocamlfind looks
74 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{module}
75 mv $OCAMLFIND_DESTDIR/%{module}/META \
76         $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{module}
77 cat <<EOF >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{module}/META
78 directory="+%{module}"
79 EOF
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_libdir}/ocaml/stublibs/*.so
87 %dir %{_libdir}/ocaml/%{module}
88 %{_libdir}/ocaml/%{module}/*.cma
89 %if %{with ocaml_opt}
90 %attr(755,root,root) %{_libdir}/ocaml/%{module}/*.cmxs
91 %endif
92
93 %files devel
94 %defattr(644,root,root,755)
95 %doc LICENSE
96 %{_libdir}/ocaml/%{module}/*.cmi
97 %{_libdir}/ocaml/%{module}/*.cmo
98 %{_libdir}/ocaml/%{module}/*.mli
99 %if %{with ocaml_opt}
100 %{_libdir}/ocaml/%{module}/*.[ao]
101 %{_libdir}/ocaml/%{module}/*.cmx
102 %{_libdir}/ocaml/%{module}/*.cmxa
103 %endif
104 %{_libdir}/ocaml/site-lib/%{module}
105 %{_examplesdir}/%{name}-%{version}
This page took 0.056139 seconds and 3 git commands to generate.