]> git.pld-linux.org Git - projects/template-specs.git/blob - lib.spec
apache version independent config
[projects/template-specs.git] / lib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        -
7 Summary(pl.UTF-8):      -
8 Name:           ---
9 Version:        0.1
10 Release:        0.1
11 License:        - (enter GPL/LGPL/BSD/BSD-like/other license name here)
12 Group:          Libraries
13 Source0:        %{name}-%{version}.tar.gz
14 # Source0-md5:  -
15 #Patch0:        %{name}-what.patch
16 #URL:           -
17 #BuildRequires: -
18 #BuildRequires: autoconf
19 #BuildRequires: automake
20 #BuildRequires: intltool
21 #BuildRequires: libtool
22 #Requires(postun):      -
23 #Requires(pre,post):    -
24 #Requires(preun):       -
25 #Requires:      -
26 #Provides:      -
27 #Obsoletes:     -
28 #Conflicts:     -
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 # do not keep them in newly created specs
32 # these are only here to help fixing quickly broken specs
33 %define         filterout_ld    -Wl,--no-copy-dt-needed-entries
34 %define         filterout_ld    -Wl,--as-needed
35
36 # Ignore file in __spec_install_post_check_so
37 BuildRequires:  rpmbuild(macros) >= 1.583
38 %define         skip_post_check_so      libunresolved.so.*
39
40 %description
41
42 #%description -l pl.UTF-8
43
44 %package common
45 Summary:        Common files for %{name} library
46 Summary(pl.UTF-8):      Wspólne pliki biblioteki %{name}
47 Group:          Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description common
51 Common files for %{name} library.
52
53 %description common -l pl.UTF-8
54 Wspólne pliki biblioteki %{name}.
55
56 %package devel
57 Summary:        Header files for %{name} library
58 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description devel
63 Header files for %{name} library.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki %{name}.
67
68 %package static
69 Summary:        Static %{name} library
70 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static %{name} library.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka %{name}.
79
80 %package apidocs
81 Summary:        %{name} API documentation
82 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
83 Group:          Documentation
84
85 %description apidocs
86 API and internal documentation for %{name} library.
87
88 %description apidocs -l pl.UTF-8
89 Dokumentacja API biblioteki %{name}.
90
91 %prep
92 %setup -q
93 #%patch0 -p1
94
95 %build
96 # if ac/am/lt/* rebuilding is necessary, do it in this order and add
97 # appropriate BuildRequires
98 #%{__libtoolize}
99 #%{__aclocal}
100 #%{__autoconf}
101 #%{__autoheader}
102 #%{__automake}
103 %configure \
104         %{!?with_static_libs:--disable-static}
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 # create directories if necessary
110 #install -d $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 # if library provides pkgconfig file containing proper {Requires,Libs}.private
116 # then remove .la pollution
117 #%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc AUTHORS CREDITS README THANKS
128 %attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/%{name}.so.N
130
131 %files common
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_bindir}/%{name}*
134 %{_datadir}/%{name}
135
136 %files devel
137 %defattr(644,root,root,755)
138 %doc devel-doc/* ChangeLog NEWS TODO
139 %attr(755,root,root) %{_libdir}/%{name}.so
140 # if no pkgconfig support, or it misses .private deps, then include .la file
141 #%{_libdir}/libFOO.la
142 %{_includedir}/%{name}
143 %{_aclocaldir}/%{name}.m4
144 %{_pkgconfigdir}/%{name}.pc
145
146 %if %{with static_libs}
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/%{name}.a
150 %endif
151
152 %if %{with apidocs}
153 %files apidocs
154 %defattr(644,root,root,755)
155 %doc apidocs/*
156 %endif
This page took 0.062342 seconds and 3 git commands to generate.