]> git.pld-linux.org Git - projects/template-specs.git/blob - cacti-template.spec
pecl: add example how to make failed tests as XFAIL
[projects/template-specs.git] / cacti-template.spec
1 # NOTE: existing plugins http://forums.cacti.net/viewtopic.php?t=14985
2 # NOTE: existing templates http://forums.cacti.net/viewtopic.php?p=161928
3 %define         template TEMPLATE_NAME
4 %define         php_min_version 5.0.0
5 %include        /usr/lib/rpm/macros.php
6 Summary:        Template for Cacti -
7 Name:           cacti-template-%{template}
8 Version:        0.1
9 Release:        0.1
10 License:        GPL v2
11 Group:          Applications/WWW
12 Source0:        http://mirror.cactiusers.org/downloads/templates/%{template}-%{version}.zip
13 # Source0-md5:
14 URL:            http://docs.cacti.net/plugin:TEMPLATE_NAME
15 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
16 BuildRequires:  rpmbuild(macros) >= 1.554
17 # for %%undos macro
18 BuildRequires:  rpmbuild(macros) >= 1.553
19 Requires:       cacti >= 0.8.7e-8
20 Requires:       php-common >= 4:%{php_min_version}
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         cactidir                /usr/share/cacti
25 %define         resourcedir             %{cactidir}/resource
26 %define         scriptsdir              %{cactidir}/scripts
27
28 %description
29 Template for Cacti -
30
31 #%description -l pl.UTF-8
32 #Wtyczka do Cacti -
33
34 %prep
35 %setup -qc
36 %setup -q -n cacti-%{template}-%{version}
37 mv %{plugin}/{LICENSE,README} .
38
39 %undos -f php,inc
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT{%{resourcedir},%{scriptsdir}}
44 cp -a *.xml $RPM_BUILD_ROOT%{resourcedir}
45 install -p *.php $RPM_BUILD_ROOT%{scriptsdir}
46
47 %post
48 %cacti_import_template %{resourcedir}/TEMPLATE_NAME.xml
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc LICENSE README
56 %attr(755,root,root) %{scriptsdir}/TEMPLATE_NAME.php
57 %{resourcedir}/TEMPLATE_NAME.xml
This page took 0.041348 seconds and 3 git commands to generate.