]> git.pld-linux.org Git - projects/template-specs.git/blob - browser-plugin.spec
- up macros requirement for installing cross-arch packages
[projects/template-specs.git] / browser-plugin.spec
1 #
2 # NOTE: using symlinks will not have rpm file conflicts verification,
3 # but that's okay since most of the plugins are cross browser, so you
4 # won't be having any regular files in browser specific plugin dir.
5 #
6 Summary:        Template for browser plugins
7 Name:           template-browser-plugin
8 Version:        0.1
9 Release:        0.1
10 License:        GPL
11 Group:          X11/Applications/Multimedia
12 BuildRequires:  rpmbuild(macros) >= 1.235
13 Requires:       browser-plugins(%{_target_cpu})
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 # directory where you store the plugin
17 %define         _plugindir      %{_libdir}/browser-plugins
18
19 %description
20 This spec is for demonstrating triggers used for linking package
21 plugins to all browsers plugins dir capable for NSAPI plugins
22
23 See also browser-plugins.spec
24
25 %prep
26 %setup -q -c -T
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 install -d $RPM_BUILD_ROOT%{_plugindir}
31
32 cat >> $RPM_BUILD_ROOT%{_plugindir}/%{name}.so <<EOF
33 # dummy plugin
34 EOF
35 cat >> $RPM_BUILD_ROOT%{_plugindir}/%{name}.xpi <<EOF
36 # Second plugin file.
37 EOF
38
39 %triggerin -- mozilla-firefox
40 %ns_plugin_install -d %{_libdir}/mozilla-firefox/plugins %{name}.so %{name}.xpi
41
42 %triggerun -- mozilla-firefox
43 %ns_plugin_uninstall -d %{_libdir}/mozilla-firefox/plugins %{name}.so %{name}.xpi
44
45 %triggerin -- mozilla
46 %ns_plugin_install -d %{_libdir}/mozilla/plugins %{name}.so %{name}.xpi
47
48 %triggerun -- mozilla
49 %ns_plugin_uninstall -d %{_libdir}/mozilla/plugins %{name}.so %{name}.xpi
50
51 %triggerin -- opera
52 %ns_plugin_install -d %{_libdir}/opera/plugins %{name}.so %{name}.xpi
53
54 %triggerun -- opera
55 %ns_plugin_uninstall -d %{_libdir}/opera/plugins %{name}.so %{name}.xpi
56
57 %triggerin -- konqueror
58 %ns_plugin_install -d %{_libdir}/kde3/plugins/konqueror %{name}.so %{name}.xpi
59
60 %triggerun -- konqueror
61 %ns_plugin_uninstall -d %{_libdir}/kde3/plugins/konqueror %{name}.so %{name}.xpi
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %attr(755,root,root) %{_plugindir}/*.so
69 %{_plugindir}/*.xpi
This page took 0.1723 seconds and 4 git commands to generate.