]> git.pld-linux.org Git - packages/zsh.git/commitdiff
- moved from zsh.spec to the right place
authorTomasz Pala <gotar@pld-linux.org>
Tue, 30 Mar 2004 23:47:35 +0000 (23:47 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    zprofile -> 1.1
    zshrc -> 1.1

zprofile [new file with mode: 0644]
zshrc [new file with mode: 0644]

diff --git a/zprofile b/zprofile
new file mode 100644 (file)
index 0000000..1e6ec54
--- /dev/null
+++ b/zprofile
@@ -0,0 +1,5 @@
+# for login shell
+
+. /etc/profile
+setopt no_function_argzero
+setopt hist_ignore_space
diff --git a/zshrc b/zshrc
new file mode 100644 (file)
index 0000000..a5f6cec
--- /dev/null
+++ b/zshrc
@@ -0,0 +1,25 @@
+# for interactive shell
+
+alias which=whence
+alias cd='builtin cd'
+alias precmd=' precmd'
+
+bindkey -e >/dev/null 2>&1
+
+bindkey `tput khome` beginning-of-line >/dev/null 2>&1
+bindkey `tput kend` end-of-line >/dev/null 2>&1
+bindkey `tput kich1` quoted-insert >/dev/null 2>&1
+bindkey `tput kdch1` delete-char >/dev/null 2>&1
+bindkey `tput kpp` up-history >/dev/null 2>&1
+bindkey `tput knp` end-of-history >/dev/null 2>&1
+bindkey `tput kcuu1` history-beginning-search-backward >/dev/null 2>&1
+bindkey `tput kcud1` history-beginning-search-forward >/dev/null 2>&1
+
+case "$TERM" in
+       xterm*)
+               precmd () { print -Pn "\e]0;%n@%m: %~\a"i; }
+               bindkey '^[[H' beginning-of-line >/dev/null 2>&1
+               bindkey '^[[F' end-of-line >/dev/null 2>&1
+               ;;
+esac
+
This page took 0.04151 seconds and 4 git commands to generate.